PLEX slukar RAM och processorkraft

Tråden skapades och har fått 12 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Jönköping
  • 2008-12-15 12:36

Problemet hittat men inte löst!!
(gamla första inlägget hittas nedan i mindre textstorlek)

När Plex körs så slukar det i sig 130-150% av processorkraften (både enligt iStat Pro och Akvititetskontrollen) vilket medför att datorn blir otroligt seg (otroligt snabbt) samt att ledigt ram-utrymme sjunker ner till oacceptabla 4-15 Mb efter bara några få minuters användning.

Någon som också stött på detta problem och/eller vet en lösning!?

(MacBook Pro 17" C2D köpt i Nov. 2006, 4Gb DDR2 ram sedan någon månad tillbaka)

Exempel efter bara 17 min upload och några få minuters användning av PLEX:
Wired: 217 Mb
Active: 1.16Gb
Inactive: 1.60Gb
Free: 11 Mb

Senast redigerat 2008-12-15 20:37
  • Medlem
  • Örebro
  • 2008-12-15 13:19

Sök och du skall finna:

Ramet säger slurp? Vart tar det vägen?

Segheten kan bero på flera saker. Kolla dina processer om något tar anmärkningsvärt många CPU-cykler. Kan hita något där du inte har tänkt på.

  • Medlem
  • Stockholm
  • 2008-12-15 13:21
Ursprungligen av Werzion:

Vad kan felet vara?

Jag tycker att du verkar ha svara på frågan själv. Det är nog PLEX som har en minnebugg i sig och har käkat upp allt minne. För att kolla det så kan du öppna programmet Aktivitetskontroll. Markera programmet PLEX i listan och klicka på Granska i toppen. Klickal på Minne i toppen och kolla hur mycket minne programmet använder. Jag skulle titta på "Verklig minnesstporlek".

Kolla när du har startat programmet utan att ha spelat nått, spela nått, spela nått annat och kolla mellan gångerna. Mellan spela nått och spela nått annat borde det inte hända så väldigt mycket, max 40% ändring. När datorn börjar bli seg och minne börjar ta slut kolla igen. Om du allt minne används av PLEX har du fått svaret.

Lycka till

  • Medlem
  • Jönköping
  • 2008-12-15 13:22

Ahh, tack för länken!

däremot är det badboll jag får, inte jämt men saker och ting kan ta otroligt lång tid ändå. t.ex. klicka på en länk i safari...

ska inspektera CPU-cykler.

Någon annan med tips/rekommendationer?

Ursprungligen av Werzion:

Tjenare! tror inte detta problem är specifikt till det är en MacBook Pro jag sitter på, men postar här ändå (om någon mod tycker tråden passar bättre i en annan avdelning så är det bara att flytta!).

Ja, eftersom det handlar om MacBook Pro, så kan vi väl lägga det i MacBook Pro-forumet.

Flyttar tråden från "IBook, MacBook, MacBook Air"

/Mod

  • Medlem
  • Jönköping
  • 2008-12-15 13:28

God damn, PLEX kör på ca 130-150% processor !? !? !?
Verklig minnesstorlek ökar med kanske 0,5 Mb per sekund (detsamma med virtuell)
däremot Virutellt privat minne kan få sinnessjuka peaks till flertalet hundra Terabyte O_o
men oftast kring 95 Mb

Denna tråd kanske borde göras om till en PLEX-tråd!?

Ursprungligen av Jesper Ohlsson:

Ja, eftersom det handlar om MacBook Pro, så kan vi väl lägga det i MacBook Pro-forumet.

Flyttar tråden från "IBook, MacBook, MacBook Air"

/Mod

Opps, läste en rad, klickade på en annan :">

Ursprungligen av Werzion:

Denna tråd kanske borde göras om till en PLEX-tråd!?

OK, tråden flyttad (igen), och rubriken ändrad.

/Mod

  • Medlem
  • Jönköping
  • 2008-12-15 22:00

Liten update från min sida:

checka bifogade bilder:

Bild 1:
3 minuter efter omstart
processer normala
RAM okej (2,5 Gb ledigt, totalt 4 Gb)
CPU lite varm p.g.a bara omstart

Bild 2:
9 minuter efter omstart
6 minuter med PLEX igång
redan nu är processer onormala (plex på 80%, mestadels bara varit meny, någon minut simpel videoklipp, ingen direkt kvalité)
RAM, borta nästan 500 mb...

Bild 3:
16 minuter efter omstart
7 minuter ytterligare med PLEX igång
processer helt fucked up (plex på 140%... senaste minuterna har en 1080p-film varit igång)
RAM, ytterligare 500 Mb borta...

Bild 4:
27 minuter efter omstart
10 minuter till med PLEX igång
processer fortfarande helt fucked up...
RAM på låga 60 Mb...

Bild 5:
29 minuter efter omstart
bara fjuttiga 2 minuter sedan förra bilden
processer fortfarande fucked up, pendlar mellan 130-160% mestadels
RAM, ynkliga 10 Mb (ledig RAM hoppar mellan 4-15 Mb ungefär...)

Är det bara för mig som denna "psykopatiska händelse" sker iochmed Plex!?

  • Medlem
  • Stockholm
  • 2008-12-16 11:46

Blir allt bra när du avslutar PLEX? Lämnas allt minne tillbaka och går CPU:n ner i normaltakt?
/B

  • Medlem
  • Jönköping
  • 2008-12-16 12:47

Nej, det som är problemet, har jag en gång kört Plex i några minuter så måste datorn nästan startas om.
CPU går visserligen ner i normaltakt, men hela datorn är seg och badbollen dyker ofta upp, även vid simpla saker som att klicka på en länk i Safari eller öppna Hämtade Filer-mappen (med få filer i sig).

Och sedan igår har man numera dessutom uppdaterat till 10.5.6 som kom sent igår kväll/natt. Har dock inte förändrat något vad gäller detta problem.

p.s noterar nu dessutom att själva Safari drar en jäkla massa ram, ska det verkligen vara så!? enligt Aktivitetskontrollen så drar Safari nästan 500 Mb (verkligt minne) och 1,75 Gb "VSIZE" (virtuellt?)

Även om jag inte tror att ca 20 Gb är för lite hårddisk utrymme, men säkerligen skulle vara bättre med mer, så får man hoppas att när den nya externa hårddisken kommer hem och man kan tömma den interna rätt rejält, att det löser alla problem helt magiskt... *drömmer och hoppas*

*EDIT*

men va fasen är det för skumt som har hänt med min mac

Stänga av Safari, poff direkt så blev det ungefär 500 Mb ledigt RAM-minne. När jag startade Safari igen och gick in på en sida så tog det upp 40 Mb RAM direkt samt nästan 1Gb VSIZE....

  • Medlem
  • Nacka
  • 2008-12-16 21:03

Vart har du köpt minneskorten? Vad är det för märke? Hade du problem innan du uppgraderade minnet? Sätt tillbaka dom gamla minneskorten, prova om samma sak händer. Har du kvar problemen så installera om systemet! Ta backup på allt och gör en helt ren installation! Inget arkivera installera. Blås allt och se om du har kvar problemet efteråt, utan att du installerat massa program.

  • Medlem
  • Jönköping
  • 2008-12-17 08:08

Köpta och insatta av MacHuset. Så man vill ju inte tro att något är fel där.... :S

Har kollat runt och skrivit lite på plex forum, att plex tar en massa CPU-kraft verkar vara ett känt fenomen (för utvecklarna iallafall).

*EDIT*

High ram/cpu usage is a known issue or issues, the developers are busy rewriting sections of Plex. One of the side effects may be better processor usage. As to temperature I think you can lay blame for that with apple. IIRC the new line of MBPs are supposed to run cooler.

*/EDIT

Ska försöka fixa lite mer info om det hela, undviker gärna att blåsa allt, men visst, kommer det ner till att det är enda utvägen så...

p.s precis fått hem nya externa hårddisken på 1Tb, utrymmet det kommer ge på interna hoppas jag ska skapa lite julefrid (15-20 Gb borde väl vara tillräckligt, men med runt 60-80 Gb ledigt senare så är det ju en faktor att lämna ut ur beräkningarna)

  • Medlem
  • Nacka
  • 2008-12-17 13:54

Men om du har fått en extern disk så börja med att installera system på den innan du flyttar över massa grejer! Bara för att testa!!
Skulle vara intressant om den gör så fast det är ett nytt system.

1
Bevaka tråden