Problem med skärmdelning i iChat

Tråden skapades och har fått 9 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Göteborg
  • 2008-11-29 21:26

Hej!

Jag har problem med skärmdelning i iChat, någon som kan hjälpa mig?

Vid ett tillfälle har det funkat bra, fast då kändes det som att programmet inte riktigt var med på noterna ändå, för det fanns inget sätt att avsluta skärmdelningen på, fick stänga hela iChat. Det fanns alltså ingen ruta som hörde till skärmdelningssessionen.

När jag försöker dela skärm med min kompis så funkar det i en sekund, det kommer fram lite ljud och en stor grå text över hela skärmen, typ "delar skärm". Efter en sekund så kommer dialogrutan upp och säger:
Kopplade från skärmdelning eftersom:
Skärmdelning inte kunde upprättas.

Båda datorerna kör Leopard. Videochat, textchat och ljudchat funkar. Skärmdelning funkade som sagt en gång.

I Systeminställningar / Delning så har båda datorerna aktiverat Skärmdelning.

Någon som har en aning om har jag ska göra?

/Mattias

  • Medlem
  • Stockholm
  • 2008-11-29 22:59

Kan det vara så att din, eller din kompis router inte släpper igenom iChat?

Vänligen, Ylan

Prova båda två att låta brandväggen släppa igenom allt under de tio minuter ni testar, det är inget farligt.

Om det funkar då kan man behöva ge sig på brandväggens regler.

  • Medlem
  • Göteborg
  • 2008-11-29 23:38

OK, det ska jag testa. Återkommer med resultatet.

Skumt ändå att allt annat funkar ... Men routern kanske "upplever" de olika chat-lägena på annat sätt.

Tack så länge!

  • Medlem
  • Stockholm
  • 2008-11-30 10:16
Ursprungligen av tigobos:

OK, det ska jag testa. Återkommer med resultatet.

Skumt ändå att allt annat funkar ... Men routern kanske "upplever" de olika chat-lägena på annat sätt.

Tack så länge!

Dvs. iChat använder måhända olika portar för olika tjänster.

Vänligen, Ylan

  • Medlem
  • Göteborg
  • 2008-12-02 22:56

Nu funkar det ibland, det är tyvärr lite nyckfullt. Jag hittade den här listan med portar som skulle öppnas i routern:

In Mac OS X 10.4 or later, in the TCP Port Numbers field, type (you can omit 5220, 5222, 5223 if you don't use Jabber):
5190, 5220, 5222, 5223, 5298

In the UDP Port Numbers field type:
5060, 5190, 5297, 5298, 5353, 5678, 16384-16403

I ena routern kunde jag skilja UPD- från TCP-portar. I den andra hittade jag inte den valmöjligheten så jag la in alla portarna i en och samma virtuella DMZ host (vad nu det är) eller virtual server, som jag gav adress 192.168.1.180.

Båda datorernas brandväggar i Systeminställningar var avstängda när vi lyckades koppla upp datorerna mot varandra. Se'n gick det bra att slå på brandväggarna igen när det väl var gång. Fast det funkade bra bara igår. Idag lyckades vi ansluta skärmdelning (1) gång, se'n gick det inte mer. Videochat funkar hela tiden (fast inte på samma gång som skärmdelning.)

Skumt att det är så skakigt... jag hade hoppats att det var stabilare.

/Mattias

  • Medlem
  • Göteborg
  • 2008-12-02 23:20

... insåg just att adressen till den virtuella servern för iChat i min router ska vara samma som till min dator, så då var ju 192.168.1.180 fel ... Ändring och nytt försök imorgon.

Ursprungligen av tigobos:

Vid ett tillfälle har det funkat bra, fast då kändes det som att programmet inte riktigt var med på noterna ändå, för det fanns inget sätt att avsluta skärmdelningen på, fick stänga hela iChat. Det fanns alltså ingen ruta som hörde till skärmdelningssessionen.

Avslutningsmenyn tog det ett tag för mig att hitta. Denna bild kanske hjälper.

Om man inte har öppnat portar på sin router så används UPnP (Unversal Plug and Play) för att automatiskt öpppna och stänga portar på routern. UPnP stöd verkar lite dåligt i en del routers. Vad för router har ni på båda sidor av kopplingen?

  • Medlem
  • Jönköping
  • 2008-12-03 00:48
Ursprungligen av tigobos:

I Systeminställningar / Delning så har båda datorerna aktiverat Skärmdelning.

Detta är inget som har att göra med iChat - skärmdelning, det är inte det som är boven att det är aktiverat?

  • Medlem
  • Göteborg
  • 2008-12-23 12:18

Hej!

Tack för alla förslag! Nu funkar det.

Jag ändrade i routrarna på båda sidor enligt guide på www.portforward.com . Den sa i princip samma sak som de andra, förutom att den visade att man skulle gruppera UDP-portar tillsammans och TCP-portar tillsammans.
Kan det ha någon betydelse? I min router har jag bara 10 platser för Port Forwarding och det är många datorer som delar router.

Det jag tror löste problemet var att slå på UPnP i båda routrarna. Det andra känns mer tvek hur mycket det hjälpte.

Knappen för skärmdelning dök upp till slut på en av datorerna, men det verkar som att det finns en bugg där som gör att den inte alltid kommer upp.

/Mattias

1
Bevaka tråden