8-bitars SSID och Mac

Tråden skapades och har fått 26 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Södertälje
  • 2008-10-08 19:09

Är det så vansinnigt att MacOS X är enda OS som inte klarar av att ha annat än 7-bitars ASCII i SSID? Både Windows och Linux klarar av det.

/Jonas

Ja, tänk, det kanske är så vansinnigt.

  • Medlem
  • Jönköping
  • 2008-10-08 20:34
Ursprungligen av Goflorp:

Ja, tänk, det kanske är så vansinnigt.

Kan man få ett signerat idolfoto med den kommentaren?

Ursprungligen av Csoft:

Kan man få ett signerat idolfoto med den kommentaren?

Bild kan jag väl åstadkomma iaf....:)

Du kan väl ha den till att skrämma barn med eller nåt...

  • Medlem
  • Södertälje
  • 2008-10-08 19:41

OK, så när man då, som jag precis varit i 2 dagar, är på konferens på ett ställe som Kista Entré där det tillgängliga trådlösa nätverket heter just "Kista Entré" så får man klara sig utan nät om man är Mac-användare?

Ouch. Är det så illa alltså? Googlade runt lite men hittade inget matnyttigt. Någon som vet hur det ligger till?

  • Medlem
  • Helsingborg
  • 2008-10-08 20:02

Nehejdå!

Har själv SSID med både det ena och det andra i namnet. Funkar fint för både MP, MB, MBP, Globe, Cube och iPhone. Samtliga har, enligt uppgift, det häringa MacOS O:-)

Ba'fatt bevisa det så bytte jag namn på en av mina AP till det välklingande "Kista Entré"
och voila!

  • Medlem
  • Södertälje
  • 2008-10-08 19:58

Jag hittade ett par inlägg i forumen på Apple - Support - Discussions - Forum Home med samma fråga - ingen av dem är besvarad.

Men, som killen från Taiwan skrev: "Man kan ju inte tvinga alla hotell, caféer och andra som erbjuder trådlöst nätverk världen över, att ändra sina SSID till 7-bitars ASCII bara för att man har en Mac." Det är lite Microsoft över det.

Någon som vet hur man loggar en bug mot Apple? Tycker inte att Apple - Support är direkt intuitiv.

/Jonas

  • Medlem
  • Helsingborg
  • 2008-10-08 20:03
Ursprungligen av jbygden:

Är det så vansinnigt att MacOS X är enda OS som inte klarar av att ha annat än 7-bitars ASCII i SSID? Både Windows och Linux klarar av det.

/Jonas

Nej, SÅ vansinnigt är det inte!! Var har du fått det ifrån?

  • Medlem
  • Södertälje
  • 2008-10-08 20:15
Ursprungligen av Macsimal:

Nej, SÅ vansinnigt är det inte!! Var har du fått det ifrån?

Jag har fått det från att jag inte ser nätverk som innehåller 8-bitars tecken. De visas överhuvudtaget inte i listan över valbara nät. Och från det faktum att flera har ställt samma fråga i Apples egna support-forum.

Härom veckan var jag i norrland och hälsade på släktingar, deras SSID innehöll ett "ä". Efter att ha ändrat det till ett "a" så hade jag inga problem längre.

Har som sagt varit på konferens nu i 2 dagar, där SSID som sagt var "Kista Entré" - det syntes inte i listan. Det gjorde däremot övriga 5 eller 6 nät (som bara hade 7-bitars tecken i SSID) som inte var för oss gäster (lösenordsskyddade nät som tillhörde företag i huset).

Vid båda dessa tillfällen hade jag inga problem att komma åt nätet via Windows och Linux - bara Maccen vägrade att hitta dem.

/Jonas

PS. Eftersom frågan lär komma:

Powerbook G4 17" ("sista utgåvan")
MacOS X 10.5.5

DS.

  • Medlem
  • Helsingborg
  • 2008-10-08 20:28
Ursprungligen av jbygden:

Jag har fått det från att jag inte ser nätverk som innehåller 8-bitars tecken. De visas överhuvudtaget inte i listan över valbara nät. Och från det faktum att flera har ställt samma fråga i Apples egna support-forum.

Mycket märkligt
Givetvis är din upplevelse rätt, men jag har aldrig stött på problemet (och därför inte läst i supportforumen) Antog att det kanske var ett problem för MacOS att hitta ett sådant SSID (som du skrev) När jag gjorde min test så letade jag ju inte efter namnet, utan skrev in det direkt. Så när jag såg ditt svar så gjorde jag om det - och min MacOSX 10.5.5 hittar öppna SSID. Se nedan i nya exemplet O:-)

Maskinen är ju inte den senaste, kan det vara en firmware som behöver uppdateras?

  • Medlem
  • Södertälje
  • 2008-10-08 20:37
Ursprungligen av Goflorp:

Maskinen är ju inte den senaste, kan det vara en firmware som behöver uppdateras?

Det är väl inte omöjligt. Jag vet dock inte hur jag ska bära mig åt. Finns det i så fall att ladda ner från någonstans på Apple - Support

  • Medlem
  • Helsingborg
  • 2008-10-08 20:40
Ursprungligen av jbygden:

Det är väl inte omöjligt. Jag vet dock inte hur jag ska bära mig åt. Finns det i så fall att ladda ner från någonstans på Apple - Support

Jepp! Kolla här!

  • Medlem
  • Helsingborg
  • 2008-10-08 20:38
Ursprungligen av Goflorp:

Maskinen är ju inte den senaste, kan det vara en firmware som behöver uppdateras?

Ja, det är förstås möjligt att ett äldre Airport-chip inte stödjer mer än 7-bitars ASCII fastän operativet gör det...

Tänkte inte på det - en annan kör ju på nya grejor :">

  • Medlem
  • Södertälje
  • 2008-10-08 20:34

Det ser ju trevligt ut, då är i alla fall inte allt hopp förlorat... Tack för att du tar dig tid att testa!

Kan det vara relaterat till vilket språk man har inställt? Att eftersom jag har min PB inställd på engelska så beter den sig så här?

Hittade dessutom detta dokument AirPort 3.0 and later: Configuration applications don't accept high ASCII characters, det är visserligen gammalt och handlar om Airport AP men kan kanske vara relevant ändå?

/Jonas

På Apples supportsida för Apple Macbook G4 finns det en Firmware Update;
Apple - Support - PowerBook

(Kolla längst upp till höger)
men den gäller bara 550 och 667MHz...

letat igenom hela halva Apple Support.... damn!

Ngn annan som har hittat ngt?

Damn Macsimal!

Du är en bättre man än mig

  • Medlem
  • Helsingborg
  • 2008-10-08 21:09
Ursprungligen av Goflorp:

Damn Macsimal!

Du är en bättre man än mig

Njae, det vet jag inte... Det var ju du som styrde in på firmware.
Och jag som är fena på att googla

Vi är ett bra team!

Men, stödjer SSID-namn-utrop *olika teckenset då*? Vad säger standarden?

När man explicit anger en text, låt säga "Påven har en kul mössa" så kodas den olika i olika teckenset. Det finns inte bara ett sätt! Hur vet man vilket man skall använda om inte standarden specar något?

Om du har angett ett icke ASCII-namn kodat i Unicode UTF-16 hur skall jag kunna skriva in det i Extended ASCII ISO-8859?

Angående trådens rubriken kan man ändra frågeställningen - VILKEN 8-bitar-teckenkodning är standard för SSID-ar?

  • Medlem
  • Jönköping
  • 2008-10-08 21:27
Ursprungligen av ace4711:

Angående trådens rubriken kan man ändra frågeställningen - VILKEN 8-bitar-teckenkodning är standard för SSID-ar?

Ursprungligen av Wikipedia:

As the SSID is a name that may be displayed to users, it normally consists of displayable ASCII characters. However the standard does not require this—the SSID is defined as a sequence of 1–32 octets each of which may take any value.

Goflorp jag ska ta fram den till halloween

Så, då borde det fungerar när man väljer nät från menyn via en SSID-broadcast, Men, måste man skriva in nätnamnet eftersom admin inte använder broadcast på namnet kan man inte veta om det man själv skriver in blir kodat i samma teckenkodning.

jbygden, vad har du datorn inställd på för teckenuppsättning?

Macsimal, vad kör du ?

  • Medlem
  • Helsingborg
  • 2008-10-08 21:31
Ursprungligen av Goflorp:

jbygden, vad har du datorn inställd på för teckenuppsättning?

ace4711 har ju en poäng där. Det kan vara jbygdens språkinställning som spökar (han kör ju MacOS på engelska).

Ursprungligen av Goflorp:

Macsimal, vad kör du ?

Öh... var kollar jag det??

Tror problemet kan ligga här.

jbygden, vad händer om du byter tangentbordet till Svenska i maskinen? Under Systeminställningar / Internationellt.

  • Medlem
  • Södertälje
  • 2008-10-08 21:51

Just nu har jag ingen AP att testa med.

Det jag kan säga är att jag har vill ha mitt OS på engelska, men jag varierar mellan svensk och amerikansk tangentbordslayout (är UNIX-nörd i botten och vill därigenom ha amerikanskt tangentbord i terminalen). Tangentbordslayouten är det inte beroende av. Det har jag testat med både och.

Jag kan skriva nät-namnet men kan ändå inte ansluta. Ska leta upp meddelandet jag får i /var/log/system.log så ni får se vad den säger när jag försöker.

/Jonas

  • Medlem
  • Södertälje
  • 2008-10-08 22:09

Hmm,

Min AP (Linksys WRT54 GL) vägrar att acceptera ett SSID med 8-bitars tecken, så jag kan inte testa hemma.

Får testa den gamla routern (Netgear 624 eller vad den nu heter) som står hemma hos mina föräldrar någon annan dag.

/Jonas

1
Bevaka tråden