ASIO4ALL - fel utenhet vald

Tråden skapades och har fått 12 svar. Det senaste inlägget skrevs .
1

Tjenare!

Jag sitter på en laptop utan ASIO-ljudkort och vill göra lite hip hop-beats. Problemet är att när jag öppnar ASIO4ALL så finns det två ljud ut-enheter (HD Audio Headphone/Speakers och HD Audio SPDIF out) där den sistnämnda är "Running" medan headphones/speakers är "Unavailable". Vad jag gissar mig till efter att ha googlat lite är att ASIO4ALL tar den första enheten och blockar den andra. Om detta är fallet, hur kan jag då avaktivera SPDIF så att jag kan få ut ljudet i line out istället? Jag har letat i Kontrollpanelen men inte hittat nåt. Kör Vista.

Och sen värsta noobfrågan ever: vad är SPDIF out för nåt? Jag hittar inte någon annan ljudport på datorn. Jag har en Lenovo Thinkpad T61.

Tack på förhand!

  • Medlem
  • Gävle
  • 2008-08-29 16:04

Länge sen jag körde asio4all, så första frågan kan jag inte säga på rak arm. Du bör kunna byta output nånstans i asio4all iaf. Provat plugga in ett par hörlurar i jacket, kanske kan "väcka" drivarna.

SPDIF är en standardutgång för digitalt ljud iaf. Har du digitala högtalare eller stärkare kan du koppla in rakt dit, ger i allmänhet mindre brus och jäkelskap.

Tack för era svar!

Ursprungligen av Arete:

Länge sen jag körde asio4all, så första frågan kan jag inte säga på rak arm. Du bör kunna byta output nånstans i asio4all iaf. Provat plugga in ett par hörlurar i jacket, kanske kan "väcka" drivarna.

Testade det, gjorde ingen skillnad. Jag har även försökt disabla SPDIF men den vanliga utgången är fortfarande "Unavailable".

Ursprungligen av Arete:

SPDIF är en standardutgång för digitalt ljud iaf. Har du digitala högtalare eller stärkare kan du koppla in rakt dit, ger i allmänhet mindre brus och jäkelskap.

Hur ser en SPDIF-utgång ut? Jag är väldigt tveksam till huruvida jag har en sån port.

Och: finns det något lågnivåsätt i Windows att disabla SPDIF? I så fall skulle ju ASIO4ALL bara hitta line out.

Ursprungligen av jgb:

Det är inte så att vanliga ljudkortet är disablat i bios eller så?

Nej, jag använder det hela tiden när jag lyssnar på musik etc.

  • Medlem
  • 2008-08-29 16:14

Det är inte så att vanliga ljudkortet är disablat i bios eller så?

LOL, jag är sämst. Efter lite RTFM insåg jag att man skulle disabla SPDIF och starta om datorn. :S Tänkte visst inte på det! Men tack!

Hmm... tills jag startade Fruity Loops och SPDIF var tillbaka. Återkommer. Tipsa om ni vet nåt!

OK, jag ändrade det igen från Fruity Loops ASIO4ALL-instans och startade om. Det var som att FL hade sin egen ASIO4ALL-profil liksom. Men nu har jag ett svårignorerat surrande ljud i bakgrunden hela tiden, är det något som måste vara där eller som jag kan konfigurera bort på något sätt tror ni?

Och vidare: Det verkar endast kan spela in eller lyssna med ASIO4ALL-drivrutinen, men inte båda samtidigt. Skumt detta...

  • Medlem
  • Gävle
  • 2008-08-29 22:58

Det surrande ljudet är nog antagligen för att du har ett sunkigt ljudchip och/eller det störs av datorns nätadapter. Surrar det fortfarande om du drar ur adaptern och kör på batterier? Thinkpads inbyggda ljud är tyvärr ruggigt risigt, så spela in/spela upp med kvalitet är inget du kan hoppas på.

Om du inte kan spela in/spela upp samtidigt så är det antagligen för att full duplex inte är på. Ingen aning om du kan få det att fungera, det borde gå att få igång iaf (kunde köra full duplex på den sunkiga thinkpad jag hade från sandvik 2006 så).

Tack för ditt svar Arete!

Idag när jag testade var surret under helt acceptabla nivåer och jag kunde spela in och lyssna samtidigt (!). Jag vet inte med mig att jag har gjort någon ändring själv.

Har ett sista problem dock: när jag sitter med headset och spelar in så spelas även det jag lyssnar på in, även om det inte skall nå till micen. Någon aning om vad det beror på? Alla inspelade kanaler innehåller alltså alla kanaler som spelades upp samtidigt som de spelades in och det blir ett kort eko på rösten. Någon aning om vad det beror på?

  • Medlem
  • Gävle
  • 2008-08-30 11:03

Det brukar vara någon ljudkortsinställning. Du har med största sannolikhet "spela in det som spelas upp" inställt nånstans. Kolla genom inställningarna för ljudkortet (brukar finnas nåt soundmax eller sånt i kontrollpanelen), och kolla även så asio4all inte är inställt till "what you hear" på inspelningskanalen.

Ursprungligen av Arete:

Det brukar vara någon ljudkortsinställning. Du har med största sannolikhet "spela in det som spelas upp" inställt nånstans. Kolla genom inställningarna för ljudkortet (brukar finnas nåt soundmax eller sånt i kontrollpanelen), och kolla även så asio4all inte är inställt till "what you hear" på inspelningskanalen.

Jag har letat överallt men inte kunnat hitta det. Installerade Soundmax-drivrutinerna (som jag trodde var installerade) (som löste en del andra problem) men har fortfarande bara Sound-länken i Kontrollpanelen.

Bump.

1
Bevaka tråden