Problem med publicering till one.com

Tråden skapades och har fått 5 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Stockholm
  • 2008-08-22 15:21

Hej,

Jag har skapat en hemsida i Iweb 1.1.2 Jag vill nu publicera hemsidan till ett webbhotell one.com Men jag stöter på problem: typsnitt har förändras och bilder publiceras inte.

Hur jag gjort steg för steg:

Publicerat hemsidan från iweb till en mapp på datorn.

Lagt in alla html sidorna till ftp programmet cyberduck och laddat upp till one.com webbhotell

Gått in på one.com och tittat på mina upplagda sidor (här inträffar problemen med fel typsnitt och inga bilder)

Hur ska jag gå till väga för allt ska bli rätt? Vad gör jag för fel? Jag har varit i kontakt med one.com online service som säger att det blir fel i länkarna när jag publicerar från iweb till mappen på datorn. De hänvisar mig till macsupport...

Tacksam för svar!

  • Medlem
  • Göteborg
  • 2008-08-22 15:38

Har du bara laddat upp HTML filerna? Eller du kanske har laddat upp alla bilder någon gång tidigare?

Har du kollat i HTML filerna så att de t.ex. länkar rätt till bilderna så att sökvägen inte är hårdkodad?
T.ex. du har bilderna till hemsidan i /home/username/hemsidan/pictures
i /home/username/hemsidan har du dina html filer.

Om du öppnar t.ex. din html fil och så står det t.ex. där du har en bild <img src=pictures/minbild.jpg">
Står det så så länkar den ju rätt till din bild, står det t.ex. <img src=/home/username/hemsidan/pictures>
ja då blir det ju fel.

jag har också one.com, ska prova att ladda upp en sida när jag kommit hem så återkommer jag med resultat

EDIT: hur det är med typsnittena vet jag inte, men webläsare stöder väl bara ett visst antal typsnitt, rätta mig om jag har fel någon?

  • Medlem
  • Stockholm
  • 2008-08-22 15:52

Jag vore väldigt tacksam om du ville gå igenom steg för steg hur du publicerar din hemsida till one.com. Jag är ingen expert och det finns risk att mycket har blivit fel!

  • Medlem
  • Göteborg
  • 2008-08-22 15:53

Jag har aldrig använt mig av iweb innan, men jag har publicerat en del hemsidor ändå, jag ska som sagt undersöka när jag kommit hem, och förhoppningsvis kommer jag vara till någon hjälp!

  • Medlem
  • Stockholm
  • 2008-08-22 17:35

Nu fick jag det att fungera! Det var lite oklart hur jag skulle lägga upp mina filer genom ftp. Men efter att pratat med en ny support kille på one.com fungerade det! (Problemet var att index.html skulle vara för sig och sedan skulle hela mappen med webbsidan och dess filer ligga tillsammans)

Tack dock för det fantastisk snabba hjälpen.

PS Skulle aldrig hända i CP (läs PC) världen!

  • Medlem
  • Göteborg
  • 2008-08-22 22:19
Ursprungligen av hobicat:

Nu fick jag det att fungera! Det var lite oklart hur jag skulle lägga upp mina filer genom ftp. Men efter att pratat med en ny support kille på one.com fungerade det! (Problemet var att index.html skulle vara för sig och sedan skulle hela mappen med webbsidan och dess filer ligga tillsammans)

Tack dock för det fantastisk snabba hjälpen.

PS Skulle aldrig hända i CP (läs PC) världen!

Jodå, det skulle det nog allt kunna göra ska du se

Bara man har baskunskapen om HTML så ska de kvitta om det är PC eller Mac

1
Bevaka tråden