PureFTPd FTP-server kan ej nås, brandväggs problem eller vad?

Tråden skapades och har fått 8 svar. Det senaste inlägget skrevs .
1

Hejsan

Jag har installerat en PureFTPd Manager (senaste versionen) på min Mac OS X Server 10.5.4. Jag uppgraderade till 10.5.4 för några dagar sedan men redan före dess så slutade den fungera.

Jag tycker mig ha provat allting, men kan inte från min dator hemma ansluta till FTP-servern på min egen server i serverhallen. Hemma har jag provat på två olika datorer (den ena kör Airport/DHCP, den andra fast IP). Det är som om anropet från min dator inte når den. Jag får inga felmeddelanden på min sida (bara en timeout) och i ftp-loggen syns ingenting.

I min FTP-klient's transcript-fönster står:
Transmit 3.5.6 Session Transcript
LibNcFTP 3.1.9 (March 19, 2005) compiled for UNIX
Uname: Darwin|Spiderman.local|8.11.1|Darwin Kernel Version 8.11.1: Wed Oct 10 18:23:28 PDT 2007; root:xnu-792.25.20~1/RELEASE_I386|i386
Could not connect to nickfury.intelligentmammals.se -- try again later: Operation timed out.

Här är en lista på provade åtgärder och eliminerade felkällor (inget av detta hjälpte alltså):

  • Jag har på servern i terminalen anslutit till servern och kunnat konstatera att den är uppe. I PureFTPd Manager står det även running. Så här ser terminalutskriften ut:

    Last login: Wed Jul  9 22:45:05 on console
    nickfury:~ olaandersson$ ftp
    ftp> open localhost
    Trying ::1...
    Connected to localhost.
    220---------- Welcome to Pure-FTPd [tls] ----------
    220-Local time is now 14:39. Server port: 21.
    220-This is a private system - No anonymous login
    220 You will be disconnected after 15 minutes of inactivity.
    Name (localhost: olaandersson): 
  • Den inbyggda FTP-servern är avstängd i Server Admin förstås.

  • I min egen dator kör jag när jag testar med brandväggen av under Äpplet > Systeminställningar > Fildelning (i OS X 10.4.11).

  • Jag har även laborerat med min bredbandsrouter och dess brandvägg hemma (en D-Link DI 804HV) och försäkrat mig om att inget vad gäller port 20-21 är spärrat på något sätt. Eftersom jag kan nå andra FTP-servrar och logga in i dessa på samma portnummer, så borde detta visa att brandväggen hemma eller i min dator inte är problemet.

  • Jag har även tittat under inställningarna i min dator under Äpplet > Systeminställningar > Nätverk och där letat rätt på den däringa PASV-krysset och provat med det av och på. Avslutat FTP-program mellan testen och tom provat starta om min dator mellan testen. Krysset heter "Använd passivt FTP-läge (PASV)" och finns på fliken "Proxyservrar".

  • På servern har jag i Server Admin provat stänga av brandväggen helt. Har även provat starta om efter att jag gjort det.

  • Jag har i brandväggen på servern i Server Admin när den ÄR PÅ noga kollat att det är valt "Allow only traffic from 'any' to these ports:" I listan finns dessa med:

    • FTP service Port 20-21

    • FTP service - PASV port range Port 49152-65535

  • Jag har även provat att göra en Port Scan med Nätverksverktyg till min server dels på port 80-88 vilket visar att port 80 är öppen och att port scan fungerar. Jag har sedan provat att göra port scan igen mellan 20-21 och där händer ingenting.

    Port Scanning host: 195.43.255.203

    Open TCP Port: 80

  • Jag har även provat att göra en traceroute (vilket egentligen inte visar någonting eftersom jag når alla andra tjänster på samma server, webb, fildelning, ARD osv).

  • Jag har även provat ansluta på IP-numret istället för domännamnet, vilket egentligen heller inte visar något, jag får ju inga felmeddelanden alls, förutom timeouten. Hade den inte kunnat hitta domänen borde FTP-programmet ju säga det?

Finns det något mera man kan kolla som inte redan är med i denna lista? Uppskattar all hjälp!

Det verkar inte som att din fpt server lyssnar på någon port.
På servern kör kommandot:
netstat -na -f inet
En av raderna du får som output skall då se ut ungefär så här:
tcp4 0 0 *.21 *.* LISTEN
(Lyssnar på port 21 på alla interna ipadresser från alla externa ipadresser)

Egentligen är det inte ftp-servern som skall lyssna utan launchd. För att PureFTPd skall funka med launchd måste den vara kompilerad med stöd för inetd. Dessutom måste det finns en konfigurationsfil i /Library/LaunchDemons.

Jag har ingen egen erfarenhet av PureFTPd så jag vet inte exakt hur en sådan fil bör se ut, men du kan kolla på tex pure-ftpd and launchd [Archive] - The macosxhints Forums

Tack för tipset Tycho!

Har kollat nu och jag får mycket riktigt en rad som ser ut så här:

tcp4 0 0 *.21 *.* LISTEN

Men det finns ingen motsvarande rad för port 20, skall det inte finnas en sådan?

Jag har också tittat på länken du skickade, vet inte om jag törs ge mig på att pilla i sådana filer, men länken gav mig ett uppslag: Preferenserna.

Ännu ett symptom jag inte beskrivit ovan som jag just kom på, är ju att när jag försöker komma åt preferences, så står PureFTPd Manager bara och snurrar, lite senare kraschar den. Provar man igen så kan det fungera men inte alltid.

Så jag skall också testa att avinstallera och installera om PureFTPd och PureFTPd Manager. Ojdå, avinstalleraren står också och snurrar... Återkommer.

Ok, jag lämnade avinstallationen snurrande och när jag sprungit klart mina ärenden några timmar senare och den fortfarande stod och snurrade så avbröt jag avinstallationen. Den verkade ha tagit bort en hel del filer i alla fall.

Installerade om PureFTPd Manager, gjorde lite inställningar och under installationsprocessen fick jag en fråga om jag ville att PureFTPd skulle "lyssna" på på trafik utifrån och att jag om jag inte ville det kunde ändra det i datorns brandvägg senare. Jag svarade att jag ville att PureFTPd skulle lyssna och pillade in en ny användare och provade ansluta. Passive mode funkar inte, men active mode fungerar. Wow.

Så det var tydligen lösningen, avinstallera och installera om.

Fortfarande hänger sig PureFTPd Manager när jag vill titta på inställningarna och klickar runt bland ikonerna, men jag kan ansluta i alla fall, så man får väl vara nöjd med det.

Jag besökte det här problemet igen, för att det har uppstått på nytt. Jag vet inte riktigt vilken av nedanstående åtgärder som fick det hela att fungera men någon av dem var det...

* Avinstallera (man måste avbryta avinstallationen för den hänger sig) och installera igen.

* Kolla alla brandväggar på hela sträckan, min dator (av), min bredbandsrouter (tillåter FTP port 20-21), brandväggen i Mac OS X Server 10.5 Leopard (

  • FTP service Port 20-21

  • FTP service - PASV port range Port 49152-65535

* Överge Active mode helt. Dvs i min dator, ställ in Systeminställningar > Nätverk > Proxy, sätt dit krysset för Passive mode. I FTP-programmet, kolla att Passive mode används.

* I inställningarna i pureFTPd Manager, Preferences > Settings > Passive port range, ställ in exakt samma portnummer för passive mode som faktiskt står i inställningarna för brandväggen (Server Admin > Firewall > Settings > Services. Det kan vara bra, jag vet inte... (Se ovan för vilka nummer).

* Jag var också noga med att stänga av inbyggda FTP-servern och tom ta bort den från tjänster som går att konfigurera i Server Admin.

* Har fortfarande problemet med att PureFTPd manager kraschar när man tittar på inställningarna, men FTP funkar nu (igen). Vi får se hur länge det håller..

* Starta om hela servern. Har även provat upprepade gånger att starta om bara FTP-servern.

* Den där raden Tycho skrev om finns fortarande (tack igen!). Men det verkar fungera.

Såg denna artikel också, notera att om man har systemet på svenska så kanske något händer med config-filen, jag har inte det så.. Det är kommentaren jag menar i på denna sida:

macosxhints.com - 10.4: Install and use PureFTPd Manager FTP server

Senast redigerat 2008-07-27 13:13

Gjorde en systemuppdatering dag, någon säkerhetsuppdatering. Då lade FTP-servern av igen.

Lade märke till en sak nu när jag löste problemet på nytt, denna ordning är bättre:

  1. Avinstallera pureFTPd Manager först. Avinstallationen hänger sig efter några minuter, så avsluta programmet.

  2. Starta om hela servern.

  3. Installera pureFTPd Manager igen.

  4. Starta pureFTPd Manager.

  5. En guide för inställningar för pureFTPd startar, gå igenom den.

  6. Någonstans här ovan får du upp en fråga, vill du att pureFTPD Manager skall lyssna på port 21, svara ja på den.

  7. Glöm inte ställa in PASV port range i pureFTPd Manager.

Detta fungerade. När jag inte startade om emellan avinstallation och ominstallation så fungerade det inte.

Kan återigen bekräfta vad jag skrev i inlägget före detta, efter nästan varje systemuppdatering (men inte alla) så lägger PureFTP av och går ej att nås. Nu senast med 10.5.6.

Efter avinstallation (som hänger sig och behöver tvångsavslutas), omstart, ominstallation, start av PureFTPd Manager, svarat "Tillåt" på nedanstående fråga, så är det hela uppe igen.

Samma som ovan efter uppdateringen till 10.5.7.

Blivit billigare att köpa en Rumpus!

Kört uppdateringar ifrån 10.4.4 till 10.5.7 utan problem med rumpus. Finns nog inget program till Mac OS X som är så stabilt och driftsäkert!

1
Bevaka tråden