Hur installerar man om kraschad Safari i Leopard 10.5.3?

Tråden skapades och har fått 15 svar. Det senaste inlägget skrevs .
1

Hej på er,

Efter 10.5.3 så kan jag ej längre starta Safari. När man dubbelklickar så studsar den en gång sen händer det ingenting. Har letat på nätet och de flesta rekommenderar att installera om Safari men grejen är att när jar drar ner den senaste versionen så vill inte Installern installera. Det står utropstecken och säger att jag behöver Leopard 10.5.2 eller nyare.

Grejen är att jag har 10.5.3 som ska vara nyare Nu står jag utan Safari och vet ej vad jag ska göra.

Det jag har gjort är att jag har lokaliserat felet. Det är vid uppstart det strular då den visar följande:

May 31 21:06:37 BosnianX Safari[55275]: Unable to load nib file: MainMenu, exiting
May 31 21:06:37 BosnianX com.apple.launchd[187] ([0x0-0xc10c1].com.apple.Safari[55275]): Exited with exit code: 1

Efter en sökning på nätet så visar det sig att man ska installera om men som sagt det går inte.

Vissa säger att reparera behörigheter, launchd databas och rensning av loggfiler hjälper men det har jag också gjort och samma sak. Har även raderat safaris .plist fil men samma problem återstår.

Vad mer kan man göra?

Senast redigerat 2008-06-02 00:02
  • Medlem
  • International user
  • 2008-06-01 23:18

Du kan ju prova o ladda ner Mac OS 10.5.3 kombouppdateringen och installera om den. Kan ju ha hänt nåt vi uppdateringen.

Sen kan du ju kolla så det inte fungerar i en ny användare

Ursprungligen av ufred:

Du kan ju prova o ladda ner Mac OS 10.5.3 kombouppdateringen och installera om den. Kan ju ha hänt nåt vi uppdateringen.

Sen kan du ju kolla så det inte fungerar i en ny användare

Har testat att installera om uppdateringen 10.5.3 men samma sak. Safari vill ej starta.

Ska testa nu med att editera distributionen för att se om det hjälper.

  • Medlem
  • International user
  • 2008-06-01 23:23

Annars finns ju Safari att hämta här:

Apple - Safari

Ursprungligen av Konrad:

Annars finns ju Safari att hämta här:

Apple - Safari

Det är just den som inte fungerar, den vill ha 10.5.2 eller nyare och jag har 10.5.3. Ironsikt av Apple

Ska testa att installera om uppdateringen. Återkommer.

Det funkar inte med ny användare, samma sak där.

Tack än så länge.

  • Medlem
  • International user
  • 2008-06-01 23:24
  • Medlem
  • International user
  • 2008-06-01 23:25

Konrad, han sa ju att han provat det redan

Du borde kunna editera Distribution, som är ett skript som ligger med installeraren, och kontrollerar att du har rätt systemversion.

Jag tittar i filen nu, och den kontrollerar att du har 10.5.2, annars installerar den inte.

Gör så här:

Öppna paketet Safari311UpdLeo.pkg med "Flat Package Editor".

Plocka ur "Distribution".

Editera skriptet på rad 44, så att det står '10.5.3' istället för '10.5.2'.

Åter i Flat package editor, radera den gamla versionen och dra in din nya.

Nu tror jag det ska funka.

Ursprungligen av marcushedenstrom:

Du borde kunna editera Distribution, som är ett skript som ligger med installeraren, och kontrollerar att du har rätt systemversion.

Jag tittar i filen nu, och den kontrollerar att du har 10.5.2, annars installerar den inte.

Gör så här:

Öppna paketet Safari311UpdLeo.pkg med "Flat Package Editor".

Plocka ur "Distribution".

Editera skriptet på rad 44, så att det står '10.5.3' istället för '10.5.2'.

Åter i Flat package editor, radera den gamla versionen och dra in din nya.

Nu tror jag det ska funka.

Måste man installera dev tools för att köra "Flat Package Editor" ?

Ursprungligen av BosnianX:

Måste man installera dev tools för att köra "Flat Package Editor" ?

Japp det måste du.

Ursprungligen av marcushedenstrom:

Japp det måste du.

Har samma problem. För mig var det SafariSpeed som sabbade det när jag började leka med "enable brushed steel" och sånt. Vad är det för dev tools som måste laddas ner? Länk?

Senast redigerat 2008-09-23 21:13
Ursprungligen av marcushedenstrom:

Du borde kunna editera Distribution, som är ett skript som ligger med installeraren, och kontrollerar att du har rätt systemversion.

Jag tittar i filen nu, och den kontrollerar att du har 10.5.2, annars installerar den inte.

Gör så här:

Öppna paketet Safari311UpdLeo.pkg med "Flat Package Editor".

Plocka ur "Distribution".

Editera skriptet på rad 44, så att det står '10.5.3' istället för '10.5.2'.

Åter i Flat package editor, radera den gamla versionen och dra in din nya.

Nu tror jag det ska funka.

Vill bara meddela att följande tips har hjälpt. Safari is up and running. Tusen tack Marcus.

Ursprungligen av BosnianX:

Vill bara meddela att följande tips har hjälpt. Safari is up and running. Tusen tack Marcus.

Gött!

Ovanstående tog bort varningen om att 10.5.2 krävs hos mig. Har dock inte prövat att trycka på "Installera".

  • Medlem
  • Stockholm
  • 2008-06-02 00:14

Du har förmodligen något tilläggsprogram till Safari installerat som 10.5.3 inte gillar. Om du inte kan hitta och ta bort det, installera ett nytt system utan att radera din hd men behåll program och inställingar.
Joel

Ursprungligen av Joel:

Du har förmodligen något tilläggsprogram till Safari installerat som 10.5.3 inte gillar. Om du inte kan hitta och ta bort det, installera ett nytt system utan att radera din hd men behåll program och inställingar.
Joel

Nej, nuvarande versionen av Safari går inte att installera på 10.5.3 enligt installationsskriptet jag nämnde ovan.

1
Bevaka tråden