Öppna TCP port på Leopard?

Tråden skapades och har fått 10 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2008-04-18 14:32

Jag trodde först att jag blivit knasig när jag letade i en timme efter den där menyraden där man öppnar TCP portar. Men sen ha läst lite på olika forum har jag förstått att detta INTE går i Leopard. Varför de tagit bort den funktionen är för mig obegripligt. Så nu hamnar man där man absolut inte vill vara som macanvändare. Framför Terminalens fönster med text kods remsor..... Känns såååå PC.

Jag har försökt öppna en TCP port (51413) genom att knappa in följande kommando (obs jag vet inget om kod, så pröva inte nån av de koder jag skriver här, jag har bara hittat dem på forum...)

ipfw add allow tcp from 51413 to 51413

Det funkade inte... och nu kan jag inte skriva nån mer kod i Terminalen för det kommer fram en felkod som säger

ipfw: socket: Operation not permitted

Vad gjorde jag för fel? Hur blir jag permittad igen... Har jag pajat nått?

Ingen aning...
På denna sidan diskuteras lite olika syntax (i comments):
http://taisteal.atomiclemur.com/2007/10/living-with-leopards-firewall/

  • Medlem
  • 2008-04-18 15:47

Jag kom åt terminalen igen efter att ha startat om datorn... och...Ups.... såg att mitt kommando var fel.. så här ska det vara

sudo ipfw add allow tcp from xxxx to xxxx

och då måste jag knappa in mitt systemanvändar lösen, sen får jag en rad som säger...

00100 allow tcp from x.x.x.x to x.x.x.x

Men jag tror inte att det funkar. I programmet jag använder står fortfarande
xxxx "Port is Stealth"

Gör jag fel?

  • Medlem
  • Överallt
  • 2008-04-18 16:01

Eller så går du in i Systeminställningar -> Säkerhet -> Brandvägg. Kryssar i Ställ in åtkomst för specifika tjänster och program.

Lägg till din applikation och välj Tillåt inkommande anslutningar. Sen gör Leopard resten med ren magi.

  • Medlem
  • 2008-04-18 16:23

Magin uteblev.... (funkar inte)

  • Medlem
  • International user
  • 2008-04-18 19:26

Du har steralth mode ikryssat?

System preferences -> Security -> Firewall -> Advanced

Bara en tanke, vet inte om det är relaterat.

  • Medlem
  • 2008-04-20 17:01

Jag fick det att funka till slut. Men tycker nog det var lättare förut...

  • Medlem
  • International user
  • 2008-04-20 23:03
Ursprungligen av oee:

Jag fick det att funka till slut. Men tycker nog det var lättare förut...

Vad var kruxet?

Säkert någon som är intresserad av det i framtiden. Så berätta gärna vad du gjorde.

  • Medlem
  • 2008-04-21 15:00
Ursprungligen av ufred:

Vad var kruxet?

Säkert någon som är intresserad av det i framtiden. Så berätta gärna vad du gjorde.

Jag testade fram o tillbaka, starta om datorn, starta om programmet. Sen funka det helt plötsligt....

  • Medlem
  • Göteborg
  • 2008-04-20 17:14

Det finns en trevlig front-end till brandväggen, waterroof ( http://www.hanynet.com/waterroof/ ).

Personligen tycker jag att det är lite svårt med gränssnittet i Leopard över huvud taget. Därför försöker jag att hantera brandväggen enligt de instruktioner som finns på http://www.FreeBSD.org/cgi/man.cgi?query=ipfw&apropos=0&sektion=0&manpath=FreeBSD+6.3-RELEASE&format=html. Samtliga borde fungera om Leopard är fullt kompatibelt med ipfw.

EDIT; Däremot stör det mig som fasen att man inte kan ändra på standardregeln 65535 manuellt. Den kan varken tas bort med "sudo ipfw delete (nr)" eller ändras med "sudo ipfw add 65535 deny ip from any to any". Någon som har en idé om lösning?

Senast redigerat 2008-04-21 00:30
1
Bevaka tråden