åäö i nano

Tråden skapades och har fått 7 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Karlskrona
  • 2008-04-16 08:39

Någon som vet om det finns ett sätt att kunna skriva åäö i nano?

Ja, det är bara att skriva. Vad får du för resultat då du försöker?

Om det inte fungerar kan du kontrollera vilken teckenkodning du använder i Terminals inställningar. Med Unicode UTF-8 brukar man få bäst resultat.

  • Medlem
  • Karlskrona
  • 2008-04-16 13:20

Hehe, sant. Jag får såna här:


Markören hoppar till slutet av filen och skriver ett par såna tecken.
Jag har inga problem med att skriva åäö i filnamn eller så, bara i just nano.
Kör med sv_SE.UTF-8.

Senast redigerat 2008-04-16 15:22
  • Medlem
  • Ale
  • 2008-04-16 16:18

Det fungerar direkt för mig, utan några speciella inställningar. Gör du något speciellt, ssh:ar till en annan dator och kör nano på den eller nåt sånt? Kör du Leopard eller Tiger?

  • Medlem
  • Karlskrona
  • 2008-04-16 16:49

Hmm, över ssh, lokalt och över ssh till min debian-burk. På debian-maskinen blir det � och på os x (tiger) blir det vanliga ?.

  • Medlem
  • Karlskrona
  • 2008-04-17 07:45

Kollat över lite nu, jag hade visst lite olika inställningar.
I terminalens inställningar har jag Unicode UTF-8.

locale (os x):
LANG=
LC_COLLATE="C"
LC_CTYPE="C"
LC_MESSAGES="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_ALL="C"

locale (debian):
LANG=sv_SE.UTF-8
LC_CTYPE="sv_SE.UTF-8"
LC_NUMERIC="sv_SE.UTF-8"
LC_TIME="sv_SE.UTF-8"
LC_COLLATE="sv_SE.UTF-8"
LC_MONETARY="sv_SE.UTF-8"
LC_MESSAGES="sv_SE.UTF-8"
LC_PAPER="sv_SE.UTF-8"
LC_NAME="sv_SE.UTF-8"
LC_ADDRESS="sv_SE.UTF-8"
LC_TELEPHONE="sv_SE.UTF-8"
LC_MEASUREMENT="sv_SE.UTF-8"
LC_IDENTIFICATION="sv_SE.UTF-8"
LC_ALL=

Ska jag ändra locales i mac os x för att få det till att funka?

  • Medlem
  • Karlskrona
  • 2008-04-17 08:53

Ett till tillägg …
åäö blir \303\245\303\244\303\266 när jag skriver direkt i os x:s terminal.
Ssh:ar jag däremot till min debian-maskin så kan jag skriva åäö på kommandoraden, dock inte i nano.

  • Medlem
  • Karlskrona
  • 2008-04-17 09:29

Nu så! En ny fil ~/.inputrc med innehållet:
set meta-flag on
set convert-meta off
set input-meta off
set output-meta on

samt kryssa ur rutan Escape icke-ASCII-tecken i Terminals fönsterinställningar löste det hela.

1
Bevaka tråden