Plugin input sätter hela systemet ur spel!

Tråden skapades och har fått 28 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Mölndal
  • 2008-02-05 08:30

OBS!!! problemet är nu löst.

satt och skulle fixa en egen input för leopard, la den i /library/input methods och startade om enligt instruktioner.

Men det verkar som detta har satt datorn i en loop. Den hänger sig totalt och inget hjälper. Inte ens en omstart. Så jag kan inte ens ta bort filen igen.

Måste försöka ta bort den via boot dvdns terminal, men hur?

Senast redigerat 2008-02-07 08:08
  • Medlem
  • Gävle
  • 2008-02-05 09:22

Om du har en till Mac i närheten kan du använda TargetMode. Håll ner T när datorn startar. Koppla ihop Macarna med en Firewirekabel. Datorn kommer upp som en HD på den andra datorn.

  • Medlem
  • Mölndal
  • 2008-02-05 10:04

tyvärr har jag inga andra mackar i närheten bara en xp dator.

Försökte genom att logga in command-s och sedan

rm library/input.....osv

men där har man ju bara read only

  • Medlem
  • Umeå
  • 2008-02-05 10:19

När du startar i säkert läge så måste du montera om filsystemet för att kunna skriva till det.

efter att du startat skriver du följande

mount -u rw /

, därefter så kan du ta bort de filer du lagt till.

  • Medlem
  • Mölndal
  • 2008-02-05 10:27

tackar. lyckades med det fast det hjälpte inte. urk. vad ska man hitta på nu.

  • Medlem
  • Mölndal
  • 2008-02-05 10:31

går det skapa ny användare i safe mode?

  • Medlem
  • Umeå
  • 2008-02-05 10:40

Har du provat att starta från DVDn och reparera filsystemet så att alla rättigheter är som de ska?

Det går att skapa nya användare i konsoll läge.

sudo dscl . create /Users/$USERNAME
sudo dscl . create /Users/$USERNAME PrimaryGroupID 599
sudo dscl . create /Users/$USERNAME UniqueID 599
sudo dscl . create /Users/$USERNAME UserShell /bin/bash
sudo dscl . passwd /Users/$USERNAME $PASSWORD
sudo dscl . append /Groups/admin GroupMembership $USERNAME

byt bara ur $USERNAME och $PASSWORD mot lämpliga fraser.

  • Medlem
  • Mölndal
  • 2008-02-05 11:01

jag har tyvätt bara tiger skivan här, leopard har jag i sverige. Konsoll läge kommer man bara till inloggad antar jag.

  • Medlem
  • Umeå
  • 2008-02-05 11:08

Konsoll läge är det du kommer till när du startar med Command-S

  • Medlem
  • Mölndal
  • 2008-02-05 11:09

hur kommer jag åt filer i safe mode när jag har filevault aktiverat.

kan man mounta sparseimagen på något sätt?

  • Medlem
  • Umeå
  • 2008-02-05 11:24
hdiutil attach -stdinpass $IMAGENAME -mountpoint /path/to/mount/point

Detta borde montera din FV image.
om du behöver mera info använd

man hdituil
  • Medlem
  • Mölndal
  • 2008-02-05 11:43

tack för alla svar.

får upp missing image argument

skriver hdiutil attach -stdinpass $JOHAN -mountpoint /users/.johan/johan.sparsebundle

  • Medlem
  • Umeå
  • 2008-02-05 12:01

$IMAGENAME är namnet på din sparseimage i ditt fall verkar det vara johan.sparsebundle.
Mountpoint måste peka på en katalog ex /Users/johan/

  • Medlem
  • Mölndal
  • 2008-02-05 13:40

filerna forsvann verkligen inte utan verkar ligga kvar. vad ska man anvanda for kommando egentligen for att ta bort dem

rm -rf fil

Var försiktig så du kör detta kommando på rätt fil och inte en hel katalog som kanske skall va kvar, det tar bort allt rekursivt utan möjlighet att ångra.

  • Medlem
  • Mölndal
  • 2008-02-05 13:56

testade att flytta filen i commando-s mode. Filen flyttades. jag stangde av datorn och pa igen men denna gangen sa lag filen pa gamla stallet igen. maste man konfirmera eller nat for att andringarna ska finnas kvar?

Skall inte behövas. Låter skumt, hur flyttade du den?

  • Medlem
  • Mölndal
  • 2008-02-05 14:10

forst korde jag

/sbin/mount -uw /

sedan
mv library/input method/pinyin.rtf /library

sedan kollade jag ls library

och dar lag den. sedan stangde jag av datorn med power knappen och pa igen och kollade ls library och sa finns den inte dar

  • Medlem
  • Mölndal
  • 2008-02-05 14:32

nu verkar de ligga kvar nar jag korde 'logout' det sista. dock hanger sig datorn fortfarande nar jag loggar in.

  • Medlem
  • Mölndal
  • 2008-02-05 15:05

jag far inte till det med nytt anvandar konto. finns det nagat satt att logga in pa root via login dialogen

bota datorn från din installations dvd tiger eller Leopard .... stoppa in skivan och håll nere c för att tvinga datorn att botta från den ... du kan också hålla ner alt tangenten för att få en grafiskt vall vart datorn skall botta från ... när du väll botat från skivan så får du tillgång till terminalen i installations programet ...

starta terminalen där och sedan navigera till foldern ...

de vanligaste kommandorna för terminalen är
cd - tex cd .. eller cd System osv ..
tänk på att unix är känslig för stora och små bokstäver ..

rm är kommandot för att ta bort = ReMove

tänk också på att skall du ta dig till input methods foldern så skall du använda ""
så ta dig till rooten genom
cd ..
cd ..
osv ..
sedan
ls = listar folders i din katalogen du är
cd Library
cd "Input Methods"
ls

då bör du hitta filen du lagt där ..
sedan kan du använda rm komandot för att ta bort den ..

  • Medlem
  • Mölndal
  • 2008-02-05 15:44

jag har lyckats flytta den, men jag la ocksa en variant i mitt anvandar library, som ar en sparsebundle. Kommer inte at den, forsoker mounta som intrueras ovan, men det gar inte.

  • Medlem
  • Umeå
  • 2008-02-05 15:54

För att montera din sprarseimage gör du så här.

hdiutil attach [namn] -stdinpass

detta monterar din image där den brukar vara monterad.

  • Medlem
  • Mölndal
  • 2008-02-05 16:11

testade

bada far bara autentication error och jag vet at pw ar ratt

  • Medlem
  • Mölndal
  • 2008-02-05 17:17

hdiutil mount johan.sparsebundle -stdinpass

hdiutil mount users/.johan/johan.sparsebundle -stdinpass

hdiutil attach johan.sparsebundle -stdinpass

hdiutil attach users/.johan/johan.sparsebundle -stdinpass

inget fungerar far autentication error eller path error.

hmm på tal om plugin. installerade ett core image plugin paket ett tag sen. förra veckan så la macen bara av när jag använde den. först frös den sen när jag startat om med elknappen så blev det bara grått vid booten. sen testade jag starta om datorn igen, då funka det. skumt.

  • Medlem
  • Mölndal
  • 2008-02-06 17:21

hjalp!

Det maste val finnas nagat fungerande satt att montera en sparsebundle i terminalen via startdvd eller commando s lage.

Halsn johan

  • Medlem
  • Mölndal
  • 2008-02-07 08:16

Jag har nu löst problemet genom att skapa en ny användare i äpple+S läge.

Först tog jag bort input filen som jag lagt i /library/input methods

Sedan eftersom jag har filevault aktiverat var jag tvungen att skapa en ny användare i commando+s läge, logga in där, aktivera root, logga in på root, montera min sparsebundlefil, ta bort motsvarande fil som jag lagt i mitt användar bibliotek.

Ny användare skapade jag utifrån detta tips:
(http://osxdaily.com/2007/10/29/how-to-add-a-user-from-the-os-x-command-line-works-with-leopard/)

On Leopard 10.5 final, substituting “.” for the “/” works. I needed to perform software updates and other admin functions on a Mac with Leopard that I didn’t have the admin password for. Adapting the above steps allowed me to do so (thanks!). What I did:

[boot into single-user mode (hold down cmd-S during early startup)]
/sbin/fsck -fy (to verify integrity of the filesystem)
/sbin/mount -uw / (to be able to make changes to the disk)
launchctl load /System/Library/LaunchDaemons/com.apple.DirectoryServices.plist (to be able to use dscl)
dscl . -create /Users/testuser
dscl . -create /Users/testuser UserShell /bin/bash
dscl . -create /Users/testuser RealName “Test User”
dscl . -create /Users/testuser UniqueID 502 (see notes below about this)
dscl . -create /Users/testuser PrimaryGroupID 80 (I chose to make the user a member of the admin group)
dscl . -create /Users/testuser NFSHomeDirectory /Users/testuser (note this is changed from above)
dscl . -passwd /Users/testuser PASSWORD
dscl . -append /Groups/admin GroupMembership testuser
exit
[restart after Mac OS X loads or login window appears]
[log out if Mac OS X loads straight into a user rather than login window]
[log in as testuser]
[update software, enable root user, do whatever you like]

And then, when I’m ready to delete the user:
[boot into single-user mode]
/sbin/fsck -fy (to verify integrity of the filesystem)
/sbin/mount -uw / (to be able to make changes to the disk)
launchctl load /System/Library/LaunchDaemons/com.apple.DirectoryServices.plist (to be able to use dscl)
dscl . -delete /Groups/admin GroupMembership testuser
dscl . -delete /Users/testuser
cd Users
rm -rf testuser (warning: will delete any files in user home folder)
exit
[restart or shut down after Mac OS X loads]

I chose the UniqueID (502) in a way consistent with the OS: the number 5xx where xx is one greater than the number of users ever created. To figure out the best available number, before issuing the dscl commands to create the user (but after the launchctl command), I typed:
dsexport users.out /Local/Default dsRecTypeStandard:Users
more users
I then scanned the list of users to see any 5xx users and then chose the next highest one available. There was only one user on this system, so that meant 502. I then deleted the export user info file (rm users.out). (I imagine it probably doesn’t really matter what UniqueID you choose as long as it is unassigned, but I am not enough of a Unix guru to know for certain.)

Tack för hjälpen!
Frågan kvarstår om det verkligen går att montera en sparsebundle i commando+s läge.

Jag gjorde ett snabbtest, skapade en krypterad image i Disc Utility, denna lyckades jag mounta utan problem med denna rad:

hdiutil attach topsecret.dmg -stdinpass
1
Bevaka tråden