§ och < har bytt plats

Tråden skapades och har fått 9 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Lidköping
  • 2008-01-28 14:54

Sitter med en Power Mac G5 (Mac OS X Leopard) och ett Logitech Elite Keyboard och stötte för ett litet tag sedan på ett problem. § och < har bytt plats av någon anledning. Detta leder till problem, då jag knackar en del XHTML.
Nybörjare på Mac som jag är, har jag ingen som helst aning om vad detta kan bero på. Har googlat som en galning efter en lösning, men har inte hittat något.
Någon därute som varit med om detta och vet vad det handlar om?

Kolla om tangentbordslayouten ändras till engelsk eller kanske Swedish istället för Swedish Pro. Du ser detta under Internationellt -> Indatameny i Systeminställningar.

  • Medlem
  • Lidköping
  • 2008-01-28 15:20
Ursprungligen av Johan S:

Kolla om tangentbordslayouten ändras till engelsk eller kanske Swedish istället för Swedish Pro. Du ser detta under Internationellt -> Indatameny i Systeminställningar.

Tack för förslaget, men det verkar tyvärr som om det inte är det som bråkar.

Testa Systeminställningar -> Tangentbord och mus -> Ändra tangentbordstyp...

  • Medlem
  • Lidköping
  • 2008-01-28 17:48
Ursprungligen av Adrian B:

Testa Systeminställningar -> Tangentbord och mus -> Ändra tangentbordstyp...

Det finns ingen "Ändra tangentbordstyp" där. :unsure:

har samma problem, hittar ingen knapp för att ändra tangentbordstyp. Så jag är fast med mina §§§§ och °°° istället för <<< >>> när jag använder ett extern tangentbord

Ladda hem och installera drivrutinerna från tangentbordstillverkarens webbsida. Det kan finnas saker däri som göra att tangentbordet känns igen korrekt.

Ursprungligen av dialbo:

Det finns ingen "Ändra tangentbordstyp" där. :unsure:

Sex år senare råkade jag ut för samma sak, så nu kan du få svar på den frågan

Jag hade ställt in mitt tangentbord via den vanliga vägen med "inställningsassistent för tangentbord":

Men efter att ha använt "snabbt användarbyte" och ställt in tangentbordet där också blev något galet. Min ordinarie användare hade plötsligt fått tecken som < och § omkastade på tangentbordet.

Inga problem, bara att öppna Systeminställningar, gå in under Tangentbord och trycka på "Ändra tangentbordstyp..." för att göra om inställningen.

Men vänta nu, var har den knappen tagit vägen? Mycket snopen så hittade jag ingen knapp där den brukade vara. Jag började googla frågan och hittade till slut lite förslag på lösningar varav ett fungerade för mig. Jag raderade följande fil helt enkelt:

/Library/Preferences/com.apple.keyboardtype.plist

(Eller snarare, jag drog den till skrivbordet, onödigt att radera om den inte visade sig vara problemet.)

Sedan en omstart av datorn (bara logga ut/in räckte inte) för att återställa tillvaron till normal:

Tjoho!

  • Medlem
  • Karlskoga
  • 2014-02-06 07:51

Jag saknar också den knappen i inställningarna..... använder Apples trådlösa tangentbord, alla tangenttryckningar ligger dock på rätt ställe. Den inställningsknappen kanske bara ska dyka upp om man använder andra/fler tangentbord?

Ursprungligen av kenjon:

Jag saknar också den knappen i inställningarna..... använder Apples trådlösa tangentbord, alla tangenttryckningar ligger dock på rätt ställe. Den inställningsknappen kanske bara ska dyka upp om man använder andra/fler tangentbord?

Ja, jag tror det stämmer. I mitt fall är det Sculpt-tangentbordet jag recenserade förut. Det är ett PC-tangentbord så man måste fixa några detaljer innan det fungerar rätt här i Sverige (det ena är att ställa in ISO (Europeisk) tangentbordsstandard via den där knappen och det andra är att byta plats på alt och kommando, som nämns i recensionen).

1
Bevaka tråden