Terminalproblem med ssh mot Slackwareserver

Tråden skapades och har fått 11 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Bromölla
  • 2008-01-23 22:49

Hej. Behöver lite hjälp med terminalen.
Det är så att när jag sshar till min server som kör slackware och startar irssi så kan jag inte skifta mellan mina kanaler som jag brukar (alt + 1 -> i). Sen så kan jag inte skriva åäö heller, och inte kan jag se åäö heller, inget fel på servern eller irssi då jag kan köra ssh från mina andra datorer (icke macar) och se samt skriva åäö.

Samt att när jag drar igång pftp-mew och skriver nått fel, som tex password eller namn på sen server, så kan jag inte sudda ut och jag måste tabort hela siten från listan och skriva om allt (och hoppas på att det blir rätt.) för när jag försöker sudda så slänger den bara in ^? för varje gång jag kör backspace.

Någon som vet hur jag ska fixa detta? Eller alternativt en annan terminalklient som finns till macen som man kan köra?

mvh. Johan

edit: Testade att köra X11 som ligger i utilities, och nu så funkar det att sudda. jag kan skriva och se åäö. MEN, jag kan inte tabba mellan kanalerna i irssi

Senast redigerat 2008-01-23 23:22
  • Medlem
  • Stockholm
  • 2008-01-24 00:09

att du inte kan skriva åäö är för att du har fel teckenuppsättning, mest troligt kör du UTF-8 på din Linux maskin.

Sedan önskar jag dig välkommen till ett riktigt Unix system, dock räknas inte din Linux maskin till listan, Alt är inte Meta i Unix, ESC är Meta, så esc+1, esc+2 osv byter kanaler åt dig.

Sist, när du endå håller på och fixar inställningarna att passa in Linux maskin så kan du slå på "Delete key sends backspace" för att kunna sudda som du vill i terminalen.

  • Medlem
  • Bromölla
  • 2008-01-24 00:19
Ursprungligen av ntity:

att du inte kan skriva åäö är för att du har fel teckenuppsättning, mest troligt kör du UTF-8 på din Linux maskin.

Sedan önskar jag dig välkommen till ett riktigt Unix system, dock räknas inte din Linux maskin till listan, Alt är inte Meta i Unix, ESC är Meta, så esc+1, esc+2 osv byter kanaler åt dig.

Sist, när du endå håller på och fixar inställningarna att passa in Linux maskin så kan du slå på "Delete key sends backspace" för att kunna sudda som du vill i terminalen.

Får väll tacka till det då , har haft macen i ca 1månad nu, och är mäkta imponerad av den, och kan säga att jag inte kommer köpa en pc mer iaf

men hur som helst. ESC + 1 osv fixade tricket, så tack ska du ha för det. Men jag har ställt in så att terminalen enbart ska köra Latin 1, men funkar inte ändå. Eller är det kanske i systemet jag ska ändra nånstans? För jag kör ju med internationellt os, eller vad alternativet hette som man kunde välja Kör iaf engelska som språk på oset.

Och ctrl + h fixade biffen som backspace

Tack så mycket. Men nu kvarstår iaf biten med Encodingen, någon som har nått vettigt tips där? Ska även ta och testa iTerm.

  • Medlem
  • Stockholm
  • 2008-01-24 00:25

Som sagt med "Delete key sends backspace" så får du som sagt ctrl+h istället för normal delete i terminalen.

Sen är det som sagt mest troligt att du kör UTF-8 på Linux maskinen som ställer till det för dig, testa byta till UTF-8 i terminalen eller för den delen fixa Linux maskinen då irssi iaf tidigare ogillade UTF-8 skarpt och det hatas normalt på IRC ännu med då alla kör med ACII / Latin-1 etc och UTF-8 ger bara en massa ??? tecken

  • Medlem
  • Bromölla
  • 2008-01-24 01:11

ahhh. Såg att det var inne i Setings -> Advanced man valde, jag hade bara ändrat i tabben encoding ;D

haha... Jaja. Nu funkar iaf allt som det ska i den vanliga terminalen och jag är glad

Tack för hjälpen ntity

  • Medlem
  • Huddinge
  • 2008-01-24 12:27

Jag har ett liknande problem med att folk ser ? istället för åäö. Var är det alltså man ska ändra någonstans? Just nu för tillfället kör jag Ubuntu och ssh'ar till en burk som kör Gentoo. Ska införskaffa en MacBook Pro snart och köra allt genom terminalen.. Men som sagt, var någonstans ska man ändra så att andra kan se åäö? Tror att jag kör Västerländsk enconding eller vad det heter just nu.

  • Medlem
  • Stockholm
  • 2008-01-24 12:34
Ursprungligen av dayweed:

Jag har ett liknande problem med att folk ser ? istället för åäö. Var är det alltså man ska ändra någonstans? Just nu för tillfället kör jag Ubuntu och ssh'ar till en burk som kör Gentoo. Ska införskaffa en MacBook Pro snart och köra allt genom terminalen.. Men som sagt, var någonstans ska man ändra så att andra kan se åäö? Tror att jag kör Västerländsk enconding eller vad det heter just nu.

Problemet är din Linux maskin, ändra antingen tecken tabellen i systemet eller irc klienten till en som är mer kompatibel med irc.

  • Medlem
  • Huddinge
  • 2008-01-24 13:06

ntity: Det som är rätt roligt är att jag inte har fulla rättigheter på den maskinen.. Den körs via ett företag, och DE har servern hos någon.. Men om du säger hur jag kan ändra tecken tabellen i systemet så kanske jag kan göra det.. I irc-klienten (irssi) har jag ändrat till Västerländsk där också.. Eller ISO-8859-15 tror jag rättare sagt.

  • Medlem
  • Stockholm
  • 2008-01-24 14:00
Ursprungligen av dayweed:

ntity: Det som är rätt roligt är att jag inte har fulla rättigheter på den maskinen.. Den körs via ett företag, och DE har servern hos någon.. Men om du säger hur jag kan ändra tecken tabellen i systemet så kanske jag kan göra det.. I irc-klienten (irssi) har jag ändrat till Västerländsk där också.. Eller ISO-8859-15 tror jag rättare sagt.

Testa att antingen sätta miljövariabeln LC_ALL likt:

LC_ALL=ISO-8859-1 

eller så kollar du i http://www.irssi.org/documentation/settings

exempelvis:

term_charset = US-ASCII 
  • Medlem
  • 2008-01-24 14:19

Ligger den här tråden i rätt forum? Jag flyttade den hit från OSX eftesom det handlade om Terminalen.

testa

export TERM='linux'
1
Bevaka tråden