Registreras inte snabba tangenttryck hos er heller?

Tråden skapades och har fått 27 svar. Det senaste inlägget skrevs .
1

Hej!

Jag har en haft min nya MBP2.2Ghz/Leopard i typ två månader nu och jag börjar bli galen!

Jag upplever att ibland när jag skriver (dvs trycker på tangenter) så händer ingenting. Det är som att tangenttryckningar ignoreras. Har någon annan upplevt detta? Nu har jag till sist kommit på ett sätt att återskapa "bugen".

Även om ni inte har upplevt detta, skulle någon vilja vara en ängel och prova följande:

  • Öppna TextEdit

  • Ta ett finger och dra bestämt och snabbt längs med övre raden knappar på er MBP (alltså från Q till P)

När jag gör det får jag:

qwop

(Det varierar - men bokstäver försvinner!) När jag gör det på min PowerBook 1GHz/Tiger får jag alltid (oavsett hur snabbt jag drar)

qwertyuiop

Que!!? Är det inte skumt!? Vad får ni?

Jag har stängt av Slow Keys under Universal Access i System Preferences så det kan inte vara det.

mvh
/soul8o8

qwertyuioppå

jag har samma mbp som dig, haft den i en månad. har misstänkt ofta tänkt ojdå, tryckte jag så lätt på första tangenten i meningen eller varför kom inte den med? *sudda sudda tillbaka*

hittade en bugg-fixare på macs hemsida...har använt mig av den men ja..det hjälpte inte nämnvärt. jag kanske helt enkelt är lite för slö på första tangenten...

har letat lite men jag kan inte återfinna tråden där jag hittaden länken.. kanske nån annan som kommer fram till det..

har du också varit med om att muspekaren försvinner? särskilt efter sleep-mode? fått veta av en bekant att det är en bugg i leopard. de vet tydligen om det men har inte hanterat det..uppenbarligen...

Det var en känd bugg i Leopard som gjorde att tangentbordet slutade svara, men den fixades i en uppdatering (tror det är det som klarabara syftar på).

Kolla in denna tråd för mer om detta: Tangentbordet på macbook stängs av

Dock verkar dina problem vara lite annorlunda, så det kanske inte är samma sak, men det kan ju vara värt att kolla in.

Jag passar på att flytta den här tråden till forumet för MacBook Pro.

  • Medlem
  • Stockholm
  • 2008-01-15 20:19

Håller med. Sitter med samma problem. Händer mig flera ggr om dagen att tangentbordet inte hinner med. skriver jag en www adress så saknas 3 av 10 ggr ett w. Mycket irriterande.
Jag tycker ock att det blv lite bättre efter 10.5.1, men det kanske bara är jag som börjar skriva saktare...

fett störigt...

Samma tokighet här, har dock vant mig att första nedslaget är mer distinkt och det verkar hjälpa, inte för att det på något sätt är optimalt men så ligger det till.. ska läsa igenom tråden Mr Adrian hänvisar til och se om man blir klokare.

Jag upplever ibland samma sak som klarabara, att just första tangenten man trycker ner när man ska börja skriva inte "hinner med" och uteblir. Men det är bara ibland...

(Aha, snygg flytt där Adrian - sorry, jag va lite trött igår..)

Tack för era svar! Skönt!
Skulle vara jobbigt om det bara va min dator och konstigt - har inte spillt några drinkar på den här än - men samtidigt ännu tråkigare att det är fler som har så

Jag har rapporterat till Apple - få se om det händer nåt. Än så länge är bugen "open" iaf..

Jag upplever också att bara första tangenttryckningen uteblir ibland. Och jag tycker att MBPn under Leopard överhuvudtaget beteer sig skumt vad gäller gå in och ur sleep-mode. Min gamla PowerBook tar alltid typ 0,5sek att vakna - MBPn kan ta flera sekunder ibland. Har för mig att det blev bättre när jag stängde av BlueTooth.

Jag misstänker att Apple har försökt lägga in nån slags anti-feltryckningsgrej - så att om man råkar trycka på två tangenter "samtidigt" (dvs inom en mikrosekund typ) ska bara en registreras. Hur låter det som teori?

hi-5!
/soul8o8

update:

den här bugen med att första tangenttrycket inte registreras är tydligen fett me stor och har gått o blivit politiskt: http://petergabriel.dk/mbp.html

hittade det här angående att tangenttryck "missas": http://episteme.arstechnica.com/eve/forums/a/tpc/f/8300945231/m/916004267831

det verkar som att det kan bero på dåliga tangentbord helt enkelt - att om man inte trycket ned knapparna rakt uppifrån typ funkar de inte.

Om jag trycker mitt-i-mellan vissa knappar så händer faktiskt ingenting alls!! t.ex om jag trycker precis mitt-i-mellan J och K (alltså båda samtidigt) på ett visst sätt händer nästan inget alls!!!

Så här: jjjjjj

Ni ser, jag tryckte kanske 10 ggr på både J och K.

ok,
hej
/soul8o8

  • Medlem
  • Kalmar
  • 2008-01-16 20:00

hej!
Jag upplever samma problem på min mbp2.2, 15t, missar massa bokstäver, trodde att det är fel på mig men nu känns det bättre om jag inte är ensam.
hälsn
/janiec

Hej!
Jag kommer inom en vecka eller två köpa min första MBP så jag har följt den här tråden med stort "intresse".
Det jag undrar är om problemet avhjälps av ett externt tangentbord? Alltså, är det tangentbordet i MBPn som är knasigt eller i mjukvaran någonstans?
tack,
eric

  • Medlem
  • Kalmar
  • 2008-01-18 00:04
Ursprungligen av s340addict:

Hej!
Jag kommer inom en vecka eller två köpa min första MBP så jag har följt den här tråden med stort "intresse".
Det jag undrar är om problemet avhjälps av ett externt tangentbord? Alltså, är det tangentbordet i MBPn som är knasigt eller i mjukvaran någonstans?
tack,
eric

Hej Eric! Jag tror att det mera mekaniskt åkomma för att min gammal iBookG4 känns tydligt mjukare i tangenterna och jag gör inte så ofta fel i det jag skriver. Men har inte testat med externt tangenbort.
/janiec

  • Medlem
  • Kalmar
  • 2008-01-18 00:17

... och jag menar inte alls att det hela med tangentbordet förhindrar användande (mera kosmetiskt grej i ergonomin) kanske räcker det att man har lite "tyngre fingrar" eller sitter bekvämare
/janiec

Jag har ett externt BT-tangentbord också - det funkar utmärkt! (oh mama det är fint.)

Vidare har jag upptäckt följande: om jag trycker ute i kanterna och hörnen på knappar så svarar de ibland inte! Jag kan hitta "sweetspots" där en knapp sällan svarar. Detta är uppenbarligen hårdvarurelaterat. (Igen, PowerBooken - inga problem.)

Apple har svarat på min bugreport, yay! (efter att jag fyllt i alla sätt jag kommit på hur man kan reproducera problemet) och de säger att det verkar vara hårdvarurelaterat och jag borde gå till Genius Bar. Jag vet inte ens var den syltan ligger, och jag förstår inte hur öl ska lösa problemet

Nu håller jag på och dividerar med butiken där jag köpte MBPn. Återkommer.

hi-5!
/soul8o8

Ang. att första tangenttryck inte registreras - hittade följande rätt intressanta inlägg som påstås komma från nån som faktiskt jobbar på Apple:

http://discussions.apple.com/message.jspa?messageID=6283475#6284079

Förresten, jag hoppas att ni skriver till Apple om ni upplever problem med era datorer!? Ju fler som skriver desto större är chansen att problemet får högre prioritet än "Word-Gemet försvinner ibland!"-bugen

ciao!

ny uppdatering från Mac idag! tror jag?

keyboard-firmware, adresserar det faktum att första tangenten inte kommer med när man börjar skriva när datorn varit idle...tjohooo

hoppas de kommer upp med något för att få min MBP att vakna på riktigt när jag öppnar den..för det verkar som om ifall den vaknar av att man rör på musen fast locket är stängt och sen får somna om så vaknar den inte alls när man öppnar locket, oavsett mus och tangent-rörelser..

  • Medlem
  • Sundsvall
  • 2008-02-23 11:20
Ursprungligen av klarabara:

ny uppdatering från Mac idag! tror jag?

keyboard-firmware, adresserar det faktum att första tangenten inte kommer med när man börjar skriva när datorn varit idle...tjohooo

hoppas de kommer upp med något för att få min MBP att vakna på riktigt när jag öppnar den..för det verkar som om ifall den vaknar av att man rör på musen fast locket är stängt och sen får somna om så vaknar den inte alls när man öppnar locket, oavsett mus och tangent-rörelser..

Vad för MBP har du?

jag har samma problem med min nya 2.6 mbp
jag håller på att bli galen

det kom ju en fix för precis det här igår...!
hos mig är i alla fall problemet borta.

kör programuppdateraren!

  • Medlem
  • Bollnäs
  • 2008-02-21 07:57

Det som diskuteras i tråden är helt klart hårdvarurelaterat, hos mig är det främst a-tangenten som strular. Trycker man för löst eller inte precis i mitten av tangenten händer ingenting. Grymt irriterande.

  • Medlem
  • Ale
  • 2008-02-21 13:32

Har ett liknande problem med min MBP (2.2 GHz, MacBookPro3,1). Den registrerar bara en 90-95% av alla tangenttryckningarna, ibland ännu färre, vilket tenderar att bli irriterande även efter bara lite skrivande. Massa ord saknar bokstäver jag vet att jag skrivit. (Har gjort tangetbordsuppdateringen från software update.)

  • Medlem
  • Göteborg
  • 2008-02-21 15:28

Uppdateringen fixade problemet för mig. Puh! Har varit två jäkligt irriterande månader...

  • Medlem
  • International user
  • 2008-02-21 23:47

Ahh vad trevligt! Jag har fått mindre spel på min maskin pga. det här tangentbordsproblemet. Hoppas att det är ur världen nu!

*drar igång programuppdatering...*

ny firmware-update igen!?

aja, *installerar*

MBP 2.2ghz inköpt i mitten av december 07

jaghar mitt problem kvar är det någon annan??

  • Medlem
  • White Beach, Puerto Galera
  • 2008-03-05 16:06

Jg Föstr int ad i enar.:)

i början tänkte jag att det hade blivit värre (när jag väl hade lyckats installera uppdateringen..) men nu känns det ganska bra faktist..kanske har lärt mig vilket tryck jag ska ha på tangenterna också?

1
Bevaka tråden