CUPS slutat fungera på 10.4.11 PPC

Tråden skapades och har fått 8 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2007-12-20 15:51

Hej,

Min far har precis uppgraderat till 10.4.11 och cups verkar ha slutat och fungera.
När man försöker lägga till en skrivare möts man av "server-error-service-unavailable"

Försöker jag sparka igång cups manuellt får jag:
xxxx:/etc/cups Bengt$ sudo cupsd
dyld: Symbol not found: _cupsFileRead
Referenced from: /usr/sbin/cupsd
Expected in: /usr/lib/libcups.2.dylib

Så något har gått åt helvete med cups.
Jag har reparerat skivbehörigheter och försökt starta om cups och datorn.
Jag kommer heller inte åt cups admin via localhost.

Dra ner "Mac OS X 10.4.11 Combo Update (PPC)" uppdateringen och installera om den igen.

http://www.apple.com/support/downloads/macosx10411comboupdateppc.html

edit: Senaste Security Update 2007-009 (10.4.11 PPC) innehåller ju också ändringar för CUPS...

http://www.apple.com/support/downloads/securityupdate200700910411ppc.html

Nu har Apple lagt ut en uppdatering utav säkerhets uppdateringen...

Kanske problemen med CUPS försvinner
Security Update 2007-009 1.1 (10.4.11 PPC)

http://www.apple.com/support/downloads/securityupdate20070091110411ppc.html

  • Oregistrerad
  • 2007-12-23 12:21
Ursprungligen av o z o n e:

Nu har Apple lagt ut en uppdatering utav säkerhets uppdateringen...

Kanske problemen med CUPS försvinner
Security Update 2007-009 1.1 (10.4.11 PPC)

http://www.apple.com/support/downloads/securityupdate20070091110411ppc.html

Ska testa, vore skönt o slippa dra hem 300M igen

  • Oregistrerad
  • 2007-12-23 17:58

Gick inge vidare, ingen skillnad. Måste man installera om? Fråga på Apple forums?

Kolla vad Printer Setup Repair kommer fram till.
http://www.macupdate.com/info.php/id/8070/printer-setup-repair

  • Oregistrerad
  • 2007-12-26 16:15
Ursprungligen av Matrix:

Kolla vad Printer Setup Repair kommer fram till.
http://www.macupdate.com/info.php/id/8070/printer-setup-repair

Mums! Trevligt program. Jag drog bara igång det och sen fungerade alls. Det verkade som den lyckades starta Cups (vilket jag inte lyckades med). Så nu fungerar det o jag slapp en ominstallation såhär i jultider

  • Medlem
  • International user
  • 2007-12-26 21:39

Du kan skriva localhost:631 i din browser så kommer du åt cups inställningarna. Fast om CUPS inte startar går det inte. Bra att Printer Setup Repair verkar ha fungerat för dig.

//Rob

  • Oregistrerad
  • 2008-02-10 23:33

Fast det slutade att fungera nu igen.

Fattar inte riktigt vad som är fel, har tittat på launchctl och försökt se vad som är fel. Jag har cups där och det borde gå igång. Men det gör det inte.

Kör jag en sudo cupsd så hoppar allt igång och är frid o fröjd. Men den vill inte gå igång automatiskt (Så den försvinner efter en reboot). Blir helt galen.

Vet att jag installerat cups manuellt och det har fungerat fint. Dock vid en uppgradering (10.4.11) så slutade det fungera. Måste jag försöka att avinstallera cups (Det jag manuellt installerade)?

Såhär säger loggen:
launchd: org.cups.cupsd: exited with exid code:1
launchd: org.cups.cupsd: 9 more failures without living at least 60 secounds will cause job removal
launchd: org.cups.cupsd: failed to checking

1
Bevaka tråden