hal.dll fil saknas vid uppstart av xp

Tråden skapades och har fått 45 svar. Det senaste inlägget skrevs .

Hej! Jag vet att detta är ett mac fourm men jag vet inte riktigt vart jag ska vända mig.. När jag startar upp min MB XP partion så saknas hal.dll och det är så varje gång jag installerar/formaterar om den partionen. Hur ska jag göra för att installationen och sedan uppstarten skall lyckas? Vista går att installera och har testat både ntfs och fat32 som filsystem för xp partionen.

tacksam för hjälp Filip

HAL.DLL filen är den som identifierar din hårdvara på datorn. Om den fattas Varje gång du installera så är det verkligen nått väldigt fel på din skiva.
Dock kan du testa att starta upp skivan i återställningsläge och försöka köra fixmbr och fixboot och för att se om det fungerar.
Eller göra en ominstallation på den nuvarande och hoppas på att det ska komma tillbaka.

Okej.. Det lät ju inte så bra, grejen är att jag testat med 4 olika skivor nu, och alla sp2 pro.
Ja de kan jag ju göra, du menar "reparera installation" eller vart går jag inte i återställnings läget?

tack för svar!

  • Medlem
  • Stockholm, Sweden, Sweden
  • 2007-11-28 20:12

Möjligen fel - edit:
*******
Det händer när du installerat Parallells och startat upp i "rent" XP-läge efter att du först startat i Parallels. Lösning: precis när du startar upp (i "rent XP-läge") så flimrar ett val förbi där du kan välja mellan "Parallels configuration" och "XP-configuration". Parallels är förstahandsvalet. Tryck pil ner kvickt i början, så att du väljer XP-configuration. Felet kan komma någon gång till, men försvinner efter några gånger. Du kan också behöva tramsa med att omregistrera XP hos Microsoft i bägge lägena (eftersom "större hårdvaruförändring har skett" - vilket är nys såklart). Det är dock aldrig några problem med att validera XP igen...
********

Senast redigerat 2007-11-28 23:52
  • Medlem
  • Gävle
  • 2007-11-28 20:33

Nej nej, såhär ligger det till.

Jag gissar att du kör Boot Camp i Leopard wilhelmsson?
Det är en bugg i Boot Camp som innebär att Boot Camp inte formatterar Windowspartitionen på rätt sätt, och när man då installerar XP och kommer till "steg 2" - dvs efter första omstarten - så kommer det där meddelandet upp.

Lösningen är att göra följande:

1. Ta bort Boot Camp-partitionen med Boot Camp. (dvs. återgå till "grundläge").
2. Kör Boot Camp-assistenten och skapa din Windowspartition.
3. Stoppa i XP-sivan och starta om.
4. I första "menyvalet" i XP-installationen får du frågan om du vill Installera, Reparera eller Avbryta. Tryck R för att reparera.
5. Väl inne i Recovery Console (Återställningskonsolen?) ska du nu formattera partitionen "på riktigt".

Kolla först så att C: verkligen är din Boot Camp-partition genom att skriva komandot diskpart och trycka på enter. Då visas en lista på partitioner, och den som Boot Camp-assistenten skapade ska vara märkt med C: som enhetsbokstav.

Sedan skriver du:
format c: /q /fs:fat32

Partitionen raderas. Nu kan du starta om datorn (håll ner strömknappen i 4 sek) och hålla ner C-tangenten för att återigen komma in i XP-installationen. Väl där fortsätter du som vid en vanlig XP-installation.

Lycka till.

tack mbp det ska bli intressant och testa:)

Filip

  • Medlem
  • Stockholm, Sweden, Sweden
  • 2007-11-28 23:52

mbp har säkert rätt. Faktum kvartår emellertid att jag haft identiskt felmeddelande när Parallels hängt sig och jag varit tvungen att göra en "fulstart" med påknappen. Då har den inte hittat dll-filen, men det har löst sig genom "tricket" ovan...

  • Medlem
  • Gävle
  • 2007-11-29 00:38

Stämmer det också William. Men just vid en nyformatterad partition har inte Parallels med saken att göra

Hej igen, jag har nyss formaterat och installerat som du hjälpte mig med
mbp.
Tyvärr så har jag problem, när jag startar upp windows så kan jag
välja att "boota" från cd, jag väljer inte det och får meddelandet: disk error, press any key to restart. Vad tror su det kan betyda?

Edit:när jag startar upp windows utan cd i får jag samma
"error" plus: no bootable device. Insert boot disk and press any key

Otroligt tacksam för hjälp/ Filip

  • Medlem
  • Gävle
  • 2007-12-03 20:38

Jadu, bra fråga.
Jag skulle prova att göra om alltsammans, men att välja att formattera i Windows-installationen. (Om du inte gjorde det, alltså)
Dvs, välja inte "Behåll det aktuella filsystemet" utan formattera den igen.

Annars vettefan. :-/

Enda gånger jag har varit med om sådana där problem så har det varit när Windows skivan har varit korrupt.

Tack så mycket mbp.

Jag ska testa med en original skiva i veckan. Jag har haft mina misstankar om att det är det som är problemet men när jag använde tiger så har bootcamp installation med windows xp funkat flytande.
Kanske är något med leopard, who knows.
Återkommer med resultat:)

Tack //Filip

Irriterande det här är. Har samma problem.
Till en början fick jag upp "diskfel", efter att formaterat i Windowsinstallationen med alternativet FAT32, långsam, så kommer jag lite längre.
Men den här gången är det hal.dll som jävlas med mig.

Såg i en annan tråd(http://www.99.se/windows-pa-mac/223765-windows-bootcamp-installationsproblem.html?highlight=diskfel), mbp, där du länkat till http://discussions.apple.com/thread.jspa?messageID=5729521, enligt trådskaparen fungerar det dock bara om man väljer 32gb alternativet, så road av windows är jag inte så att jag allokerar nästan hälften av min hårddisk för ändamålet.

Man får väl ha lite is i magen och hoppas att de fixar det här.

  • Medlem
  • Gävle
  • 2007-12-04 22:30

Borde funka med mindre också. Grejen är väl att inte välja mer än 32GB.

Jag har nu testat att installera Windows Vista vilket fungerar utmärkt, någon som har någon teori om varför det går att installera Vista men inte Windows Xp sp2?
Jag har testat på en macbook, mac mini intel, imac intel nu och får samma problem på alla och har testat med 6 olika skivor nu.
Hjälp?!

/Filip

  • Medlem
  • Stockholm, Sweden, Sweden
  • 2007-12-06 14:29

XP-installationsproblem enl ovan; Jag valde formattera med NTFS på den blåa skärm som kommer en bit in i XP-installationen (INTE "snabb" - utan "riktig" formattering) och slapp då problemet.

aha. Jag ska testa det genast, återkommer med resultat:)

Hej igen, jag testade precis att formatera windows disken i NTFS "långsam" och det går ändå inte att installera XP, dock går det att installera Vista enkelt som en plätt, what's the deal!??!

  • Medlem
  • Göteborg
  • 2007-12-15 12:32

Jag har också exakt samma problem (hal.dll saknas). Enligt rekommendation från Apple (BootCamp-manualen) så skulle man först formatera disken med BootCamp-verktyget och sedan formatera disken på nytt med XP-skivan. Jag vill köra FAT (med NTFS kommer ju inte OS X åt disken).

Provat flera skivor och gjort ominstallationer flera gånger. Är inte särskilt sugen på att prova sista lösningen på http://www.kellys-korner-xp.com/xp_haldll_missing.htm (plocka ur disken och reparera i en annan dator).

FAT-partitionen går inte mounta heller, annars kunde man ju justerat filerna från OS X.

Går nu över till att testa med NTFS.

Jag har idag pratat med både apple support och microsoft. Apple vet ingenting om detta problem och vidarebefordra mig till microsoft som inte vill hjälpa mig eftersom jag kör på en mac.
Antar att jag sitter i Skiten!!!!!!
NTFS ska tydligen inte fungera med xp på mac.
Efter att bootcamp partionerat en partiton så ska man enligt mac support formatera om partitonen till FAT32 för att det ska fungera, konstigt!?

  • Medlem
  • Göteborg
  • 2007-12-28 21:02

Detta är en känd bugg i leopard, kolla bara supportforumet hos apple, det svämmar med trådar om detta (även jag har samma strul). Dock funkar vista utmärkt att installera, men ej XP.

Jag har inte grottat nåt mer i detta de senaste veckorna, men tänkte ge mig på det ikväll igen, återkommer om jag hittar en fix/workaround.

mvh
b0bben

Hej bobben, okej! Är det någon som lyckats komma förbi buggen?
hoppas du fixar det så du kan berätta för mig hur du gjorde;)

MVH Filip.

Kan denna bugg ha lösts i 10.5.1?

Jag har funderat lite, är det möjligt att denna xp bugg har lösts i 10.5.1??

Ursäkta svordomen men FY FAN VA gött. jag installerade 10.5.1 och nu funkar xp på datorn.. NAJS

Senast redigerat 2008-01-10 17:27

Hej, har senaste versionen av leopard på min nya iMac. Vill installera Win XP sp2 på en NTFS partition i storleken 95GB. Kör boot camp sen så väljer jag att radera partitionen via windows installationsprogrammet, därefter formaterar jag om den till NTFS (ej quick format). Får sedan fel på hal.dll. Vid vilka konfigurationer har ni lyckats med era installationer.

Har samma fel som dig med min nya Imac! Blir fan galen! suttit i 6 timmar med detta nu!
Installerat på 3 andra Macar nyligen. Men på Imacen funkar det fan inte! =(
Lyckades ifall jag deleta partionen på 200 mb men det fuckar ju upp systemet för OSX.
Så nu håller jag på att installera om hela OSX igen. Prövat med att försöka installera
en äldre ver. av Leopard som följde med min Macbook Pro men det blev bara
grå skärm med anvisningen att starta om datorn hela tiden. Så det funkade inte heller

HJÄLP!!!

Tror jag har löst problemet nu! Phew trött som fan. Berättar mera om mina experiment imorgon!

Update:

- Installera om hela OSX 10.5.2. Undvek att uppdatera.
- Körde igång Bootcamp och partionerade HD'n
- Körde igång XP SP2 skivan

- Nu till det viktiga. Valde att bara installera på C: partionen
och gick vidare UTAN att ta bort partionen, skapa ny partition,
formatera till NTFS. När du sedan går vidare får du upp valen att installera på FAT32 eller NTFS. DÄR valde jag alternativet NTFS Quick format.

Sedan har det bara fungerat än så länge!
Inga missing hal.dll !

Hoppas detta funkar för andra.

Senast redigerat 2008-06-14 11:57

Tackar för infon. Kan du lista lite tydligare vilka olika partitioner du har efter att du startat om efter Bootcamp formateringen. Du säger att du har en c-partition, sen går du vidare utan att ta bort den, istället så väljer du att skapa en ny partition. Skapar du en ny partition av c? Kan man verkligen gör det utan att ha raderat partitionen som redan är där?

Jag har 4 partioner listade när den första "blå rutan" dyker upp i XP's installationsprogram.
Jag valde helt enkelt att bara installera på C: i första steget. Dvs ingenting i den "första
rutan". När man valt att installera på C: så går installationen vidare... och där i "steg 2"
dyker flera alternativ upp som gör att du kan välja att formatera som NTFS tex.

Jag skapar alltså INTE någon ny partion.

Det verkar som om det händer något ifall man väljer att göra om partionen till NTFS etc.
i det första steget. Dvs den pajar de 2 små-partioner som behöves för Bootcamp.

Detta funkade för mig. Vet inte ifall det kan ha nått att göra med att jag inte
uppdaterade OSX till 10.5.3. Dvs att jag körde Bootcamp genom 10.5.2.

Måste ta o tacka drifter7508, hans beskrivning fungerade nämligen klockrent. När jag sedan gick vidare och installerade Parallells och på så sätt kom åt min Boot Camp installation inifrån OS X blev jag grymt nöjd. Har nu en oslagbara datormiljö iom min 3 GHz intel iMac. Hur fräckt är det inte att i OS X dra igång XP i Parallels för att där accessa min OS X disc och mounta en iso fil. Sedan när man väntat på att installation blivit klar boota om i XP och lira loss!

Bevaka tråden