ClamXav rapporterar virus

Tråden skapades och har fått 9 svar. Det senaste inlägget skrevs .
1

Installerade ClamXav och körde en virusscanning...
Och fick upp ett meddelande om infekterade filer..?
Stod även något om oversized zip...?

Någon som kan tala om för mej vad jag ska göra?
Hehe!

Tack på förhand!

//Cattis!

  • Medlem
  • International user
  • 2007-11-23 15:24

ClamAV FAQ så står det :

Citat:

I get many false positives of Oversized.zip
Whenever a file exceeds ArchiveMaxCompressionRatio (see clamd.conf man page), it’s considered a logic bomb and marked as Oversized.zip . Try increasing your ArchiveMaxCompressionRatio setting.

Du kan öppna clamd.conf filen som ligger i /usr/local/clamXav/etc/ och ändra ArchiveMaxCompressionRatio till 0 jag tror 250 är standard värdet.

Spara och starta om ClamXav.

//Rob

Hmm...okej...
Men...jag hittar inte den filen?
Har sökt efter den, men utan resultat...
O har letat igenom varenda mapp i hela datorn tror jag..:S

Vettefasen va det är frågan om riktigt...hehe!

Något mer tips?

Tack för det snabba svaret!!

Mvh Cat!

  • Medlem
  • 2007-11-23 18:42

Spotlight lär inte hitta den. Har du tittat i sökvägen som beskrivs av Robo-X?

Har testat alla sökvägar som går tror jag..
Men som sagt..utan resultat..:(

  • Medlem
  • International user
  • 2007-11-23 18:55

Använde du Terminalen eller Findern?

//Rob

Finder...

  • Medlem
  • International user
  • 2007-11-24 00:00
Ursprungligen av Cattitude:

Finder...

Lättast att använda terminalen. Vet du inte hur man gör det så kan du göra det med Findern genom att trycka Shift+Äpple+g tangenterna. I fönstret skriver du in /usr/local/clamXav/etc/ och tryck OK. Findern ska då gå till den riktiga mappen. Editera clamd.conf filen med en texteditor som bbedit. Spara och starta om clamxav.

//Rob

Hej igen!
Nu har jag ivf hittat rätt!
Ändrade default till 0, sparade och startade om som du sa...
Fick upp samma meddelande igen...?

//Cat!

  • Medlem
  • Stockholm
  • 2007-12-03 21:58

från FAQ om clamAV:
I get many false positives of Oversized.zip
Whenever a file exceeds ArchiveMaxCompressionRatio (see clamd.conf man page), it’s considered a logic bomb and marked as Oversized.zip . Try increasing your ArchiveMaxCompressionRatio setting.

anledningen funktionen finns är att man kan skicka en zip fil som säger att den blir X stor då man packar upp den, men i själva verket blir den ENORM, äter upp all plats och minne, clamAV crashar i vilket egentligen är en DOS attack..

dock ger felformaterade zip filer samma "fel" även om de funkar som tänkt

1
Bevaka tråden