Kör IE på OS X

Tråden skapades och har fått 53 svar. Det senaste inlägget skrevs .
  • Medlem
  • Gävle
  • 2007-11-20 09:30

Detta är inte lite användbart: http://www.kronenberg.org/ies4osx/

Gör det möjligt att installera IE version 4,5,6 och 7 parallellt på OS X! (Ingen installation av Windows nödvändig.)

Praktiskt, men därtill intressant att det mig veterligen inte ens är möjligt på Windows; den vanligaste lösningen på detta problem på Windows är att ha en testmaskin med 4 installationer av Windows med varsin webbläsare på.

Jag hittar inget om systemkrav på den sidan.

Är det bara för Intel-Macar, eller funkar det på PPC också?

  • Oregistrerad
  • 2007-11-20 10:30

Darwine fungerar bara på Intel och är det som gör det möjligt. Med darwine kan du köra många andra program också (Office 2007 om du skulle vilja)

Tack! Misstänkte det. men eftersom det inte stod något, så ville jag få det bekräftat.

Ännu en anledning att byta dator snart...

Darwin

Ursprungligen av studiox:

Darwine fungerar bara på Intel
och är det som gör det möjligt. Med darwine kan du
köra många andra program också (Office 2007 om du
skulle vilja)

Först och främst så heter det Darwin (var får du E från ???)

Sedan så ärt Darwin grunden för *ALL* OS X oavsett processor:

http://www.opensource.apple.com/darwinsource/

http://en.wikipedia.org/wiki/Darwin_(operating_system)

Ursprungligen av SkrotNisse:

Först och främst så heter det Darwin (var får du E från ???)

Sedan så ärt Darwin grunden för *ALL* OS X oavsett processor:

http://www.opensource.apple.com/darwinsource/

http://en.wikipedia.org/wiki/Darwin_(operating_system)

Ni talar om olika saker. Darwin är mycket riktigt BSD-grunden som OS X vilar på. Darwine å andra sidan är en portning av Wine för Darwin – därav namnet Darwine.

http://darwine.sourceforge.net/

Ursprungligen av staed:

Ni talar om olika saker. Darwin är mycket riktigt BSD-grunden som OS X vilar på. Darwine å andra sidan är en portning av Wine för Darwin – därav namnet Darwine.

http://darwine.sourceforge.net/

Då ber jag så mycket om ursäkt. Håller inte på speciellt
mycket med cross platform längre (har suttit för många
nätter med 680x0 emulatorer i Windows så det får räcka).

Fast jag har lite svårt att förstå hur man kan förvränga
namnet Darwin...

  • Medlem
  • Gävle
  • 2007-11-23 11:10
Ursprungligen av SkrotNisse:

Fast jag har lite svårt att förstå hur man kan förvränga
namnet Darwin...

Wine på Darwin. Darwine.

Ursprungligen av studiox:

Darwine fungerar bara på Intel och är det som gör det möjligt. Med darwine kan du köra många andra program också (Office 2007 om du skulle vilja)

Darwine finns även till PowerPC, men där är användningsområdet inte lika stort.

Senast redigerat 2007-11-23 14:15
  • Medlem
  • Stockholm
  • 2007-11-20 11:14

Får inte detta att fungera. Följt anvisningarna men programmet (ie 6 & 7) laddar bara och sedan stängs det.

  • Medlem
  • Gävle
  • 2007-11-20 17:41

Funkar inte. Kör vidare med vmware.

Funkar inte för mig heller. Kan det vara så att det är inkompatibelt med Leopard?

Vad är det ni gör då det inte fungerar?
Enligt instruktionerna på sidan ska man först ladda ner Darwine, jag kan tänka mig att det är lätt hänt att man bara laddar ies4osx vilket borde resultera i att det inte fungerar.

  • Medlem
  • Stockholm
  • 2007-11-20 21:51

Som jag skrev... följt instruktionerna, punkt till punkt. och jo staed enl. versionrapporten så stödjer senaste 10.5an.

Allt installeras men sedan går inte .app filerna att starta.

  • Medlem
  • Falun
  • 2007-11-20 22:15

Fungerar på Leopard men man måste ha X11 installerat

  • Medlem
  • Gävle
  • 2007-11-20 22:25

Ni som inte får det att fungera, kolla följande:

  1. Att ni har X11 installerat. Det installerar ni genom att installera Apple Developer Tools.

  2. Om det fortfarande inte fungerar, starta då först ett av exempelprogrammen som medföljde Darwine. Själv körde jag igång Notepad först, och då startade IE6 sedan också.

Detta kommer att underlätta en hel del för undertecknad, den saken är säker. Ironiskt nog så blir det enklare för mig att testa IE6&7 än för min kollega, som kör Windows.

Ursprungligen av Jogin:

Ni som inte får det att fungera, kolla följande:

  1. Att ni har X11 installerat. Det installerar ni genom att installera Apple Developer Tools.

  2. Om det fortfarande inte fungerar, starta då först ett av exempelprogrammen som medföljde Darwine. Själv körde jag igång Notepad först, och då startade IE6 sedan också.

Vad innebär det att installera Apple Developer Tools? Är det set här du menar?
http://developer.apple.com/tools/download/
vilken av dessa filer i så fall? de är ju riktigt stora filer som jag inte vill ha på datorn bara för IEs skull.

  • Medlem
  • Stockholm
  • 2007-11-20 22:26

stod inte någonstanns.. men självklart... jag installerar och testar direkt

Funkar tokbra för mig! Men på Leopard verkar det vara så att X11 måste vara igång när man startar .app-filerna. Är det inte igång händer ingenting, förrän när man väl startar X11 (då drar IE igång direkt). Iaf på min maskin...

Ursprungligen av Samuel K:

Funkar tokbra för mig! Men på Leopard verkar det vara så att X11 måste vara igång när man startar .app-filerna. Är det inte igång händer ingenting, förrän när man väl startar X11 (då drar IE igång direkt). Iaf på min maskin...

Exakt samma sak här borta Testade som du skrivit, och då funkade det direkt! Tack!

En lite fundering.. varför skulle man vilja köra gamla versioner av IE?

Edit: såg nu att det inte gällde så gamla versioner

  • Medlem
  • Gävle
  • 2007-11-20 22:36
Ursprungligen av rikard.agren:

En lite fundering.. varför skulle man vilja köra gamla versioner av IE?

För att man är webbutvecklare.

Ursprungligen av lilledanne:

Är inte crossover mac ett bättre alternativ ?

http://www.codeweavers.com/products/cxmac/

Kanske, men det kostar. Har inte kört det så jag kan inte säga hur väl det fungerar.

Är inte crossover mac ett bättre alternativ ?

http://www.codeweavers.com/products/cxmac/

Varför är det bara IE7 beta den kan använda sig av?

  • Oregistrerad
  • 2007-11-21 00:09
Ursprungligen av Anders Täpp:

Varför är det bara IE7 beta den kan använda sig av?

Nu gissar jag bara men för att köra IE 7 måste du ha en verifierad Windows installation (med riktig nyckel) som är del av MS "Genuine Program", annars kan du inte ladda ner den. Om jag skulle ladda ner den o göra den tillgänlig skulle jag bryta mot licensavtalet och det tror jag inte skaparen vill göra.

Ursprungligen av studiox:

Nu gissar jag bara men för att köra IE 7 måste du ha en verifierad Windows installation (med riktig nyckel) som är del av MS "Genuine Program", annars kan du inte ladda ner den. Om jag skulle ladda ner den o göra den tillgänlig skulle jag bryta mot licensavtalet och det tror jag inte skaparen vill göra.

Om det var för någon månad sen var det rätt. Men MS fick göra om det där för att dom har så många piratkopior som körs och dom vill att alla ska köra IE7 så då tog dom bort den biten lika som IE6 är/var.

  • Oregistrerad
  • 2007-11-21 17:17
Ursprungligen av acidflash:

Om det var för någon månad sen var det rätt. Men MS fick göra om det där för att dom har så många piratkopior som körs och dom vill att alla ska köra IE7 så då tog dom bort den biten lika som IE6 är/var.

De var som f-n. Det har jag helt missat (tankar inte hem IE så ofta, får det via Technet och WUS)

Fungerar, ja men ingen kan väl påstå att det går särskilt bra.
Vissa sidor klarar inte IE 6 att hantera alls.

  • Medlem
  • Gävle
  • 2007-11-21 09:48

Patric08: Många utvecklare har utvecklingsverktygen installerade redan (som förövrigt också finns på din Mac OS X-skiva), de krävs för en massa andra godsaker som har med utveckling att göra också.

Det som krävs är som sagt X11. Kör installationsprogrammet och välj bort allt utom det. Annars kan du ju kolla på crossover mac som nämndes högre upp i tråden.

ska jag langa in skivan? eller kan jag ladda ner nåt?

Bevaka tråden