Webdelning funkar inte i Leopard

Tråden skapades och har fått 26 svar. Det senaste inlägget skrevs .
1

Nu har jag installerat Leopard och nu kan man inte längre komma åt mina Websidor som jag har i mappen "Websidor" eller "Sites".

Det blir "Forbidden

You don't have permission to access /~orjan/"

Jag har slagit på Webdelning.

Någon som vet hur man ska göra?

Senast redigerat 2007-10-31 14:53

Kolla att du har rätt rättigheter satta på webbside-mappen. Under visa info kan du se och ändra dem. Alla ska ha läsrättigheter till mappen för att det ska fungera. Det gäller även högre upp i katalogstrukturen, dvs du måste ha de rättigheterna satta för såväl din hemkatalog som Användare-mappen.

Jodå.
Det var det första jag gjorde.
Det finns läsrättigheter överallt.
Det funkade innan uppgraderingen.

Konstigt att ingen ännu har reagerat på det här.
Så här är det nämligen för alla.

Jag har dock hittat lösningen på ett annat forum.
Det är ett Apacheproblem:

To fix the problem, go to the directory:

/private/etc/apache2/users

Create a file called <user>.conf, where <user> is your short user name.

The file should contain the following:

#
# Allow access to Bill's Sites directory for web clients.
#
<Directory "/Users/bill/Sites/">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

I used my short user name here. Naturally, your config file will contain your short user name.

Restart Personal Web Sharing after adding the file and you should be good to go.

Thanks to Jason Kerner

Halleluja moment

Stort tack! Funkade perfekt för mig!

/Niclas Cronsioe

  • Medlem
  • Stockholm
  • 2007-11-05 00:49
Ursprungligen av the örjan:

Konstigt att ingen ännu har reagerat på det här.
Så här är det nämligen för alla.

Jag har redan en .conf-fil och det fungerar för mig så det stämmer inte.
Hur installerade du Mac OS X 10.5?

  • Medlem
  • International user
  • 2007-11-05 14:28

Med archive & install så skapar det ingen conf fil i apache2/users/ mapp. Men dina gamla inställningar ska fortfarande ligga kvar i httpd/users/ mappen. Bara att flytta filerna till den nya mappen.

//Rob

  • Medlem
  • Malmö
  • 2007-11-06 18:22
Ursprungligen av the örjan:

To fix the problem, go to the directory:

/private/etc/apache2/users

Jag hittar inte platsen som hänvisas ovan. Jag kollade på min systemdisk > Bibliotek, men hittar ingen mapp som heter "private". Var och hur hittar jag denna plats som jag ska lägga min .config-fil?

  • Medlem
  • Linköping
  • 2007-11-06 18:31
Ursprungligen av Reisan:

Jag hittar inte platsen som hänvisas ovan. Jag kollade på min systemdisk > Bibliotek, men hittar ingen mapp som heter "private". Var och hur hittar jag denna plats som jag ska lägga min .config-fil?

Använd finders "Go to Folder" (shift+cmd+g) så kommer du nog rätt.

  • Medlem
  • Malmö
  • 2007-11-06 18:34
Ursprungligen av bolle:

Använd finders "Go to Folder" (shift+cmd+g) så kommer du nog rätt.

Ah, nu hitta jag det. Bra tips för sökvägar i Finder. Det ska jag komma ihåg. Tack för hjälpen.

Jaha ja. Alla verkar inte ha det här problemet trots allt.
Men har man gjort enklast möjliga installation utan att gå in på anpassad så blir det så här.
Är det apache2 foldern som är ny för leopard?
Jag fick nämligen ändra i httpd.config också för att min web skulle funka som jag vill.

  • Medlem
  • International user
  • 2007-11-05 22:21
Ursprungligen av the örjan:

Jaha ja. Alla verkar inte ha det här problemet trots allt.
Men har man gjort enklast möjliga installation utan att gå in på anpassad så blir det så här.
Är det apache2 foldern som är ny för leopard?
Jag fick nämligen ändra i httpd.config också för att min web skulle funka som jag vill.

Ja det är nytt eftersom i Leopard är det Apache 2 som är nytt. I Tiger var det Apache 1.3. För mig så hade installationen skapat en ny httpd.conf fil. Den gamla var fortfarande där men hade .applesaved ändelse.

//Rob

  • Medlem
  • Malmö
  • 2007-11-05 22:47

Jag testa webbdelningen för första gången efter uppgradering av OS X. Och fick likadant problem. Bra att det finns enkel lösning. Ska testa detta i morgon.

  • Medlem
  • Malmö
  • 2007-11-06 19:13

Hm, trots att jag redigerat .conf-filen så funkar inte min webbdelning eller fildelning. Har läs/skrivrättighet för alla användare, på mappen Documents och även Webbsidor. Har dem båda igång. Vad kan vara fel?

Senast redigerat 2007-11-07 21:43

Ja det där var ett bra tips för att komma till osynliga foldrar. Men det verkar inte som om man kan se osynliga filer. (som börjar med punkt)

  • Medlem
  • Malmö
  • 2007-11-07 21:52

Jag vet inte vad som är fel, men jag får inte webbdelningen att funka. Har ändrat i user.conf-filen. Se bifogad skärmdump. Hilfa mig?

Ursprungligen av Reisan:

Jag vet inte vad som är fel, men jag får inte webbdelningen att funka. Har ändrat i user.conf-filen. Se bifogad skärmdump. Hilfa mig?

har du varit tillbaks i systeminställningar/Delning och startat om webdelning efter att du ändra i inställningsfilerna?

  • Medlem
  • Malmö
  • 2007-11-08 07:12
Ursprungligen av David Slättne:

har du varit tillbaks i systeminställningar/Delning och startat om webdelning efter att du ändra i inställningsfilerna?

Ja, det har jag.

  • Medlem
  • Malmö
  • 2007-11-08 07:42

Jag prova att reparera behörighet på systemdisken och fick följande meddelande, se bifogad bild. Kan detta vara orsaken? Att min webbdelning inte fungerar? Kanske ska köra en vända med Leopardskivan och installera om?

  • Medlem
  • International user
  • 2007-11-08 10:23

Nej det är fler som har detta fel. Men det är inget att bry sig om.

Prova att öppna terminalen och skriv.

httpd -S därefter httpd -t

//Rob

  • Medlem
  • Malmö
  • 2007-11-08 13:37
Ursprungligen av Robo-X:

Nej det är fler som har detta fel. Men det är inget att bry sig om.

Prova att öppna terminalen och skriv.

httpd -S därefter httpd -t

//Rob

Vad händer när man skriver ovanstående i Terminalen? Jag ska testa det när jag kommer hem från jobb.

  • Medlem
  • Malmö
  • 2007-11-08 20:38
Ursprungligen av Robo-X:

Nej det är fler som har detta fel. Men det är inget att bry sig om.

Prova att öppna terminalen och skriv.

httpd -S därefter httpd -t

//Rob

Testade nu att skriva httpd -s i Terminalen. Och fick fram en förteckning. Sen skrev jag httpd -t och då fick jag följande svar:

Syntax error on line 2 of /private/etc/apache2/users/Rei.conf:
Illegal option AllowOverride

  • Medlem
  • International user
  • 2007-11-09 10:05

Du ser om du har något fel i din konfiguration. Och det ser ut att du har något fel i din konfig fol därför fungerar webdelning inte för dig. Posta vad det står i din fil.

//Rob

<Directory "/Users/Rei/Sites">
    Options Indexes FollowSymLinks MultiViews Includes
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>
  • Medlem
  • Malmö
  • 2007-11-09 12:52
Ursprungligen av Robo-X:

Du ser om du har något fel i din konfiguration. Och det ser ut att du har något fel i din konfig fol därför fungerar webdelning inte för dig. Posta vad det står i din fil.

//Rob

<Directory "/Users/Rei/Sites">
    Options Indexes FollowSymLinks MultiViews Includes
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

Såhär står det i min Rei.conf-fil:

<Directory "/Users/Rei/Sites/">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

  • Medlem
  • Malmö
  • 2007-11-16 22:50

Mitt problem var tydligen inte något med .conf-filen. Fick ställa in mitt modem så att den fick ett allmänt ip-nr. Och då funka webbdelningen.

  • Medlem
  • 2007-11-18 16:22

Att flytta conf-filen från HTTPD till etc/apache2/users löste biffen. men nu funkar inte PHP.. Skit också. får nog installera om…

  • Medlem
  • International user
  • 2007-11-18 20:12

Varför då?

Eftersom Leopard kommer med Apache 2 så tror jag inte att conf filen från Tiger fungerar eftersom Tigers Apache är 1.3. Det rätt mycket nytt i apache2 och man ska inte använda den från Tiger. Om du vill få PHP att fungera öppna httpd.conf filen och leta efter #LoadModule php5_module libexec/apache2/libphp5.so .

Ta bort # och spara filen. Starta om Apache och då ska PHP fungera igen.

//Rob

1
Bevaka tråden