Jag är inte längre admin efter att ha laddat Leopard!

Tråden skapades och har fått 16 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2007-10-30 14:16

Laddade Leopard på min PM G5/2x2 GHz.

Det verkar fungera men jag har tappat adminrättigheterna.
Hittar inte heller någon annan admin bland kontona.

Hur skall jag kunna få tillbaka admin?

  • Medlem
  • Stockholm
  • 2007-10-30 14:56

Samma problem har jag!
Kör med PM G4!

  • Medlem
  • 2007-10-30 16:45

Fungerar! Tack för tipset!

Vet inte om jag är trött eller trög.

Var ska jag skriva in detta?
Lider av samma problem..

  • Medlem
  • Stockholm
  • 2007-10-30 18:11

Starta om, håll nere  + S för att boota i single user mode.

Tack!

Fungerar dock inte fortfarande, är väldigt ny på detta dock.
Trycker kringla + s, kommer in i single user mode.
skriver mount[mellanslag]-uw[mellanslag]/
händer ingenting. har testat utan sista mellanslaget mellan 'w' och '/'
skriver passwd root, får skriva in lösen 2 ggr. thats fine

sedan, skriver man passwd yourusername (mitt användarnamn antar jag)
skriver passwd Marcus Jarnefur (fungerar inte, antagligen för att den inte fattar mellanslaget.

Hur ska jag göra?

Mvh
Newbie

  • Medlem
  • Stockholm
  • 2007-10-30 19:14
Ursprungligen av mjarnefur:

Tack!

Fungerar dock inte fortfarande, är väldigt ny på detta dock.
Trycker kringla + s, kommer in i single user mode.
skriver mount[mellanslag]-uw[mellanslag]/
händer ingenting. har testat utan sista mellanslaget mellan 'w' och '/'
skriver passwd root, får skriva in lösen 2 ggr. thats fine

sedan, skriver man passwd yourusername (mitt användarnamn antar jag)
skriver passwd Marcus Jarnefur (fungerar inte, antagligen för att den inte fattar mellanslaget.

Hur ska jag göra?

Mvh
Newbie

Du skall skriva namnet på din user, alltså det som din hemkatalog exempelvis heter, inte fulla namnet som du har satt på användaren.

  • Medlem
  • Stockholm
  • 2007-10-30 19:07

Händer det ingenting kan det vara ett bra tecken. Så länge inte kommandot spottar ur sig felmeddelanden borde det vara ok.

Användarnamnet du ska skriva in är inte ditt "långa" användarnamn utan det korta. Om du i OS X startar Terminalen och kör whoami får du se vad ditt korta användarnamn är. Gissningsvis marcus eller dylikt.

Okej, tack så hjärtligt.

En liten sista sak, ska man skriva
1, mount[mellanslag]-uw[mellanslag]/
eller
2. mount[mellanslag]-uw/
?

  • Medlem
  • Stockholm
  • 2007-10-30 19:13

Det första.

Tack så mycket allihopa.
Jag får det fortfarande inte att fungera.

Antar för att jag inte skapat ett rootaccount? eller?

Hej igen!
Nu fick jag mig till administrator igen!
Men har tappat bort precis allt jag hade på datorn mp3,foton,dokument
ja allt!
Hur ska jag göra för att få allt tillbaks som det var förut?

  • Medlem
  • I skogen utanför Umeå
  • 2007-10-31 19:23

Jag fick samma problem med min PB G4 efter uppgradering, startade om på 10.5 skivan och aktiverade root genom att ange ett lösenord för det kontot, sedan kunde jag låsa upp inställningarna för mitt konto, och ge det admin-rättigheter, med root och det nya lösenordet.

rjp1974. Du har nog inte tappat det utan det syns bara inte, gör inget med kontot och sök här på 99 så hittar du nog hur du får tillbaka rättigheterna för kontot.

Jag har ett liknande problem. När jag körde en clean install och importerade användare från en backupen så fick jag inte skrivrättighet till filerna. Det innebär att varken mail eller itunes eller nåt funkar eftersom de inte får skriva till deras respektive library-fil. När jag kör reparera behörigheter står det:

Reparerar behörigheter för ”Macintosh HD”
ACL hittades men väntades inte på ”private/var/root/Library/Preferences”.
ACL hittades men väntades inte på ”private/var/root/Library”.
ACL hittades men väntades inte på ”private/var/root”.
Varning: SUID-fil ”System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent” har ändrats och kommer inte att repareras.
Behörighetsreparation slutförd

Någon som har nån idé? Är inget vidare på sånt här...

  • Medlem
  • International user
  • 2007-10-31 22:26

Du kan aktivera root användaren via installationsdisken (verktyg -> återställ lösenord -> systemadministratör -> ändra lösenordet)

Ja, det gjorde jag, men jag lessnade rätt fort på att gå in och ändra varje fil för sig, och jag hittade inget snabbt sätt att ändra många filer. Jag blåste rent datorn igen och importerade inga användare den här gången helt enkelt. Jag konfigurerade en ny användare att bli som min gamla manuellt istället.

1
Bevaka tråden