Airport extreme - Portöppning

Tråden skapades och har fått 10 svar. Det senaste inlägget skrevs .
1

Hej!

Jag har ett problem med att öppna portar i min airport extrem och jag har gått igenom en mängd disskussioner där folk har haft liknande problem men inte hittat någon lösning som funkar för mig. När jag har öppnat portarna i airportverktyget och kollar på canyouseeme.org och de program jag andvänder raporterar trots allt mina portar som stängda. På Applesuporten vill de inte ge suport eftersom jag kommer ut på internet och där slutar deras åttaganden. En kort beskrivning om vad jag gjort kommer nedan och så håler jag tummarna för att någon ska kunna leda mig rätt.

Jag har tidigare haft en router med samma portar och då fungerade det.

När jag ansluter direkt till nätverksuttaget fungerar det fint(jag har inget modem utan ansluter direkt till ett fiberuttag)

Jag har satt en fast intern ipadress på dator och router (192.168.1.5 resp. 192.168.1.1)

I airportverktyget har jag öppnat mina portar under portkoppling och hänvisat till datorn ip. Här är jag dock osäker på vad allmänna och egna portar betyder men de har alla fått samma portnummer av mig.

Jag har stängt av NAT-portkopplingsprotokollet och låter routern dela en allmän IP-adress.

Är det något jag missat eller vad kan det bero på? Jag håller på att bli galen över det här vansinnigt irriterande problemet så ag hoppas att det finns någon vänlig själ som kan sträcka ut en hand.

  • Medlem
  • Stockholm
  • 2007-09-12 13:59

Det är inte så att du försöker dela ut någon av de fördefinierade portarna då?
Har för mig att du skall välja de först innan du börjar definiera egna portar... eller blandar jag ihop med annan router nu... för själv gjorde jag detta en gång på min AEBS och det funkade kanon.

  • Medlem
  • Sollentuna
  • 2007-09-12 15:54
Ursprungligen av Trineo:

Det är inte så att du försöker dela ut någon av de fördefinierade portarna då?
Har för mig att du skall välja de först innan du börjar definiera egna portar...

Det finns inga förinställda portar, däremot finns i en rullgardin ett antal förpreparerade protokoll att välja bland. Du kommer dessutom att få gnäll tillbaka om du dubbel-definierar någon protokoll-port.

  • Medlem
  • Sollentuna
  • 2007-09-12 15:48
Ursprungligen av superkingpin:

I airportverktyget har jag öppnat mina portar under portkoppling och hänvisat till datorn ip. Här är jag dock osäker på vad allmänna och egna portar betyder men de har alla fått samma portnummer av mig.

Kan du visa oss en skärmdump av den sidan från Airport Utility?

Ursprungligen av superkingpin:

Jag har stängt av NAT-portkopplingsprotokollet och låter routern dela en allmän IP-adress.

Det kan du göra, men det är fler och fler applikationer som stödjer NAT Portmapping Protocol (ibland PnP). Jag har bla sett tex Transmission göra detta.

  • Medlem
  • Stockholm
  • 2007-09-12 16:09

Jo, det var just de fördefinierade protokollen jag menade... så vad är de om inte förinställda portar... för mig veterligen gör de inget annat.

  • Medlem
  • Sollentuna
  • 2007-09-12 17:03

Nej, dom finns bara för att underlätta livet för dig när du ska göra själva inställningen. Dom måste finnas i rutan/tabellen nedanför rullgardinen för att vara aktiva/fungera/i drift/<what-ever>. I grunden är en Extreme (och alla andra också, för den delen) igenstängd/blockerande för inkommande trafik.

Jag har kollat igenom de förinställda protokollen som ni talar om men det finns inget där som passar mina syften.

Vad det gäller NAT så har jag uppfattat det som att man får välja mellan det eller manuell portmappning. Eftersom jag har flera datorer i nätverket så trodde jag då att jag var tvungen att koppla ur det och manuellt öppna portar. Kan det stämma?

För tillfället kan jag inte ta en skärmdump av Airportverktyget för min Extreme eftersom jag har exprimenterat med att istället koppla in min Airport Express och försökt öppna portarna i den istället. Det märkliga är att det funkar där när jag har exakt samma inställningar som på min airport extreme. Oftast brukar det vara något man gjort fel när sakerna inte fungerar men jag börjar ändå fundera på om det faktiskt kan vara så att hårdvaran är trasig.

Jag återkomer med en skärmdump så snart jag hinner.

  • Medlem
  • Sollentuna
  • 2007-09-12 21:51
Ursprungligen av superkingpin:

Jag har kollat igenom de förinställda protokollen som ni talar om men det finns inget där som passar mina syften.

Och det är därför som du får skriva egna själv. Direkt i dom olika fälten. Funktionen blir densamma.

Ursprungligen av superkingpin:

Vad det gäller NAT så har jag uppfattat det som att man får välja mellan det eller manuell portmappning.

Du ska nog kunna använda dig av en kombination av båda två. Jag har inte hittat i manualen att det är antingen eller.

Ursprungligen av superkingpin:

Eftersom jag har flera datorer i nätverket så trodde jag då att jag var tvungen att koppla ur det och manuellt öppna portar. Kan det stämma?

Det kan jag inte se någon anledning till. Oavsett om du har 1 eller 100 datorer så fungera båda lika bra, men NAT Port Mapping Protocol är ju att föredra med många datorer då varje dator förhandlar till sig sin egen portmapping.

Ursprungligen av superkingpin:

Det märkliga är att det funkar där när jag har exakt samma inställningar som på min airport extreme.

Du får också gärna posta en skärmdump på när det fungerar med Expressen.

Nu har jag äntligen fått det att funka och jag får tacka för angagemanget i min fråga. Efter att ha fabriksåterställt både min express och extreme tre gånger, gjort om processen från början exakt likadant som tidigare, så fungerade det helt plötsligt. Tyvärr vet jag inte vad som var fel men skönt att det gick till slut. Jag har nu både NAT, fast ip och öppna portar. Det går inte med bara NAT i de program som jag testat som ska stödja det men det verkar inte störa heller så jag lämmnar det på tillsvidare.

  • Medlem
  • Sollentuna
  • 2007-09-13 20:23

Har du kollat om AirPort Utility hittar någon ny firmware till dina airportar?

Japp, jag har de senaste uppdateringarna. Det verkar ju i och för sig som att den senaste firmwaren ibland krånglar till det för folk som haft det bra innan.

1
Bevaka tråden