Problem med uppspelning av 1080p-material på min Macbook

Tråden skapades och har fått 36 svar. Det senaste inlägget skrevs .
  • Medlem
  • Motala
  • 2007-09-07 00:15

Håller på att kolla på en 1080p film as we speak på min Macbook 2ghz, 2gb ram

Tidvis så har jag problem med att videon stannar upp (ljudet fortsätter) helt slumpvis. Mycket störande

Jag spelar upp filmen med VLC, jag vet att VLC inte är optimalt för Mac, men eftersom VLC är det enda program som har stöd för DTS än så länge så har jag inget alternativ.

Jag har testat att spela samma fil i QT med perian installerat, och upplever samma slags hack, nästan värre t om.

Vad kan det vara? Folk på forum berättar hela tiden att 1080p flyter på bra och utan problem, väldigt frustrerande när det inte funkar för mig.

Först trodde jag att det var för att datorn blir så varm (låg på 85c på cpun och runt 70c på heatsinkarna), och att det kunde vara det som orskade det, men nu kör jag med en slags hemmabyggd spacer och datorn går mycket svalare.

Jag har stängt av det flesta program, förutom IRC, som tar upp ungefär 150mb ram, inget mer.

Jag är clueless

Filmen ligger på 12MB/s om det kan ha något med saken att göra, för t ex Matrix som ligger på 8MB/s inbillar jag mig att det hackar mindre i, men jag vet inte.

  • Medlem
  • Lund
  • 2007-09-07 01:44

Provat köra den i windows xp på samma mac, med samma resultat?

  • Medlem
  • Motala
  • 2007-09-07 01:48

Måste jag inte ha bootcamp för det?
Jag har nämligen bara parallels.

Har läst lite om det där, att det kan funka bättre i XP, även om det funkade bättre i XP så är det ju inte det operativet jag vill använda. Men du kanske syftar på att testa XP i felsökningsperspektiv.

  • Medlem
  • Lund
  • 2007-09-07 01:56

Kör xp i boot camp. Är det lika mycket crap där är det säkert mer hårvarurelaterat. Om inte har det med programvaran att göra.

  • Medlem
  • Motala
  • 2007-09-07 02:25

Tankar Bootcamp nu.

Läste instruktionerna och uppmärksammade att jag har gammal firmware, men det kan väl inte vara det som spökar till det, angående min HD-uppspelning?

  • Medlem
  • Motala
  • 2007-09-07 02:38

Förresten, filmen jag kollade på låg på min filserver. Den är mountad via Samba.

Men det borde väl inte vara något problem? Jag kör gigabitnätverk.

Ursprungligen av qom:

Förresten, filmen jag kollade på låg på min filserver. Den är mountad via Samba.

Men det borde väl inte vara något problem? Jag kör gigabitnätverk.

Samba är boven. Spelar ingen roll hur snabbt nätverk du har, SMB-klienten på Mac OS X är inte tillräckligt bra.

  • Medlem
  • Motala
  • 2007-09-07 12:02
Ursprungligen av hansfilipelo:

Samba är boven. Spelar ingen roll hur snabbt nätverk du har, SMB-klienten på Mac OS X är inte tillräckligt bra.

Så tråkigt.
Jag testade att köra en film med lägre bitrate nu, lokalt på macbooken, och fick samma problem, och det är alltid vid samma scen..

  • Medlem
  • 2007-09-07 15:42
Ursprungligen av qom:

Så tråkigt.
Jag testade att köra en film med lägre bitrate nu, lokalt på macbooken, och fick samma problem, och det är alltid vid samma scen..

Samma scen? Är det inte fel på filen då?
Annars ställer du upp cachen i VLC så går det utmärkt att köra 1080p via samba.

Preferences > Input/Codecs > Access modules

Öka cachen till 1000 ms för samtliga moduler.
Möjligen måste du kryssa för "Advanced" längst ner till vänster allra först för att se alla menyval.

  • Medlem
  • Motala
  • 2007-09-07 16:41
Ursprungligen av eQ:

Samma scen? Är det inte fel på filen då?
Annars ställer du upp cachen i VLC så går det utmärkt att köra 1080p via samba.

Preferences > Input/Codecs > Access modules

Öka cachen till 1000 ms för samtliga moduler.
Möjligen måste du kryssa för "Advanced" längst ner till vänster allra först för att se alla menyval.

Det verkar funka väldigt mycket bättre!

http://www.megaupload.com/se/?d=YMRR89L0

När det klipper över till scenen där snubben kommer gåendes med hunden så hackar det till 9 gånger av 10.
Upplever ni samma problem?

  • Medlem
  • Stockholm
  • 2007-09-07 17:17

Vad är poängen med att köra 1080p video på en Macbook? Med tanke på att Macbookens skärm ligger mycket närmare 720p (1280x720 och skärmen 1280x800) så kan du visa hela bilden vid 720p. Tittar du däremot på 1080p så kläms bilden i höjdledd ihop väldigt mycket och du ser mindre av bilden än i 720p.

  • Medlem
  • Vimmerby
  • 2007-09-07 09:29

Jag har bara tankat hem och provat de HD-filmer som Apple lagt upp själva på sin site och alla flyter på bra när det inte rör sig så mycket i bilden. Vid snabba kamerapanoreringar eller snabba klipp hänger inte bilden med och framraten kan sjunka till 10-15 fps (bedömmer jag det till). Så jag tror inte Macbooken är helt klockren att kolla 1080p material på. Jag har första generationens svarta Macbook med 2Gb ram.

Menar ni att Macbooken ska klara 1080p utan ryck och hack?

ööhhh ... 1080 p och MacBook är väll inte en riktigt bra match eller ?

det krävs ganska mycket av datorn för att spela upp 1080 p ... MacBook Pro hade inte varit några störe problem men du har ju faktist en MacBook ... en MacBook är ingen "proffs" maskin ... jag har en Mac Pro och det känns när man spelar 1080 p ...

pröva mplayer för os x om du vill spela upp HD material men 1080p på MacBook är väll att "pusha" datorn ... lite i alla fall ..

  • Medlem
  • Motala
  • 2007-09-07 12:28

Så en MacBook Pro borde inte ha några problem alls?
en iMac?

  • Medlem
  • Malmö
  • 2007-09-07 15:33

Jag upplever inga problem med 1080p på min iMac 2,33 Ghz C2D, 2GB Ram

  • Medlem
  • Motala
  • 2007-09-07 17:38

Jag har den kopplad till en FullHD TV

Är du säker på att det inte är filmen? Jag har en Macbok med Intel Core 2 Duo 2ghz, och 1gb Ram, och för mig flyter den jättebra ända fram tills secenen med hunden, själva övergången är inga problem, men den hackar till på exakt samma ställe varje gång, (testade 5 gånger) och hackar i några sekunder på precis samma sätt. Har inte haft några problem med att spela upp trailers i 1080p, men jag har aldrig testat någon hel film.

  • Medlem
  • Motala
  • 2007-09-07 20:32

Må vara filmen, men jag upplevde problem med en annan film igår, en fullängdare, men det kan ju ha varit samba som spökade då, kanske.

Testade nu med samma trailer i 480, 720 och 1080, de första två flyt helt utan problem, den sista småhackade lite i runt 3 sekunder i början sedan flöt även den fint genom hela. Det var rätt mycket saker som hände på skärmen så, macbooken klarar nog relativt fint att spela upp full hd filmer, utifrån mina "undersökningar"

  • Medlem
  • Motala
  • 2007-09-07 22:55

Trailers och x264/h264 är inte samma sak, för jag antar att du kollade på apples trailers?

det gjorde jag, det var alltså jävligt felaktiga undersökningar?

  • Medlem
  • Motala
  • 2007-09-07 23:48

Apples format är lättare för macen att spela upp, så vitt jag vet.

  • Medlem
  • Stockholm
  • 2007-09-08 01:42

jag har spelat upp flertalet HD-filmer i 1080p i .mkv formatet utan problem, visst jag kan inte hålla på att spola fram och tillbax för då krashar VLC (vilket är kasst optimerat till macen). sitter på en macbook 2,0 ghz med 2 gb ram.

  • Medlem
  • Motala
  • 2007-09-08 02:21

Kollade precis på femte elementet i 10000kbit/s och upplevde frysningar lite då och då, jag menar, det är inte ens framedrops, utan bilden bara fryser fast, enormt störande.

  • Medlem
  • 2007-09-15 11:32
Ursprungligen av qom:

Kollade precis på femte elementet i 10000kbit/s och upplevde frysningar lite då och då, jag menar, det är inte ens framedrops, utan bilden bara fryser fast, enormt störande.

Öka till 5000 ms i cache. Har du ökat cachen för samtliga moduler?
Jag har inga framedrops i sample ovan. Jag har MBP Core Duo 2 Ghz, 2 GB RAM och X1600 256 MB.

Du ska inte heller ha några problem med din Macbook, det måste bero på något annat. Du kör senaste VLC? För Intel? 0.9.0 är tokbuggig, undvik.

  • Medlem
  • Motala
  • 2007-09-15 11:53

Jag kör 0.8.6b

Edit: Nu kör jag 0.8.6c.
Drog upp alla moduler till 5000ms som du sa

Fortfarande samma problem

Har höjt cache på alla under "åtkomstmoduler"

Senast redigerat 2007-09-15 12:09
  • Medlem
  • Motala
  • 2007-09-10 13:45

I samplet nedanför så får jag frysningar i VLC och om jag låter hela filmen buffra i QT så får jag fortfarande hemskt mycket framedrops. Någon annan som får det att flyta? Vad har ni för Macar isåfall?

http://rapidshare.com/files/54661828/sample.mkv.html

Ursprungligen av qom:

I samplet nedanför så får jag frysningar i VLC och om jag låter hela filmen buffra i QT så får jag fortfarande hemskt mycket framedrops. Någon annan som får det att flyta? Vad har ni för Macar isåfall?

http://rapidshare.com/files/54661828/sample.mkv.html

Jag får fruktansvärda framedrops på den filen med min MBP Core Duo 2 Ghz, 2 GB RAM och X1600 256 MB.

Med 1080p-filmerna på apple.com så får jag inte det.

  • Medlem
  • 2007-09-16 11:17

Du har problem även när filen körs från Macbookens interna HD?

  • Medlem
  • Motala
  • 2007-09-16 13:08

Ja.

Samma ställen.

Knepigt
Hade varit mer förståeligt om du hade lite mer CPU-kraft än mig, jag förstår inte.

Bevaka tråden