Hårddiskarna går i vila hela tiden!

Tråden skapades och har fått 10 svar. Det senaste inlägget skrevs .
1

Hej!

jag har stoppat i ett ACARD 6880M som jag har anslutit två Ata hårddiskar till, min dator är en G4 Quicksilver 933 mhz.

Mitt problem är att någon av hårddiskarna, eller möjligtvis båda två går i vila titt som tätt. Om jag inte rört datorn på en stund och skall öppna en mapp, så börjar först badbollen att snurra, sedan så hör jag hur hårddisken spinner upp, för att till sist uppdatera mappinnehållet. Jag har kontrollerat strömsparläge i systeminställningarna, så det är det inte.

Jag kan även höra hur hårddisken vaknar och somnar om vartannat om jag inte rört den på en stund, innan den vaknar så hörs ett klick, som följs av ljudet när disken spinner upp i hastighet. Jag har inga fel på datorn direkt, utan är mest irriterad över att det kan ta några sekunder extra innan jag får kontroll över mappinnehåll och dylikt.

Är det möjligtvis någon som känner igen problemet och kanske har en lösning, eller för jag leva med detta?

Hat du kryssat ur "Put the harddrives to sleep when possible" under strömspararinställningarna?

Ursprungligen av Johan S:

Hat du kryssat ur "Put the harddrives to sleep when possible" under strömspararinställningarna?

Ja, alla såna möjligheter är både dubbel & trippelkollade :-).

  • Medlem
  • Stockholm
  • 2007-08-16 21:05

Diskarna själva har SMART inställningar som du säkert kan fippla med, det kan vara så att det inte är kortet/OSet som sätter de vila utan att diskarna själva spinner ner pga inställningarna som är i deras firmare.

Program som TechTool eller SMART Utility (http://www.versiontracker.com/dyn/moreinfo/macosx/32454) borde kunna ställa detta åt dig.

Ursprungligen av ntity:

Diskarna själva har SMART inställningar som du säkert kan fippla med, det kan vara så att det inte är kortet/OSet som sätter de vila utan att diskarna själva spinner ner pga inställningarna som är i deras firmare.

Program som TechTool eller SMART Utility (http://www.versiontracker.com/dyn/moreinfo/macosx/32454) borde kunna ställa detta åt dig.

Det låter inte alls dumt, ska kolla direkt. tack för tipset, jag återkommer med resultatet.

Smartutility hade tyvärr inte stöd för mina diskar, kanske beroende på mitt acard-kort. ska prova vidare.

Det verkar som om jag hittat problemet, det finns flera rapporter om detta på macosxhints, särskilt när det gäller maxtor-diskar, vilket är en av mina diskar. Man skall tydligen göra nåt skript samt greja i terminalen, hemska tanke . Jag skall testa detta, så får vi se hur det går. Om någon är intresserad så lämnar jag en länk här nedanför med förslaget till lösning:
http://www.macosxhints.com/article.php?story=20011024160033481

Eller ett vanligt simpelt program för oss som gillar enkla saker finns här:
http://www.canelasoftware.com/freeware/hdriveawake/HDriveAwake.html

Använd pmset

Öppna en Terminal och kör nedanstående, så kommer du slippa problemet.

# pmset disksleep 0

Ursprungligen av mickep76:

Öppna en Terminal och kör nedanstående, så kommer du slippa problemet.

# pmset disksleep 0

Tack så jättemycket micke, jag har stört mej länge på detta :-).

Gäller detta för alltid tills man kör kommandot igen, eller bara tills nästa gång man startar datorn?

  • Medlem
  • Örebro
  • 2007-09-11 18:39

Inställningarna sparas.

Ursprungligen av Den fiffige teknikern:

All changes made through pmset are saved in a persistent preferences file
(per-system, not per-user) at
/Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist

Källa: Mac OS X Man Pages

1
Bevaka tråden