Coda - Problem med charset

Tråden skapades och har fått 2 svar. Det senaste inlägget skrevs .
1

Hej,

Jag är en nybliven switcher som testade programmet Coda igår. Importerade lite html-dokument från min gamla peze men när jag började göra lite ändringar i en av filerna så klagade programmet på Charset, jag fick då välja mellan UTF-8 eller UTF-16. Jag har ingen koll på vad som är bäst i det läget så körde på UTF-16.

Problemet nu är att alla å, ä och ö ser mysko ut. Eller, i Firefox ser allt bra ut men i resterande browsers (IE, Safari) ser det konstigt ut. Jag gissar att mitt val av charset har ställt till det, nån som har koll på hur jag kan fixa det här?

Tack,
Daniel

  • Oregistrerad
  • 2007-08-16 10:03

Tittar du på HTML filerna bara lokalt? Eller har du laddat upp dom någonstanns?

Du måste dels välja samma encodning som du använder för att identifiera din teckenuppsättning i scriptet. Exempelvis:

<META http-equiv="Content-Type" content="text/html; charset=UTF-16">
Däremot är UTF-16 väldigt ovanligt, UTF-8 är en mer vanlig standard, även om denna också inte är vanligast. Vanligast är LATIN1 så fungerar bra på både windows och mac.

Du kan gå in i inställningarna o på typ första sidan du får upp så kan du välja vilket charset som ska vara default.
Det där har jag också haft en jävla massa strul med, men nu funkar det bra.
Har inte min mac här, så jag kan inte lägga upp någon bild, men rota runt i inställningarna så hittar du snart den.

[EDIT]
Om inte annat så kan du högerklicka på filen i tabben och välja charset däri... Gör det på de gamla filerna, och ändra sen i inställningarna... [/EDIT]

1
Bevaka tråden