Ftp-server bakom D-Link DI-524

Tråden skapades och har fått 5 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Karlskrona
  • 2007-08-14 14:19

Är det någon som fått en ftp-server att fungera tillfredställande ihop med en D-Link DI-524?

Inom det egna nätverket funkar allt finfint.

Problemet är när jag loggar in utifrån – med de flesta ftp-klienterna listas inte filerna och så är det allmänt instabilt. (Kör i passive mode).
Portforwardning är som den ska, har provat DMZ också - samma problem.

Har jag missat något eller är routern helt enkelt inte kapabel att portforwarda ftp?

  • Medlem
  • Göteborg
  • 2007-08-16 20:19
Ursprungligen av Hepp:

Är det någon som fått en ftp-server att fungera tillfredställande ihop med en D-Link DI-524?

Inom det egna nätverket funkar allt finfint.

Problemet är när jag loggar in utifrån – med de flesta ftp-klienterna listas inte filerna och så är det allmänt instabilt. (Kör i passive mode).
Portforwardning är som den ska, har provat DMZ också - samma problem.

Har jag missat något eller är routern helt enkelt inte kapabel att portforwarda ftp?

FTP är ett klurigt protokoll. Är du säker på att portforwardingen är som den ska?

Har du uppdaterat routern med senaste firmwaren?

  • Medlem
  • Stockholm
  • 2007-08-16 20:42

Anledningen är mest troligit även det att ftp servern ger sitt NAT ip till klienterna då de skall ansluta passivt, den säger ngt i stil med "anslut till 192.168.1.3 port 73443" vilket uppenbarligen inte funkar.

En del servrar har något som kallas NAT-mode där man kan ställa vilket IP som den skall uppge..

Detta är inte routerns fel, det är FTP som är korkat..

  • Medlem
  • Karlskrona
  • 2007-08-17 09:05
Ursprungligen av ntity:

Anledningen är mest troligit även det att ftp servern ger sitt NAT ip till klienterna då de skall ansluta passivt, den säger ngt i stil med "anslut till 192.168.1.3 port 73443" vilket uppenbarligen inte funkar.

En del servrar har något som kallas NAT-mode där man kan ställa vilket IP som den skall uppge..

Detta är inte routerns fel, det är FTP som är korkat..

Tusen tack! Det var det som felade. Om man bara stavar rätt i .conf-filen så :">.

  • Medlem
  • Karlskrona
  • 2007-08-17 12:40

Äsch, var tydligen inte slut på problem där …
Nu listas filerna iallafall, men överföringen funkar sådär.
Ibland står den bara och tuggar när man ska hämta filer, ibland kör den en stund och slutar innan den hämtat klart.

  • Medlem
  • Karlskrona
  • 2007-08-21 17:48

Ingen aning om vad jag gjort fel innan, men när jag begränsade till några få höga portar på ftp-servern så funkade allt helt plötsligt hur bra som helst.

1
Bevaka tråden