Skapa osynliga systemfiler

Tråden skapades och har fått 42 svar. Det senaste inlägget skrevs .

Jag behöver skapa en osynlig fil som heter .htaccess för att få webbrowsers att spela .m4a filer. Utan denna fil laddar browsern nämligen ner filen till hårddisken.
Men systemet tillåter inte att jag döper en fil med punkt framför eftersom sådana filer "är reserverade för systemet".

Hur ska jag göra? Det går säkert med terminalen misstänker jag. Eller kanske på nåt ännu enklare sätt.

  • Medlem
  • Uppsala
  • 2007-08-13 11:35

Du kan skapa filen i terminalen genom att skriva touch .htaccess i terminalen då skapas en tom fil med namnet .htaccess i den foldern som du för tillfället befinner dig i ( i terminalen alltså)

/thomas

Men det går ju, när du trycker på spara så står det att såna filer är till för systemet så kan man ju välja att använda iaf. Vill du sedan se de osynliga filerna så kan du slå på det i Mac Helpmate

Ursprungligen av gabriel.fjellander:

Men det går ju...

Men, va 17... det går ju! :">

Hrr hrrm.
Varför det inte gick första gången beror på att jag först sparade den som synlig, sedan försökte döpa om den genom att klicka i filnamnet.
Då gick det nämligen inte...

och tack för Mac HelpMate.
Det verkar ju kunna lite av varje.

Senast redigerat 2007-08-13 18:32

Är du redan inne i terminalen så kan det vara enklast att redigera din .htaccess-fil där, t.ex. med pico ("pico .htaccess").

Om man använder BBEdit finns det "Open Hidden..." i File-menyn för att enkelt leta reda på och öppna osynliga filer.

Du kan också skapa en vanlig textfil i din dator som heter htaccess.txt,överföra den via FTP till servern och när den väl är på servern, byta namn på den till .htaccess i ditt FTP-program.

OK. Nu har jag lyckats med det, men det hjälpte inte.
Jag kanske borde berätta vad jag håller på med.
Jag bygger en musiksite där filer skall spelas upp i browsern.
Det gör mp3-filer men inte m4a-filer. Dom laddas i stället ner till hårddisken.
Jag har luskat ut att det är ett Apacheproblem.
Lösningen ska vara att addera en .htaccess fil med innehållet "AddType audio/x-m4a MPEG-4 media m4a"

Nästa jag läste var om någon som inte fick det att funka när han skrev filen i Textredigeraren, men det funkade när han gjorde filen i Cyberduck.
Nu är det bara det att ftp aldrig har funkat på min maskin.
afp däremot funkar finfint.

På en annan sida står det så här:
".htaccess files must be uploaded as ASCII mode, not BINARY. You may need to CHMOD the htaccess file to 644 or (RW-R--R--). This makes the file usable by the server."

Jaha. Hur f-n gör jag det då?

  • Medlem
  • Stockholm
  • 2007-08-13 20:33
Ursprungligen av the örjan:

OK. Nu har jag lyckats med det, men det hjälpte inte.
Jag kanske borde berätta vad jag håller på med.
Jag bygger en musiksite där filer skall spelas upp i browsern.
Det gör mp3-filer men inte m4a-filer. Dom laddas i stället ner till hårddisken.
Jag har luskat ut att det är ett Apacheproblem.
Lösningen ska vara att addera en .htaccess fil med innehållet "AddType audio/x-m4a MPEG-4 media m4a"

Nästa jag läste var om någon som inte fick det att funka när han skrev filen i Textredigeraren, men det funkade när han gjorde filen i Cyberduck.
Nu är det bara det att ftp aldrig har funkat på min maskin.
afp däremot funkar finfint.

På en annan sida står det så här:
".htaccess files must be uploaded as ASCII mode, not BINARY. You may need to CHMOD the htaccess file to 644 or (RW-R--R--). This makes the file usable by the server."

Jaha. Hur f-n gör jag det då?

ASCII/Binary mode är en FTP kvarleva, där man kan välja just då hur en fil laddas upp.. du hade inte fått ftp att funka på din maskin sa du så då behöver du inte funder så mycket på det.

chmod är hur du sätter rättigheter på en unix maskin i terminalen (och ftp etc) för att göra detta, logga in med ssh eller ftp eller för den delen om du har den på en afp fildelning så kan du använda "visa info"..

644 är för användaren read & write 4+2=6, för gruppen dom filen tillhör har det endast läsa som de kan göra (4) och samma för "everyone" alltså alla som inte faller i katergori #1 eller #2.

Komandot är enkelt "chmod 644 <filnamn>" inte svårare än så.

afp är ju hur lätt som helst.
Jahapp. Ägare - läsa och skriva.
Grupp - läsa.
Övriga - läsa.

Check. Då är filen 644 då. Funkar ändå inte.
Måste man starta om datorn...??

(Det kan jag inte för jag är på semester...) O:-)

  • Medlem
  • Stockholm
  • 2007-08-13 23:11
Ursprungligen av the örjan:

afp är ju hur lätt som helst.
Jahapp. Ägare - läsa och skriva.
Grupp - läsa.
Övriga - läsa.

Check. Då är filen 644 då. Funkar ändå inte.
Måste man starta om datorn...??

(Det kan jag inte för jag är på semester...) O:-)

Nej du behöver inte starta om servern, men har du möjlighet att läsa loggarna på maskinen eller så? det kan ju vara att det är fel på .htaccess filen eller att den inte är confad att använda dem (eller som jag gör ställer om namnet från .htacess till andra saker för att det är smidigare)

HannesP.
Du har ingen aning om hur jag ska lösa själva huvudproblemet?

Ursprungligen av the örjan:

Jag bygger en musiksite där filer skall spelas upp i browsern.
Det gör mp3-filer men inte m4a-filer. Dom laddas i stället ner till hårddisken.
Jag har luskat ut att det är ett Apacheproblem.
Lösningen ska vara att addera en .htaccess fil med innehållet "AddType audio/x-m4a MPEG-4 media m4a"

Men det hjälpte inte.

Vi får ta det efter semestern då...
Jag var i alla fall noga med att först "göra om filen till ren text" som det står i editorn.
Då försvinner ju all formatering.
Och att confa maskinen (Apache), det funkade ju för andra snubbar.

Men jag begriper inte varför ftp inte fungerar!!!

Flera bredbandsleverantörer spärrar trafik på port 21, som är den som används av FTP, sök här i forumet, det har diskuterats.

  • Medlem
  • Sollentuna
  • 2007-08-13 23:50
$ cat /etc/services
...
ftp-data         20/udp     # File Transfer [Default Data]
ftp-data         20/tcp     # File Transfer [Default Data]
ftp              21/udp     # File Transfer [Control]
ftp              21/tcp     # File Transfer [Control]
...
$

Jo men det kan inte bero på bredbandsbolaget eftersom jag inte ens kan ftp.a i lägenheten via LAN!

Den där koden, är det nåt terminalkommando?
Hur SSH.ar jag min dator hemma?

Jag är ju som sagt på semester.

  • Medlem
  • Stockholm
  • 2007-08-14 16:36
Ursprungligen av the örjan:

Jo men det kan inte bero på bredbandsbolaget eftersom jag inte ens kan ftp.a i lägenheten via LAN!

Den där koden, är det nåt terminalkommando?
Hur SSH.ar jag min dator hemma?

Jag är ju som sagt på semester.

Hinder för FTP är 99.9% av gångerna en brandvägg som inte är ställd korrekt för ftp, ftp är ett mörker när det kommer till att göra säkra brandväggsregler och funktion

vilket terminalkommando? det som frazze skrev vissar bara portnummrena som ftp använder i aktivt läge..

för att kunna ssha in till en OS X maskin måste du slå på "remote login" under "sharing" i system inställningarna.. och ev brandvägg etc.

för att sedan ansluta till den skriver du exempelvis i terminalen:

ssh host.domain.tld

alt. om det är en annan användare:

ssh user@host.domain.tld
  • Medlem
  • Simrishamn
  • 2007-08-19 12:53

Oj, vad ni krånglar till det med att göra en fil osynlig! Kör bara:

/Developer/Tools/SetFile -a V /path/to/file && killall Finder

Det sista startar om Finder, vilket verkar vara nödvändigt för att filen ska gömmas. Om ni av någon anledning inte vill starta om Finder, ta bort sista biten av raden inkl "&&".

HannesP, det där kräver väl att man först HAR developer tools installerade (en seperat nedladdning om ca 500 Mb alternativt en separat installation från system DVD vill jag minnas?) och att man dessutom känner till så mycket UNIX att man kan skriva det där som i sin tur kräver läsandet av hur många sidor i hur många böcker eller man-pages? Enkelt?

  • Medlem
  • Simrishamn
  • 2007-08-19 14:07

Testa att istället skriva:

AddType audio/mp4 .m4a

Jag vet inte om det är den rekommenderade MIME-typen för en m4a-fil, men när jag visar en sådan fil i Safari spelas den iaf upp, istället för att laddas ner.

Varför händer detta bara mej...?

Ingenting hjälper.
Min .htaccess fil ser just nu ut så här:

AddType audio/mp4a-latm
AddType audio/mp4 .m4a
AddType audio/x-m4a MPEG-4 media m4a
AddType video/mp4 MPEG-4 media mp4
AddType video/x-m4v MPEG-4 media m4v

Det första tog jag från Opera som kallade filtypen så.
Dokumentet är sparat som ren text.
Textformatet jag valt är UTF-8.
Jag suddar bort ändelsen .txt innan jag sparar.
Jag lägger filen i samma katalog som m4a filerna.

Men icke. Funkar ej.
Man skulle ju inte behöva starta om datorn heller.
Menar man alltså att Apache läser dessa osynliga filer varje gång och sedan ger order till webläsaren vad den ska göra?

Vad är det för skillnad på ditt och mitt system?
Hur gör du när m4a filen öppnas i Safari?

Ursprungligen av the örjan:

Varför händer detta bara mej...?

Därför att en .htaccess-fil inte är lösningen på detta problem på en server som du har fullständig access till. Och kanske även att du missuppfattat hur saker och ting hänger ihop på servern och därför lyssnat på ett gäng dåliga råd i denna tråd i kombination med att ha vissa saker felkonfigurerade så att vanliga lösningar på detta problem inte fungerar. Förutom då förstås att du inte lämnar tillräckligt med ledtrådar om din konfiguration och vad problemet är.

Men vad behöver ni för infomation då? ntity ville att jag skulle läsa log-filer. Visst. Vilken då?
Och vad är det som skulle vara felkonfigurerat och hur ändrar jag det?
Han skrev också om att konfigurera om Apache. Det har jag ingen aning om hur man gör, så man kan ju utgå ifrån att webservern är i "default"-läge.

  • Medlem
  • Simrishamn
  • 2007-08-19 16:07

Testa att ta bort (eller kommentera ut) alla rader som slutar på m4a, förutom den jag skrev, d.v.s "AddType audio/mp4 .m4a" och se om det funkar.

Men först måste man ju kolla att servern läser .htaccess-filer!

Ja hur gör man det?
Jag har hittat en fil: /Library/Documentation/Services/apache/configuring.html.html#htaccess.

Där finns länkar till "AccessFileName directive" och till "the Context of the directive" samt " AllowOverride directive". Samtliga är .html-filer och ingen av dessa existerar på min server.
Kan detta innebära att den ej läser .htaccess-filer?
Då blir frågan hur jag skapar dessa filer.

Jag har hittat nåt intressant i Apache dokumentationen.
"Most commonly, the problem is that AllowOverride is not set such that your configuration directives are being honored. Make sure that you don't have a AllowOverride None in effect for the file scope in question."

Det är bara det att jag inte riktigt fattar hur jag ska ändra det. Jag hajjar inte var denna parameter finns.

Det står också att default är "AllowOverride All".

Har du OS X eller OS X Server?

OS X 10.4.10 på en vanlig G5.a.

Allt det här kanske blir lättare med OS X Server?

Senast redigerat 2007-08-19 17:34

Gissa...

I ditt fall så skall du leta reda på konfigurationsfilen för Apache i OS X, en google-sökning ger dig den rätta platsen. Öppna den och hitta antingen avsnittet med mime-typer eller så letar du reda på AllowOverride direktivet och ändrar där. Att ändra i config-filen är långt mycket bättre än att skapa en .htaccess-fil, speciellt om du faktiskt har tillgång till denna fil, vilket inte är fallet om man har ett webbhotellabonnemang.

Glöm inte detta totalt självklara: Servern läser denna fil en gång, när servern startas. Så gissa vad du måste göra varje gång du ändrar i den?

Senast redigerat 2007-08-19 18:31
Bevaka tråden