Problem med portöppning i Airport Express

Tråden skapades och har fått 6 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Norrköping
  • 2007-08-09 20:01

Hej!

Har varit i kontakt med min ISP och Apples tekniska support i detta ärende, inget har gett resultat. Jag har min Airport Express direkt-kopplad till ADSL-modemet, modemet i sig innehåller ingen router (har kontrollerat med ISP).

Jag vill öppna en port i routern. Jag har gjort enligt följande:
Går in i Airport Administrationsverktyg, Fliken Portkoppling, Lägg till. Här får jag 3 alternativ:
1) Allmän port:
2) Privat Adress:
3) Egen port:
På 1 och 3 har jag skrivit den port jag vill ha öppnad. På 2 har jag skrivit den IP som jag blir tilldelad, alltså 10.0.1.2. (har jag kontrollerat under Systeminställningar, Nätverk, Aiport, TCP/IP)
Därefter trycker jag spara och Basstationen uppdateras.

När ovanstående är gjort har jag gått in på sidan http://www.canyouseeme.org/ för att kontrollera om respektive port är öppen. Där dyker min IP utåt upp (85.228.***.***) och jag skriver in den port jag vill har öppnat ovan.
Får som svar "connection refused".

Att tillägga är att båda portarna är inlagda i brandväggen, jag har även testat att stänga av den. Ändå fungerar det inte.

Finns det någon vänlig själ som skulle kunna vara behjälplig?

MVH
Henrik Petersson

  • Medlem
  • Stockholm
  • 2007-08-09 21:56

Först och fråmst, testa med det uppenbara först, koppla datorn direkt till ADSL-modemet och se om det funkar för dig då, gör det inte det så är det ju ISPn som blockerar, alla i dagsläget blockerar portar för att slippa att klantiga kunder sprider en massa skit

Finns som ingen anledning att ringa ISP supporten eller apple för den delen innan du testat det ovan...

Sedan:
#1 vilken port är det som du vill vidarebefodra?
#2 testat med en annan port för att testa?
#3 Ser du att regeln läggs in och sparas på airporten?
#4 är det TCP eller UDP som du vill vidarebefodra?

  • Medlem
  • Norrköping
  • 2007-08-09 22:29

Tack för svaret!

Jag har nu testat att koppla datorn direkt till modemt, samma fel.

Det märkliga nu är att programmet i fråga (aMSN) som använder portarna fungerar och säger att som är öppnade. Dock visar canyouseeme att dom inte är det. Funktionen med portöppningen jag vill åt är webkonversationer, den funktionen fungerar fortfarande inte. Således skulle jag tro att canyouseeme har rätt.

1. Det är portarna 1863 och 6889 som jag vill öppna.
2. Jag har testat med 6890 med samma resultat
3. Ja, regeln ligger inlagd och sparad i administrationsverktyget
4. För att bevisa min okunnighet vid nätverksfrågor så är det oklart, jag får aldrig välja detta.

Hjälpte mina svar lite eller behöver du veta mer?

// Henke

  • Medlem
  • Stockholm
  • 2007-08-10 01:23

ja då vet vi ju att det inte är Airporten som är felet iaf ett steg i rätt riktning

Anledningen jag frågade angående TCP/UDP är att som det ser ut testar canyouseeme endast med en anslutning med TCP och då är det ju som inte så konstigt det inte funkar om det är UDP (olika sätt att skicka data på internet).

Jag antar att webbkonversationer är ngt i stil med videochat eller så? använder inte MSN mer än i adium som just ren textchat så kan inte påsttå att jag har stenkoll på det tyvär. Hur som helst, har du testat med flera användare eller är det bara en, det är ju alltid en möjlighet att det inte är på din sida som problemet ligger..

Frågan är ju då om det är ngt som hindrar anslutningne, du sa att aMSN visar porten som öppen, kollade lite snabbt och det verkar som om den vill använda allt mellan 6891 & 6900 som portar för webkamera om det var det som du tänkte på.. kan vara att den använder någon annan port än den som du ställt in.

Det låter dock som om detta är lättare att felsöka med en riktig portscanner som nmap eller så, men då behäver du access till en unix maskin ansluten till internet, men det kan nog inte vara så svårt, en kompis eller så har säkert en linux maskin de kan leka med.

har dock en egen fundering ang airport extremen, kan man ställa den i bryggläge som man kan göra med expressen (ex http://img373.imageshack.us/img373/9558/picture1sv4.png)

Den där internettjänsten http://www.canyouseeme.org/ verkar ju lagom bra. Den säger nej på alla portar, även sånt som borde vara öppet för att mail och liknande ska funka......

Har du testat att sätta fast ip-adress på dina burkar, hade något liknande problem på någon äldre airport (tefatet). Där kom jag runt problemet med att sätta fast ip på alla burkar.

  • Medlem
  • Sollentuna
  • 2007-08-10 10:43
Ursprungligen av heinz_p:

På 2 har jag skrivit den IP som jag blir tilldelad, alltså 10.0.1.2. (har jag kontrollerat under Systeminställningar, Nätverk, Aiport, TCP/IP)

Här har vi felet:

En klassiker är att köra port forwarding till en dynamiskt tilldelad IP-adress (DHCP). Du får oftast samma port, men det finns inga garantier för detta. Olika tillverkare av SOHO-routrar tillämpar olika regler/följer standard olika när det gäller DHCP. Det ger att din (statiska) regel i routern jobbar mot en flyktig (dynamisk) IP-adress som din dator får.

Du måste alltså använda dig av fasta IP-adresser; antingen via manuell inställning i din dator eller via sk. adressreservering i routern (vilket bla Netgear har enorma problem med i några av sina modeller - bla WGR614v4 - v7). Såvida inte du använder sig av NAT Port mapping (kallas också ibland för UPnP tror jag) som är ett protokoll för att prata med routrar och ställa in port forwardingen automatiskt i NAT-funktionen.

Hur som helst - det går, men då kan inte förvänta dig 100%-igt problemfri drift med dynamiska IP-adresser.

  • Medlem
  • Stockholm
  • 2007-08-10 14:48
Ursprungligen av frazze:

Här har vi felet:

En klassiker är att köra port forwarding till en dynamiskt tilldelad IP-adress (DHCP). Du får oftast samma port, men det finns inga garantier för detta. Olika tillverkare av SOHO-routrar tillämpar olika regler/följer standard olika när det gäller DHCP. Det ger att din (statiska) regel i routern jobbar mot en flyktig (dynamisk) IP-adress som din dator får.

Du måste alltså använda dig av fasta IP-adresser; antingen via manuell inställning i din dator eller via sk. adressreservering i routern (vilket bla Netgear har enorma problem med i några av sina modeller - bla WGR614v4 - v7). Såvida inte du använder sig av NAT Port mapping (kallas också ibland för UPnP tror jag) som är ett protokoll för att prata med routrar och ställa in port forwardingen automatiskt i NAT-funktionen.

Hur som helst - det går, men då kan inte förvänta dig 100%-igt problemfri drift med dynamiska IP-adresser.

Om så var fallet skulle ju inte problemet kvarstå då han ansluter datorn direkt till adsl-modemet, och dessutom DHCP försöker alltid att dela ut samma adress till maskinerna igen som de hade innan, normalt försöker tom klientern fråga om den adress som de hade innan är ledig så de kan få den.

Airportens portforwarding är faktiskt väldigt enkelt och smart uppbyggd, inkommande port, till IP & port egentligen så det är som nära på omöjligt att göra fel.

100% säker drift med DHCP är en barnlek att sätta upp om man endast har lite koll på vad som man sysslar med, DDNS exempelvis löser alla problem som kommer upp och fasta portforwards funkar utmärkt.

1
Bevaka tråden