Safari - Automatisk ifyllning av formulär

Tråden skapades och har fått 7 svar. Det senaste inlägget skrevs .
1

Jag har sökt runt här på forumet och hittat en del trådar som rört vid ämnet, dock inget som hjälpt mig att lösa mitt problem.

Det är såhär att jag provade att installera beta-versionen av Safari 3 för att sedan avinstallera den med hjälp av AppZapper.

När jag gjort detta la jag in paketet för Safari 2.0.4 igen vilket fungerar strålande ur alla aspekter utom en.

Även om webläsaren är inställd att komma ihåg lösenord och dyl. så gör den aldrig det numera.

De ända fallen den automatiskt loggar in mig är på de sidor som har cookies. Men i de fallen där jag själv behöver fylla i informationen så får jag fylla i hela fälten.

Ända lösningen jag hittade här på forumet gällande detta var att totalt skapa en ny användare, rensa nyckelringarna och börja från början. Något jag själv tycker låter på tok för drastiskt och något jag hoppas inte skall vara nödvändigt.

Ursprungligen av blackline:

Det är såhär att jag provade att installera beta-versionen av Safari 3 för att sedan avinstallera den med hjälp av AppZapper.

När jag gjort detta la jag in paketet för Safari 2.0.4 igen vilket fungerar strålande ur alla aspekter utom en.

Även om webläsaren är inställd att komma ihåg lösenord och dyl. så gör den aldrig det numera.

Du skulle nog inte använt AppZapper när du tog bort Safari 3, med till Safari3 betan finns en avinstallerare som återställer till Safari 2.0.4, för mig fungerade det utan problem när jag avinstallerade Safari 3 betan med den medföljande avinstalleraren.

Ok. Frågan i så fall blir hur jag agerar från den situationen jag är i nu.

Jag är väl beredd att bli av med alla sparade lösenord och dyl, bara jag får funktionen att fungera igen.

Prova detta förfarande.
Ladda ner Safari 3 beta. Kom för övrigt en ny version idag 3.0.3.
Installera. Tror det följs av en omstart.
Sen kör du den avinstallerare som följer med direkt därefter.

Jag gjorde precis så, och har nu satt mig i en situation som verkar väldigt mycket mer kritiskt än innan.

Nu fungerar i stort sett ingenting med ett fåtal undantagsfall.

Om jag t.ex. startar Safari, Mail eller Adium i terminal så får jag liknande felmeddelande:

"blackline:/Applications/Safari.app/Contents/MacOS blackline$ ./Safari
dyld: Library not loaded: /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore
Referenced from: /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit
Reason: image not found
Trace/BPT trap"

Ursprungligen av blackline:

Nu fungerar i stort sett ingenting med ett fåtal undantagsfall.

Det beror på att Safari inte bara är en fristående webbläsare. Safari är inbyggt med OS X som gör att andra program också kan nyttja dess renderingsteknik för webbsidor.

Jag startar en ny tråd då jag antar att detta är att betrakta som ett nytt problem.

http://www.99.se/mac-os-x/221520-dyld-library-not-loaded.html

Jag vet inte om det var nödvändigt med den nya tråden. Den visar nu inte förhistorien.

Det verkar som avinstallationen med AppZapper du gjorde tidigare ställer till det. Som jag ser det har du dessa val.

1. Testa att ladda ner och installera OS X 10.4.10 combo update (länken är för intel men det finns en liknande för PPC). Med lite tur lägger den tillbaka de saknade filerna.

2. Installera om Safari 2 från systeminstallationsskivan. Det går att installera enstaka program med ett program som heter Pacifist. Du ska leta på Safari.pkg eller liknande på installationsskivan och m h a Pacifist går det att installera.

3. Installera Safari 3 och använd den.

1
Bevaka tråden