bad link wordpress.com och flickr

Tråden skapades och har fått 4 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • International user
  • 2007-05-31 17:33

Jag har klistrat in

http://www.flickr.com/photos/76021273@N00/

på min blog
http://bopersson64.wordpress.com

men när jag testar länken har '@' försvunnit och länken blir 'bad link'. Att jag är trött på att försöka fler gånger är bara ett understatement. När jag trycker 'edit' och ska korrigera finns '@' med.

Några kloka förslag?:confused:

  • Medlem
  • Stockholm
  • 2007-05-31 18:27

Kan vara så att din blogleverantör filtrerar bort @ i url:er av någon anledning. Prova att byta ut "@" mot "%40" när du skriver in länken. Kan hjälpa.

  • Medlem
  • International user
  • 2007-05-31 18:39

Det fungerade! Hur skulle man klara sig utan 99mac.se? Är '%40' någon kod för '@'? Nu vill jag veta.

  • Medlem
  • Stockholm
  • 2007-05-31 19:09

Ja, så är det. HTML stöder hela teckenuppsättningen, men definitionen av URL:er tillåter bara A-Z, a-z, 0-9 och några andra reserverade tecken. @ är med bland de reserverade tecknen och när man ska skriva ut dem på annat sätt än vad som var tänkt när de reserverades, så måste man koda dem med s.k. "URL encoding" som består av ett procenttecken följt av den hexadecimala ASCII-koden.

Jag vet inte om jag klargör något eller inte just nu...

  • Medlem
  • International user
  • 2007-05-31 20:46
Ursprungligen av macce:

Ja, så är det. HTML stöder hela teckenuppsättningen, men definitionen av URL:er tillåter bara A-Z, a-z, 0-9 och några andra reserverade tecken. @ är med bland de reserverade tecknen och när man ska skriva ut dem på annat sätt än vad som var tänkt när de reserverades, så måste man koda dem med s.k. "URL encoding" som består av ett procenttecken följt av den hexadecimala ASCII-koden.

Jag vet inte om jag klargör något eller inte just nu...

Du klargjorde det väldigt väl. Jag antar att man kan söka på "URL encoding" och lära sig mycket nyttigt.

1
Bevaka tråden