Problem med borders i IE

Tråden skapades och har fått 7 svar. Det senaste inlägget skrevs .
1

Hej!
Har ett IE problem (vem har inte det).

Jag har gjort så kallade borders runt journal artiklar i ett CMS system. Detta har jag naturligtvis gjort i CSS. Dessa borders använder sig av 1-pixel grafik lösning och jag kör repeat x + repeat y.

Problemet är att i IE så blir det ett hack i hörnet på varje artikel, precis som om det skulle fattas pixlar. Det ser perfa ut i Safarin + FF på PC men ej så klart i IE

Någon som har en idé om vilken typ av fix man skulle kunna åtgärda detta med och vad det kan bero på? Jag har ingen möjlighet att slänga upp sidan här tyvärr

IE - I hate you...

Ursprungligen av Matador2003:

Jag har ingen möjlighet att slänga upp sidan här tyvärr

Inte ens ett par skärmdumpar? ...för att visa skillnaderna

  • Medlem
  • Mölndal
  • 2007-05-15 10:46

Man kan ju också spara ner sidan med tillhörande filer. Innehållet kan ju vara hemligt iofs. Om "journal" innebär sjukhusjournal är det ju säkert så.

  • Medlem
  • Uppsala
  • 2007-05-15 12:26

Kanske du redan testat.. men prova att sätta paddning: 0px
och eller margin 0 0px;
brukar få IE att göra ifrån sig lite bättre..

Hej!
Tog skärmdumpar här av både Explorer samt Safari/FF där man tydligt kan se skillnaden.

Det jag gjort är att jag använt mig av repeat funktion, om man tittar på nederdelen av artiklarna så ser man att dessa pixlar (1 pixel bred gif) drar inte ända ut i Explorer som i Safarin. Man kan ju inte mig veterligen sätta ett värde på en repeat? Så hur göra

Senast redigerat 2007-05-15 15:33
  • Medlem
  • Mölndal
  • 2007-05-16 14:12

Grejen är att i IE så går kanterna inte omlott alls, utan "högerkanten" börjar lite nedanför toppen och går hela vägen ner osv. Lite ascii art får illustrera, (h)öger, (v)änster, (u)pp, (n)er:

vuuuuu
v    h
v    h
v    h
v    h
nnnnnh

Ja just det ja... så var det! M$IE utvecklare var fulla när det gjorde Box-modellen.
Eller det kanske tänkte "Think Different" och gjorde olikt alla andra.

Hedman, jag blev nästan orolig där ett tag Du brukar ju svara inom 24 timmar på mina inlägg hehe.

Angående problemet: Problemet löst! Det löste sig med att jag satte dit float left av någon anledning.

Kan man hata Explorer mer än jag gör?

1
Bevaka tråden