Irssi och terminalen

Tråden skapades och har fått 5 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Habo
  • 2007-05-13 17:29

Hej
Om det är någon duktigare än jag som kan hjälpa med detta skulle jag bli glad.

Kör irssi med terminalen i mac men det är vissa problem.

1. i linux-terminal kör man alt+1,2,3 för växla mellan kanaler.. detta funkar inte då Alt+2 blir @ exempelvis.. det går ändra detta i inställningarna för terminalen men då går det istället inte skriva några @.. så kör man på vanliga inställningen så kan man använda ESCAPE+1,2,3 för att byta kanal... lite konstigt men det är så jag får göra... Finns det någon lösning på detta.

2. Hur jag än försöker ändra encodingen blir det antingen jag eller alla andra som upplever ÅÄÖ som mysko tecken. Vad är lösningen? Terminalens encoding-alternativ är väldigt kort.

Jag kör irssi på en burk som jag ssh:ar till från min Mac. Mina inställningar (Fönsterinställningar) i Terminalen är:

Tangentbord: Kryssa i "Delete-tangenten ger backsteg"
Emulering: Se till att "Escape icke-ASCII-tecken" är urkryssad
Skärmutseende: Välj "Västerländsk (ISO Latin 1)" under "Teckenuppsättningskodning"

Tror det är allt jag har pillat med och det verkar fungera.

  • Medlem
  • Habo
  • 2007-05-17 02:27

Med dina inställningar:
02:20 < soft> ååäö <-- ser jag när jag skriver ÅÄÖ
(de jag skrev till såg däremot åäö och inte skum-tecken)

Och ALT+1, 2, 3 går inte använda till att byta kanaler .. ESC+1,2,3 funkar däremot.
Hur byter du kanal?

Ursprungligen av soft:

Med dina inställningar:
02:20 < soft> ååäö <-- ser jag när jag skriver ÅÄÖ
(de jag skrev till såg däremot åäö och inte skum-tecken)

Mycket märkligt. Gick igenom mina inställningar nu igen och hittade ingenting annat jag har pillat med. Jag ska kolla lite till.

"Kanalbytesproblemet" går inte att lösa, om du inte mappar om tangenter och har dig. Hittar du något terminalprogram som har stöd för någon annan tangent än Escape eller Alt som meta-tangent så kan det nog gå att lösa.

Kör du senaste irssi? Jag hade nångång problem med åäö hos andra som ja tror körde UTF-8 och då löste det sig med en upgradering av irssi.

1
Bevaka tråden