åäö + backspace i Terminalen

Tråden skapades och har fått 10 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Hedemora
  • 2007-01-30 22:51

I OS X när man trycker åäö:

emil@emils-macbook.local: ~ $ \303\245\303\244\303\266

När man listar filer:

emil@emils-macbook.local: ~ $ ls -l
drwxr-xr-x     2 emil  emil    68 Jan 29 14:05 a??a??o?? test a?? tes a?? tes o??

Problem 2:
När man loggat in på någon Linux maskin eller likande så funkar inte backspace ibland.
Om man har tex bokstäverna:
Hej! Jag he|ter Emil
Och sen trycker backspace när markören är vid pipen (| , i "heter") så raderar man baklänges. Alltså att "t", försvinner, sen "e" osv...
Och ibland funkar det inte alls.

Någon som vet vad detta beror på?

  • Medlem
  • Stockholm
  • 2007-01-31 18:56

Problem 2: Terminal -> Fönsterinställningar -> Tangentbord -> Bocka för Delete-tangenten ger backsteg

  • Medlem
  • Hedemora
  • 2007-01-31 19:08
Ursprungligen av .mp3:

Problem 2: Terminal -> Fönsterinställningar -> Tangentbord -> Bocka för Delete-tangenten ger backsteg

Tackar!
Då var väl det viktigaste löst. Men det vore ju bra om man kunde få igång åäö i OS X också...

Problem 1: Lägg till:
set convert-meta off
set input-meta on
set output-meta on
i filen .inputrc direkt i din hemmapp.

Står mer om hur och varför här

  • Medlem
  • Hedemora
  • 2007-02-01 21:54
Ursprungligen av tharkun:

Problem 1: Lägg till:
set convert-meta off
set input-meta on
set output-meta on
i filen .inputrc direkt i din hemmapp.

Står mer om hur och varför här

Tackar tackar!
Då var det bara "ls" problemet kvar. men jag fortsatte i andra tråden.

Hm. Verkar inte funka för mig. Inte blir det lättare när man är nybörjare i terminalen heller.

Ställer mig i hemmappen med kommandot "cd", sen "touch .inputrc", "open .inputrc", lägger till de tre raderna, sparar i textredigeraren och skriver "bash" (startar om bash?). ÅÄÖ funkar fortfarande int.

Några tips/förslag?

Ursprungligen av tharkun:

Problem 1: Lägg till:
set convert-meta off
set input-meta on
set output-meta on
i filen .inputrc direkt i din hemmapp.

Står mer om hur och varför här

Stort mega-TACK! Nu funkar det som det ska!

Här är ett tips som funkade bra för mig:

How do I get UTF–8 input to work correctly?

In the Terminal Inspector:
In the Emulation section, turn off the Escape non-ASCII characters option.
In the Display section, choose Unicode (UTF-8) as the Character Set Encoding.
Add the following line to your .profile:
export LC_CTYPE=en_US.UTF-8
Add the following lines to your .inputrc:
set meta-flag on
set input-meta on
set output-meta on
set convert-meta off
Apply changes by doing a source ~/.profile and a bind -f ~/.inputrc.

How do I get UTF–8 input to, you know, work correctly?

There’s an odd bug in the version of bash included with Mac OS X 10.4 that manifests itself as the LC_CTYPE enviroment variable not being set properly by export directives in .profile files. The workaround involves using the little–known environment.plist file. Thanks to Allan Odgaard for the tip!
Add a LC_CTYPE key with the value en_US.UTF-8 to the root dictionary of the ~/.MacOSX/environment.plist file.
Assuming that you don’t have that file, the easiest way to do this is to execute the following command:
echo "{ LC_CTYPE = \"en_US.UTF-8\"; }" > ~/.MacOSX/environment.plist
You could also use Property List Editor.app.
Apply changes by logging out and back in.

*

Notera att du troligen måste skapa katalogen .MacOSX för hand. Ställ dig i hemkatalogen och gör

mkdir .MacOSX

sen kan du skapa den däringa plist-filen.

Intressant. Gav upp allt ett tag efter att ha testat att ändra fönsterinställningar och .inputrc. Ägnade mig åt andra aktiviteter i ett par timmar, och när jag kom tillbaka till datorn... jaha, då funkade åäö som det ska! Kul, men det hade nog varit trevligare om jag fått reda på vad som var den egentliga lösningen...

Mer problem!

NOTERA: Diskusionen nedan gäller Latin1 == ISO-8859-1 åttabitars kodning!!!

I min nya Mac (Mac Mini OS-X 10.5 till skillnad från den tidigare diskussionens 10.4 och tidigare, min iBook funkar perfekt) så funkar det annorlunda! I Terminal funkar åäö klyddigt, det är någon fördröjning så att bokstäverna kommer ut lite hur som helst. Om man har .inputrc som ovan i diskussionstråden så funkar xterm i X11 klanderfritt (X11 fanns med förinstallerat i systemet, tack för det) men nu kommer det riktigt skrämmande: om man startar xterm inifrån Terminal på kommandoraden så klyddar xterm också!!! (Men om man startar Terminal inifrån xterm så klyddar Teminal med åäö precis som vanligt).

ALLTSÅ:
1) Terminal bryr sig inte om .inputrc och felet är annorlunda än förr med åäö.
2) xterm verkar funka felfritt och anpassa sig till .inputrc (men inte om den startas från Terminals kommandorad).

Just nu är jag nöjd med att ha fått åtminstone xterm att funka men Terminal funkar INTE. Någon som har ett hum om vad som ligger bakom det här perversa beteendet?

Anders Holtsberg

Eftersom ingen har svarat så svarar jag själv:

Man måste avmarkera "Ställ in LANG-miljövariabel vid start" under kodningsvalet för terminalen i avancerat i inställningar. Då funkar det. Kolla följande kaos i Terminalen, där jag skriver exakt "xåäöx" varje gång efter echo:

> echo xåäöx
xåäöx
> export LANG=sv_SE
> echo xåäö
xåäö
> xecho xåäö
-bash: xecho: command not found
>

Alternativt sätter man LANG till sv_SE.ISO-8859-1 eller sv_SE.BLABLABLA; då funkar det också bra.

Notera att man fortfarande måste ha .inputrc enligt tidigare diskussion i tråden.

mvh

Anders H

1
Bevaka tråden