Hur fixa upphöjd 2:a på webbsida?

Tråden skapades och har fått 8 svar. Det senaste inlägget skrevs .
1

Jag vill skriva en upphöjd 2:a för kvadratmeter på en webbsida.

Har du en modern webbläsare/operativ så ser det riktigt ut här:

men inte här:
m2.

Om man kopierar m² i OS X och klistrar in i TextEdit så kan man se att det är ett unikt tecken och inte en style i ett stylesheet som använts. Tar man sen fram Character Palette i OS X så kan man luska fram att det är Unicode 00B2 jag vill skriva. Den ligger under rubriken Digits.

Dreamweaver: Klipp och klistra gör om 2:an till en vanlig 2:a. Dubbelklick av den upphöjd 2:an i Character Palette förstår tydligen inte Dreamweaver. Man kan däremot mata in andra tecken på samma vis.

Hur får jag in detta i Dreamweaver?

Hejsan!
Koden för upphöjd 2a är ² det syns inte i Dreamweaver av ngn anledning men det syns i browsern
upphöjd 3a är följdaktligen ³

Lycka till
Micke

*ändring* hahahaha! det är ju klart att det blir upphöjda siffror när jag skriver koden så jag skriver ut den igen med mellanslag mellan varje tecken.
& s u p 2 ;
resp
& s u p 3 ;

Micke

Tjusigt!

  • Oregistrerad
  • 2003-04-03 12:10

<sup> kod sen </sup>
<sub> för nehöjt </sub>

Så enkelt var det inte...

Jag skriver in &-tecknet i kodfönstret och fram hoppar en meny med dessa specialtecken. Jag bläddrar ner till den du angivit och skriver in den. I visningsläget ser jag sen m"É2;. Explorer visar ett summatecken.

Jag testar samma sak i GoLive och i layout-läge visar den en liten ruta med ett & inuti och preview i Explorer ger även där ett summatecken.

För att visa att koden är riktig så klistrar jag här in direkt från kodfönstret i Dreamveawer: 321 000 m²

Citat:

Skrevs ursprungligen av Ekelund
<sup> kod sen </sup>
<sub> för nehöjt </sub>

Jag testade detta och de6 fungerar, men man måste ju komplettera med en style som drar ner storleken på 2:an för att det ska bli snyggt. Den där unicode-prylen sitter som en smäck direkt bara man får den att funka.

jag har inga som helst problem !
dreamweaver visar det du skriver en det får man strunta i helt enkelt
men annars så funkar det i explorer, safari, opera och mozilla

Det funkar nu. Fick tömma cachen i alla browsers innan de fattade vad som stod på. Dreamweaver visar fortfarande 3 kryptiska tecken i layout-läge men det kan jag leva med.

Nu ser jag en annan skum pryl. Explorer i OS X har problem med det där tecknet. Den lägger in ett mellanrum efter tecknet så det ser ut som dubbla mellanslag. Jag provade Explorer i Win98 och där ser det riktigt ut.

Testa med den här texten i era browsers:

321 000 m² utställningsyta

1
Bevaka tråden