Mac Pro startar inte med nya diskar

Tråden skapades och har fått 27 svar. Det senaste inlägget skrevs .
1

Okej, här har vi ett knivigt problem som jag gått bet på. Kör en Mac Pro, som bekant har fyra platser för hårddiskar, varav tre är lediga i standardutförande. Nu har jag kommit över tre begagnade 80 GB Hitachi Deskstar-diskar att fylla upp med. Diskarna är partitionerade och klara (de är plockade ur Apple Xserve G5-maskiner och har fungerat utan problem). Men av någon mystisk anledning vägrar Mac Pron starta med diskarna monterat i lagringsplatserna. Har provat alla tre på en gång, och olika diskar var för sig. Inget fungerar. Får upp parkeringsförbudsmärke efter start... inget händer. Någon som har någon ide på vad det kan vara?

/M

Har gjort ytterligare lite research nu. Startar jag med "alt" nertryck får jag upp min vanliga OSX-startpartition och BootCamp-partitionen... inget ytterligare. Jag väljer OSX-partitionen, varefter uppstartprocessen upphör och ovanstående symbol dyker upp.

Har också testat att starta maskinen i target mode. I detta läge får jag bara upp standarddisken med OS X och Win-partitionen.

Hur fasen ska jag få diskarna att dyka upp så jag kan partitionera dem?

/M

  • Medlem
  • Göteborg
  • 2007-01-11 21:34

Prova att boota från en tiger dvd/cd ser du diskarna då?

Nej, det har jag inte gjort.. men jag har ju bootat från en annan maskin i target mode, borde väl inte vara någon större skillnad.

/M

Verkar ha hitta felet själv. Diskarna levererar bara 1.5 gigabyte/sekund, Mac Pron verkar kräva SATA-diskar som kan skyffla 3.0 gigabyte information/sekund.

/M

  • Medlem
  • Stockholm
  • 2007-01-11 22:28

Kolla diskarna efter en jumper som switchar mellan 1.5 och 3 GB/s. Jag hade sådana på mina diskar...

Hm, nä, detta verkar vara gamla diskar som inte klarar 3 gb/s.
http://www.hgst.com/portal/site/hgst/menuitem.268b770f407cc00ae4c0c516bac4f0a0/

/M

  • Medlem
  • International user
  • 2007-01-14 18:18
Ursprungligen av Martin Belak:

Hm, nä, detta verkar vara gamla diskar som inte klarar 3 gb/s.
http://www.hgst.com/portal/site/hgst/menuitem.268b770f407cc00ae4c0c516bac4f0a0/

/M

Det har jag fått bekräftat från en tillverkare. Diskarna är inte SATA2. Jag har frågat runt lite med anledning av min dator-SATA kort- och diskar. I mitt fall är datorn den stora flaskhalsen men inte ens med den vassaste G5 hade en SATA2 blivit snabbare än en SATA.

  • Medlem
  • Göteborg
  • 2007-01-11 23:18

Det lät riktigt konstigt. Jag kör med en Raptor och den klarar inte att skyffla i 3 GB/s det är alltså inte en sata 2 disk. Jag tror inte att det är det beror på.
Vad har du för jumprar på diskarna?

Hm.. det sitter inga jumprar på dessa diskar.

/M

Mysteriet fortsätter, idag testade jag att starta maskinen i Windows XP-miljö med Boot Camp. Till min stora förvåning ploppade den nya disken upp där, jag formaterade den och kunde använda den utan problem. Men när jag försöker starta i OS X-läge igen händer samma sak som förr, förbudstecknet ploppar upp och bootsekvecen avbryts. Fattar inte ett jota länge, onekigen verkar hårdvaran ha stöd för disken... men skulle inte OS X gilla den? Diskarna har ju suttit i OS X-maskiner tidigare!?

Helt obegripligt för mig.

/M

  • Medlem
  • International user
  • 2007-01-14 18:09

Jag får samma ikon då och då vid uppstart av min G4 Digital Audio med SATA-kort och dito hårddisk. Förbudstecknet ploppar upp då och då vid uppstart även med min fungerande SATA skiva men låter jag datorn gå någon/några minuter så blir jag tillslut insläppt. Kan det vara så att man inte kan använda en SATA2 disk i min dator? För övrigt kan jag inte använda de nya skivor som jag köpt. De ploppar inte upp så jag kan inte formatera dom.

Men det skumma är ju att SATA ska vara bakåtkompatibelt, dvs. datorns SATA-kontroller ska kunna ställa ner hastigheten till SATA 1 (1.5Gb/s) när den kommunicerar med dissken. Detta verkar den ju också göra, i och med att det fungerar om jag bootar med Windows XP... fattar bara inte varför OS X inte gillar diskarna.

/M

  • Medlem
  • Stockholm
  • 2007-01-14 18:48

Defekt logikkort i datorn? Har du testat den?

  • Medlem
  • International user
  • 2007-01-14 18:52
Ursprungligen av Mondo:

Defekt logikkort i datorn? Har du testat den?

och hur gör man det?

  • Medlem
  • International user
  • 2007-01-14 18:53

I mitt fall fungerar iofs datorn i övrigt, med undantag för att min Zip-skiva inte poppar upp.

Verkar ha med SSC att göra!? Vissa SATA2-diskar har det påslaget som default, andra inte. SSC funkar inte med Mac. Se mer i den här tråden
På en PC kan man tydligen via ett litet program stänga av SSC.

  • Medlem
  • Stockholm
  • 2007-01-30 19:04

Det har med partitionstypen att göra... Intel-Macar har "GUID_partition_scheme", PPC-burkar "Apple_partition_scheme". Men varför ställer du inte frågan till Apple eller en Apple-auktoriserad tekniker? De borde kunna ge raka och direkta besked.

Ändrad: hittade svaret här efter en minuts googlande. Och här också.

Senast redigerat 2007-01-30 19:18
Ursprungligen av Mondo:

Det har med partitionstypen att göra... Intel-Macar har "GUID_partition_scheme", PPC-burkar "Apple_partition_scheme". Men varför ställer du inte frågan till Apple eller en Apple-auktoriserad tekniker? De borde kunna ge raka och direkta besked.

Ändrad: hittade svaret här efter en minuts googlande. Och här också.

Grejen är ju inte att jag försöker boota FRÅN G5/PPC/APM-diskarna, nej, jag bootar som vanligt från MacProns standarddisk, men G5/PPC/APM-diskarna monterade i de övriga disk-platserna. Men datorn vägrar som sagt att boota över huvudtaget så länge någon av dessa diskar sitter i, trots att jag faktiskt inte bootar från dem.

/M

  • Medlem
  • Stockholm
  • 2008-01-10 18:20

har det löst sig för dig martin ? jag har samma problem, har 3 diskar som jag tidigare hade i en G5a, har formaterat om dem i g5an men intel macen startar inte med dom i, vad är workarounden ? har läst i länkarna ovan att det gäller diskar med två olika system men mina diskar är tomma, var och hur ska jag formatera dom ??

Jag skulle tro att det har med att den är inställd på Apple Partition Scheme som Mondo säger,

Här finns hur man omformaterar en disk till GUID som krävs för en intel mac. http://docs.info.apple.com/article.html?artnum=303220

Räcker ej att bara omformatera utan man måste göra ett aktivt val för att få GUID, se apples support artikel för mer info.

  • Medlem
  • Stockholm
  • 2008-01-11 17:36

och hur är det tänkt att man ska göra det när datorn inte startar med diskarna i då ??

och vad händer när man köper en ny hårdisk ? ska man först formatera den i en annan dator innan intelburken kan tänka sig att starta.. ?

proffsigt, har just formaterat alla diskarna i en väns g5a, i GUID... får se om det funkar, tillbaks om 15 förhoppningsvis..

En uppföljning från mig, nej jag har inte lyckats få mina diskar att fungera. Hittade aldrig någon lösning som fungerade. Och precis som gabrael skriver, hur ska jag partitionera om dem mes Skivverktyget när Macens inte ens startar med disken i, (trots att den befintliga systemdisken med fungerande systeminstallation också sitter i).

/M

Du kan ju komma åt skivverktyg genom att boota från installations-DVD'n, välj Skivverktyg i "Verktyg"-menyn.

Jag kan inte boota från någonting, datorn kommer inte igång utan fastnar under boot-processen.

/M

  • Medlem
  • Sundsvall
  • 2008-01-12 09:43

Om det är diskarna som Björnström har haft över är det bara ge upp tror jag. Dessa diskar har en firmware som är byggd för en specifik kontroller. Jag har haft 8st sådana diskar, jag har lyckats få de att fungera i en av fem datorer. Ingen raidkontroller tar emot dem vad jag testat, en 3ware 9500s körde jag först, den kunde hitta diskarna, skapa en array, sedan dog diskarna, gick aldrig mer att använda tyvärr. Arrayen ville skriva till firmwaren men eftersom det var en apple-specialfirmware så sket sig allt.

Slutsats. Uppstår ett problem kan det vara svårt att göra något, för det är en mycket stor risk att det är firmware-relaterad problem.

Japp, det är lika diskar som dina Sidde. Med Leopard i MacPron startar i alla fall burken, men det verkar inte finnas något sätt att hitta disken, den kommer varken upp i Skivverktyget eller med de diskutil i unix. Tror jag kastar in handuken en gång för alla vad gäller dessa diskar.

/M

Jag har använt gamla hårddiskar som "guldskivor". Öppnat dem och blottat mekanismen, skruvat fast dem på en sköld (en sån där träplatta som man monterar djurhuven på väggen med). En plakett under med texten "För mångårigt arbete på vår IT-avdelning" etc. Sedan har man gett dem till folk som slutat på jobbet etc.

Hade en 10-kilos drive en gång som min gamla skola fick och hade i undervisningssyfte....

Nästa firmafest; kast med liten hårig disk. Strappa ihop dem med buntband till ett "RAID-cluster" ...

1
Bevaka tråden