Fel när man använder "back"-knapp

Tråden skapades och har fått 3 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2003-03-12 10:29

När jag på min PC (IE5) klickar på back-knappen, i stället för att klicka på en länk som tar mig tillbaka till sidan jag var på, blir sidan jag kommer till ofta korrumperad.

Längst upp på sidan får jag se en hel del kod (se exempel nedan) som egentligen borde ha parsats på serversidan, och jag får även 30-40 javascript-fel, eftersom det saknas kod på sidan.

Kan det vara någon inställning på servern som kan trimmas?

Jag får aldrig detta fel på andra UBB-forum, endast på 99mac och 99musik.

/J

Busenkelt vad felet är. Martin har nu (äntligen!) byggt in en spärr så att man inte ska kunna använda PC och deras webläsare på en Mac-sida

  • Oregistrerad
  • 2003-03-18 19:54
Citat:

citera:Skapades ursprungligen av: Christoffer Larsson:
Busenkelt vad felet är. Martin har nu (äntligen!) byggt in en spärr så att man inte ska kunna använda PC och deras webläsare på en Mac-sida

Vi får väl se om spärren införs i version 3.0, eller om problemet som jag har försvinner på annat sätt. Som det är nu får man ju se en hel del kod emellanåt vilket knappast kan vara bra ur säkerhetssynpunkt.
Som alldeles nyss:

ry,post_j,poll) { var new_locked_folder; var hot_new_topic_folder; var new_topic_folder; var old_locked_folder; var hot_old_topic_folder; var old_topic_folder; if(poll) { new_topic_folder = "poll_new.gif"; hot_new_topic_folder = "poll_new.gif"; new_locked_folder = "poll_new_locked.gif"; new_moved_folder = "moved_new.gif"; old_topic_folder = "poll_old.gif"; hot_old_topic_folder = "poll_old.gif"; old_locked_folder = "poll_old_locked.gif"; old_moved_folder = "moved_old.gif"; } else { new_topic_folder = "closedb.gif"; hot_new_topic_folder = "hotclosedb.gif"; new_locked_folder = "redlockfolder.gif"; new_moved_folder = "moved_new.gif"; old_topic_folder = "closed.gif"; hot_old_topic_folder = "hotclosed.gif"; old_locked_folder = "yellockfolder.gif"; old_moved_folder = "moved_old.gif"; } // end if // Workaround for browsers that think this is an IMG tag... var before = ´<´ + ´im´ + ´g src=´ + ´"http://99mac.com/ubb/´; var after = ´" border="0" alt="´; var later = ´" />´; if (post_j > session_j) { if (closed_topic == "X") { return(before + new_locked_folder + after + "[new closed]]" + later); } else if (closed_topic == "M") { return(before + new_moved_folder + after + "[new closed]]" + later); } else if (fiery == "yes") { return(before + hot_new_topic_folder + after + "[new hot]" + later); } else { return(before + new_topic_folder + after + "[new]" + later); } } else { if (closed_topic == "X") { return(before + old_locked_folder + after + "[old closed]" + later); } else if (closed_topic == "M") { return(before + old_moved_folder + after + "[old closed]" + later); } else if (fiery == "yes") { return(before + hot_old_topic_folder + after + "[old hot]" + later); } else { return(before + old_topic_folder + after + "[old]" + later); } } return true; } //-->

[ 18. mars 2003, 19:55: Meddelandet ändrat av: Goka ]

  • Oregistrerad
  • 2003-03-25 10:37

Problemet kvartstår även i version 3.02, om än int lika kraftigt som med UBB. Tidigare fick jag som sagt ett stort anta javascript-felmeddelanden, men vBulletin verkar inte vara uppbyggt på samma sätt.

Nyss fick jag dock det här längst upp på sidan, vilket också innebar att bakgrundsfärgen inte fanns:

f" alt="Frequently Asked Questions" border="0">

Det måste vara någon slags buffer någonstans som inte funkar. Jag har som sagt aldrig stött på problemet någon annanstans än på 99mac och 99musik.

1
Bevaka tråden