TiBook-upplösning i Q3A

Tråden skapades och har fått 17 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2002-11-12 12:50

Jag undrar om någon vet hur man kan ställa in att Quake 3 Arena körs i 1152x768 på en TiBook. Det känns lite trist att ha de svarta sorgkanterna vid sidan om bilden som man får när man kör en 4:3-upplösning (1024x768). Jag kör 1.32 under OS X 10.2.

Så vitt jag vet så stödjer Q3 widescreen-upplösningar. Eller så blandar jag ihop det med UT.

  • Oregistrerad
  • 2002-11-12 14:22

Den enda widescreen-upplösning som dyker upp när man väljer upplösning är 856x480 vilket varken passar eller fungerar. Finns det nån konfigurationsfil som beskriver vilka val som ska finnas? Eller kan jag manuellt ställa in i min .cfg att 1152x768 ska användas?

Det ska gå att manuellt ställa in storleken, någon Quake-guru får förklara närmare.

Eftersom jag vet att det finns väldigt Quake insatta här vill jag passa på att fråga en om en störande sak med. Fast jag har ändrat max fps:en till 300 i config filen ligger den på 60 hela tiden. Tidigare hade jag en fps mellan 150 och 250 men utan att jag kan komma på att jag ändrat något ligger den stabilt på 60 hela tiden nu. Jag kan sänka max fps men inte höja... Detta är i XP och inte på Mac, men iaf... Någon kanske vet.

  • Medlem
  • Stockholm
  • 2002-11-12 16:53

seta r_mode "-1"
seta r_customaspect "1"
seta r_customheight 768"
seta r_customwidth "1024"
seta r_fullscreen "1"

Dunka ner det i konsollen, sen skriver du /vid_restart och hoppas på det bästa.

  • Medlem
  • Stockholm
  • 2002-11-12 16:55
Citat:

quote:Skapades ursprungligen av: zodi:
Eftersom jag vet att det finns väldigt Quake insatta här vill jag passa på att fråga en om en störande sak med. Fast jag har ändrat max fps:en till 300 i config filen ligger den på 60 hela tiden. Tidigare hade jag en fps mellan 150 och 250 men utan att jag kan komma på att jag ändrat något ligger den stabilt på 60 hela tiden nu. Jag kan sänka max fps men inte höja... Detta är i XP och inte på Mac, men iaf... Någon kanske vet.

Skriv /com_maxfps eller vilken cmd det nu är, och kolla så att den verkligen har det värde du vill att den ska ha.

Sen behöver du inget mer än 125 vad gäller fysiken i spelet.

  • Oregistrerad
  • 2002-11-12 18:58

Tack för tipset Linus, men det fungerade inte. Det var föresten inte 1024 i bredd utan 1152 jag eftersträvade. Det kanske är så illa att Quake inte fixar att köra med PowerBookens upplösning på 1152x768...

Tack för tipset Linus, men det fungerade inte.

Då ändrar man ju i config filen, vilket jag gjort en massa nu. Det fungerara att sänka fps taket på det sättet men inte att höja. Och eftersom det fungerade förut så vet jag att min version stöder det. Kanske har något med systemet att göra så jag skall nog fråga på ett annat forum...

  • Medlem
  • Piteå
  • 2002-11-12 19:45
Citat:

quote:Skapades ursprungligen av: Mattias Malm:
Tack för tipset Linus, men det fungerade inte. Det var föresten inte 1024 i bredd utan 1152 jag eftersträvade. Det kanske är så illa att Quake inte fixar att köra med PowerBookens upplösning på 1152x768...

alltså om du kör något över 800x600 så kommer de ju att lagga som fan på en powerbook.....men de kanske inte märks med tanke på skärmen?

  • Medlem
  • Stockholm
  • 2002-11-12 21:17
Citat:

quote:Skapades ursprungligen av: zodi:
Tack för tipset Linus, men det fungerade inte.

Då ändrar man ju i config filen, vilket jag gjort en massa nu. Det fungerara att sänka fps taket på det sättet men inte att höja. Och eftersom det fungerade förut så vet jag att min version stöder det. Kanske har något med systemet att göra så jag skall nog fråga på ett annat forum...

Har du kollat så att det verkligen är cfg´n som sänker maxfps´n, dvs att den har tex 60 i com_maxfps?

Kolla värdena i q3config.cfg, observera att det kan finnas fler än en (under osp tex).

Citat:

quote:Skapades ursprungligen av: Gadd:

Citat:

quote:Skapades ursprungligen av: Mattias Malm:
Tack för tipset Linus, men det fungerade inte. Det var föresten inte 1024 i bredd utan 1152 jag eftersträvade. Det kanske är så illa att Quake inte fixar att köra med PowerBookens upplösning på 1152x768...

alltså om du kör något över 800x600 så kommer de ju att lagga som fan på en powerbook.....men de kanske inte märks med tanke på skärmen?

Jag har i helgen kört igenom Max Payne på min Powerbook 800 med maxupplösning och det har inte laggat en enda frame, det flyter helt otroligt ! Det är för mig den första Mac jag ägt som detta varit möjligt på, min förra iMac 800 klarade inte detta, ATI-korten i de nya bärbara är helt fantastiska. Jag väntar med spänning på min 1Ghz maskin

  • Medlem
  • Piteå
  • 2002-11-12 23:55
Citat:

quote:Skapades ursprungligen av: Daniel Ström:

Citat:

quote:Skapades ursprungligen av: Gadd:

Citat:

quote:Skapades ursprungligen av: Mattias Malm:
Tack för tipset Linus, men det fungerade inte. Det var föresten inte 1024 i bredd utan 1152 jag eftersträvade. Det kanske är så illa att Quake inte fixar att köra med PowerBookens upplösning på 1152x768...

alltså om du kör något över 800x600 så kommer de ju att lagga som fan på en powerbook.....men de kanske inte märks med tanke på skärmen?

Jag har i helgen kört igenom Max Payne på min Powerbook 800 med maxupplösning och det har inte laggat en enda frame, det flyter helt otroligt ! Det är för mig den första Mac jag ägt som detta varit möjligt på, min förra iMac 800 klarade inte detta, ATI-korten i de nya bärbara är helt fantastiska. Jag väntar med spänning på min 1Ghz maskin

Men då vill ju jag veta vad du menar med "lagg"?

För mej är lagg allt under 80fps!! och de är sant

Citat:

quote:Skapades ursprungligen av: Gadd:

Citat:

quote:Skapades ursprungligen av: Daniel Ström:

Citat:

quote:Skapades ursprungligen av: Gadd:

Citat:

quote:Skapades ursprungligen av: Mattias Malm:
Tack för tipset Linus, men det fungerade inte. Det var föresten inte 1024 i bredd utan 1152 jag eftersträvade. Det kanske är så illa att Quake inte fixar att köra med PowerBookens upplösning på 1152x768...

alltså om du kör något över 800x600 så kommer de ju att lagga som fan på en powerbook.....men de kanske inte märks med tanke på skärmen?

Jag har i helgen kört igenom Max Payne på min Powerbook 800 med maxupplösning och det har inte laggat en enda frame, det flyter helt otroligt ! Det är för mig den första Mac jag ägt som detta varit möjligt på, min förra iMac 800 klarade inte detta, ATI-korten i de nya bärbara är helt fantastiska. Jag väntar med spänning på min 1Ghz maskin

Men då vill ju jag veta vad du menar med "lagg"?

För mej är lagg allt under 80fps!! och de är sant

Hehe, ok, jag önskar jag kunde hjälpa dig här men jag har skeppat min Powerbook idag på förmiddagen och inväntar den nya så jag kan inte kolla fps åt dig. Tycker personligen att det är viktigare att det flyter och att spelkänslan infinner sig, vilket den verkligen gjorde

Min nya maskin verkar komma upp i 76fps i 1024x768 när man spelar Quake enligt Apple, så jag antar att jag nästan kvalar in i "icke laggar gruppen"

Inte för att jag använder min maskin till detta så ofta, men det är ett kul mått som säger en del om datorn.

Citat:

quote:Skapades ursprungligen av: Linus:

Citat:

quote:Skapades ursprungligen av: zodi:
Tack för tipset Linus, men det fungerade inte.

Då ändrar man ju i config filen, vilket jag gjort en massa nu. Det fungerara att sänka fps taket på det sättet men inte att höja. Och eftersom det fungerade förut så vet jag att min version stöder det. Kanske har något med systemet att göra så jag skall nog fråga på ett annat forum...

Har du kollat så att det verkligen är cfg´n som sänker maxfps´n, dvs att den har tex 60 i com_maxfps?

Kolla värdena i q3config.cfg, observera att det kan finnas fler än en (under osp tex).

Det var inte config filen utan en inställning i detonatorn för geforce kortet. Stängde av "vertikal synkronisering" så löste det sig. Ingen aning om vad det är bara...

  • Oregistrerad
  • 2004-11-03 13:35

Nu sitter jag med en ny PowerBook och vill testa lite Q3. När jag söker efter ett sätt att köra native upplösning på skärmen dyker min två år gamla fråga upp. Fortfarande utan fungerande lösning tyvärr. Nån som vet hur man kör Quake 3 i "rätt" upplösning om just den upplösningen inte finns med i Quake (1280x854)?

Tacksam för svar! Jag fick inte Linus lösning att fungera den här gången heller...

  • Oregistrerad
  • 2004-11-03 17:08

1. öppna q3configgen (~/Library/Application Support/Quake3/baseq3/q3config.cfg) med TextEdit (enklare än att fylla i värdena i q3 consollen)
2. se till att dessa variabler har dessa värden

seta r_mode "-1"
seta r_customwidth "1280"
seta r_customheight "854"
seta r_customaspect "1"
seta r_fullscreen "1"

3. spara och starta quake

  • Oregistrerad
  • 2004-11-03 21:39

Tack ul1984! Nu fick jag det att fungera. Det var ju faktiskt samma kod som angivits tidigare, så det måste varit jag som varit en klåpare när det gäller att mata in dessa värden tidigare. Jag kan dock inte se animationerna mellan banorna med denna upplösning. I övrigt fungerar det utmärkt och flyter på riktigt bra!

1
Bevaka tråden