Webbdelning och FTP-åtkomst via router?

Tråden skapades och har fått 17 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2006-11-06 16:37

Som jag nyss skrev i en tidigare tråd, jag och en kompis har idag fått trådlöst bredband med en zyxel router. Men när man nu ska starta t ex webdelning eller FTP-åtkomst (brukar föra över filer på det sättet från andra kompisar då det brukar va snabbaste sättet) så blir ju adressen bara min interna IPadress på intranätet. Kan man på något sätt ändra så att webbdelningen går på routern eller vad man ska säga, så att sidan verkligen kommer ut på Internet?

Du måste göra en portkoppling i routern så den vet vilken dator på insidan som är t.ex FTP-server.

  • Medlem
  • Borås
  • 2006-11-06 18:03

I routern väljer du Port Forwarding, där skriver du in den interna IP-adressen till den dator som ska agera server, samt vilken/vilka portar trafiken skall gå igenom. Sen är det bara att tuta och köra.

  • Oregistrerad
  • 2006-11-06 20:48

Hmm, det funkar inte riktigt. Jag har ställt in port forwarding på port 80 och skrivit in mitt IPnummer (192.1681.33) som "Server IP adress". Men vad sen? Adressen blir ju fortfarande http://192.168.1.33/~bootliner/ i webbdelning, och även om jag går til myip.dk och istället tar vårt IP utåt och sätter in som IP fungerar det inte. Vad är fel?

Om du ställt in rätt IP-nummer och har webbdelning igång så ska det fungera. Så det lät lite underligt att det inte gör det. Däremot kommer inte adressen i Systeminställningar att ändras oavsett vad du gör för ändringar i routern.

Exakt vad får du för felmeddelande då du försöker ansluta till ditt publika IP-nummer?

  • Oregistrerad
  • 2006-11-07 13:37

Så här ser det ut.

Har ännu en fråga nu när vi ändå är på G. Är helt ny vad gäller trådlösa routers (routers för den delen också). Ser att brandväggen är aktiverad. Kan ju t ex inte använda DC i active mode. Kan man bara stänga av brandväggen? Eller kan routern få virus då? För jag har ju aldrig använt mig av brandvägg förr på Macen när jag haft andra typer av internetanslutningar.

Det där meddelandet betyder att du kommer fram till någon server som svarar. Det är bra. I felmeddelandet nämns "RomPager Advanced Server" som vad jag förstår verkar vara en webbserver för inbäddade system (eller vad det brukar heta på svenska). Troligen har routern en webbserver, vilket i sig inte är konstigt då de flesta brukar ha det för att webbgränssnittet (där du gjorde port-inställningarna) ska fungera. Däremot ska man inte kunna nå det utifrån.

Vissa routerns har en inställning som gör att de kan nås utifrån. Logga in i webbgränssnittet till routern och se om du kan hitta den inställningen. Leta efter en inställning som brukar heta "Remote Management" och ställ in det så att det bara går att komma åt från LAN-sidan (inte WAN). Ibland finns en kryssruta där man istället helt kan stänga av remote management.

Som det är nu är det troligen så att webbservern som sköter routerns webbgränssnitt svarar på port 80 och alltså inte släpper igenom trafiken du vill dirigera om till din Mac.

  • Medlem
  • Borås
  • 2006-11-07 13:59

Ett annat problem kan vara att du blivit tilldelad en ny IP-adress av routern (vilket händer ganska ofta med trådlösa routers). Försök hitta en inställning i routern där du kan låsa din just DIN dator till en specifik IP-adress, så slipper du ändra i routern varje gång det händer.

För att snabbt kolla vad jag har för intern IP-adress för tillfället använder jag en smidig widget. Denna kan justeras för att visa antingen min externa eller interna IP-adress.

Lycka till med webdelningen!

  • Oregistrerad
  • 2006-11-07 14:07

Panik! Hittade nåt som kallades för Remote och sen nåt mer som jag nu inte kommer ihåg. Remote MRMT eller nåt liknande. Hittade som du sa, under WWW stod detn åt om port 80, och den stod på LAN & WAN. Tog disable, och nu kan jag inte komma in på routern överhuvudtaget! Får bara "Safari kan inte öppna sidan ”http://192.168.1.1/” eftersom Safari inte kunde ansluta till servern ”192.168.1.1”."

Hjälp!

Skulle det inte gå alls så är det reset som gäller. Brukar finnas en liten knapp som du ska hålla in en stund. Sen är routern fabriksinställd igen. Se din manual.
Vissa har också möjlighet att spara en config-fil från routern. Så om du måste återställa den så kan man snabbt läsa tillbaka config-filen så är man tillbaka där man var innan.

Tänk på om det är FTP du kör att det ska vara port 21 som standard.

Du kan ju också i din dator lägga din site i webbserverns root-katalog istället för den i din hem-mapp. Då slipper du använda "~användarnamn" efter din IP. Mer info om det lär du hitta här på forumet.
(tror det är /Library/WebServer/Documents/)

Oftast finns en återställningsknapp på routerns baksida som återställer routern om man håller inne den ett tag (ofta minst 10 sekunder). Då återställs alla inställningar samt inloggningen till webbgränssnittet. Notera att lösenordet ofta återställs till sitt grundläge.

Vad har routern för modellbetäckning?

BTW. Routern lär knappast få virus men istället för att stänga av brandväggen helt så öppna de portar du behöver.

  • Oregistrerad
  • 2006-11-07 14:33

Det löste sig via resetknappen som ni sa. Konstig funktion bara tycker jag.... ?

Bra. Ställ då om remote management så att det bara svarar mot LAN. Är port-inställningarna kvar i den? Annars kan du behöva fylla i dem igen.

  • Oregistrerad
  • 2006-11-08 14:45

Nu har jag gjort det. Nån som kan se om det funkar? http://89.150.149.224/~bootliner Härifrån funkar det fortfarande bara med den interna IPn... En till fråga här. Kan nån förklara vad det som står på bifogad bild betyder?

Man får en redirect till http://anders-baths-imac-g5.local/~bootliner/ vilket ju inte funkar. Kan inte svara på varför, men jag kommer ju igenom din router iaf.

  • Oregistrerad
  • 2006-11-08 16:24

Instruktioner för att konfigurera en otrolig mängd routers för att tex acceptera utifrån kommande trafik till web- (port 80) eller ftp-servrar (port 21) eller för trafik på andra portar som krävs för spel eller andra program finns på denna adress med skärmdumpar och förklaringar av termer mm:

http://www.portforward.com/

De exotiska inställningarna du pillar på i inlägg nr 15 är inte nödvändiga för att få det du beskriver att fungera och jag skulle återställa dessa till routerns defaultvärden.

1
Bevaka tråden