Hjälp! Firefox startar inte

Tråden skapades och har fått 14 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2006-10-03 22:25

Plötsligt slutade Firefox fungera.
Den studsar ett par gånger i docken när jag ska starta, men sedan händer inget.
Jag har testat att slänga ut FF, ladda hem installera senaste versionen igen men det hjälper inte. Fortfarande ett par studs och sedan borta.

Det enda utöver dagligt arbete som har hänt på sistonde är att jag avbröt en säkerhetskopiering av hårddisken, Vet inte om någon nödvändig fil gått upp i rök då eller vad som kan ha hänt?

Jag har en Macbook med Mac OS X 10.4.8

Tacksam för all hjälp. Jag saknar min lilla eldräv.

  • Medlem
  • 2006-10-03 22:35

Låter som en inställningsfil som blivit korrupt kanske.

Leta upp en .plist fil som verkar ha med Firefox att göra i /Users/anv.namn/Library/Preferences, dra ut den från mappen och testa att starta igen.

  • Oregistrerad
  • 2006-10-03 22:53

Tack för tipset, men det fungerade tyvärr inte...

  • Oregistrerad
  • 2006-10-04 09:00

Nu har jag testat att installera gamla versioner av Firefox. Det funkar med de äldsta, men från 1,5 är det kört. Det flimrar förbi en ruta där det står något om "compability updates" när jag försöker starta programmet.

Fler tips, eller är det läga att ominstallera OS X?

/mats

Ursprungligen av MatsPalats:

Nu har jag testat att installera gamla versioner av Firefox. Det funkar med de äldsta, men från 1,5 är det kört. Det flimrar förbi en ruta där det står något om "compability updates" när jag försöker starta programmet.

Fler tips, eller är det läga att ominstallera OS X?

Prova att plocka ut mappen användarnamn/Library/Application Support/Firefox och starta Firefox igen. Om den går igång kan du lägga tillbaka filen med bokmärken (bookmarks.html) och installera dina plugins på nytt (antagligen här felet ligger).

Jag har precis samma problem på min MacBook. Jag kan varken starta Flock eller Firefox så det verkar vara något problem med Gecko. Jag har raderat ~/Library/Application support/Firefox och i Preferences hittar jag inget med flock, firefox eller mozilla så det har jag nog tagit bort i ett tidigare försök. Jag har dessutom lagat file permissions men det funkar fortfarande inte. Jag börjar bli lite irriterad på det nu, finns det någon loggfil där det borde finnas mer information?

Har ni låtit den stå ett tag? Firefox är piggt på att ladda ner uppdateringar och installera dem ganska ofta, och jag tycker inte alltid att den säger till vad den håller på med.

Ikonen hoppar några gånger i Docken och sen försvinner den för att inte komma tillbaka.

  • Medlem
  • Gävle
  • 2007-03-06 13:10

Om man vill testa som det är en fil i ens eget Library så skapa en ny användare, logga in på den och prova att starta. Om Firefox startar då så vet du att det är en felaktig fil i din Librarymapp som är boven. Du kan kolla i den nya användarens mapp vilka filer det är som FF har lagt till så vet du vilka du ska ta bort.

Jag körde igång Firefox på ett nytt konto och fick följande resultat:

find . -mmin 5   
./Library/Application Support/Firefox
./Library/Application Support/Firefox/pluginreg.dat
./Library/Application Support/Firefox/Profiles/pk1ec0pk.default/bookmarkbackups
./Library/Application Support/Firefox/Profiles/pk1ec0pk.default/cert8.db
./Library/Application Support/Firefox/Profiles/pk1ec0pk.default/key3.db
./Library/Application Support/Firefox/Profiles/pk1ec0pk.default/kf.txt
./Library/Application Support/Firefox/Profiles/pk1ec0pk.default/search.sqlite
./Library/Application Support/Firefox/Profiles/pk1ec0pk.default/urlclassifier2.sqlite
./Library/Caches/Firefox/Profiles/pk1ec0pk.default
./Library/Caches/Firefox/Profiles/pk1ec0pk.default/Cache/039579ACd01
./Library/Caches/Firefox/Profiles/pk1ec0pk.default/Cache/7149A3B2d01
./Library/Caches/Firefox/Profiles/pk1ec0pk.default/Cache/9AFD3960d01
./Library/Caches/Firefox/Profiles/pk1ec0pk.default/Cache/9F6E93C0d01
./Library/Caches/Firefox/Profiles/pk1ec0pk.default/Cache/_CACHE_MAP_
./Library/Caches/Firefox/Profiles/pk1ec0pk.default/Cache/C5847E33d01
./Library/Caches/Firefox/Profiles/pk1ec0pk.default/Cache/E7AD9837d01
./Library/Caches/Firefox/Profiles/pk1ec0pk.default/XPC.mfasl
./Library/Caches/Firefox/Profiles/pk1ec0pk.default/XUL.mfasl
./Library/Preferences/com.apple.quicktime.plugin.preferences.plist
./Library/Preferences/QuickTime Preferences

Jag har rensat bort alla dessa filer på mitt konto men det funkar fortfarande inte.

Jag upptäckte att jag inte längre kan visa quicktime-filmet i Safari. Det visas bara en quicktimelogga med ett frågetecken över. Detta funkar tydligen med den nya användaren jag har skapat så problemet ligger nog i quicktime-inställningarna.

Hur jag ska lösa detta är dock ett stort frågetecken då jag har raderat alla inställningsfiler som heter något med quicktime utan att det har löst sig.

  • Medlem
  • Lund
  • 2007-03-07 16:54

Bara det inte är vad som hände när min bror skulle leka med min dator. Han stängde ner firefox med krysset, och när han sen ville använda det tryckt han på knappen och upp kommer ju firefox, men utan något fönster öppet så han trodde ju det var något fel. I det fallet var ju äpple+n den enkla lösningen ;D

  • Medlem
  • Gävle
  • 2007-03-08 10:50

Ett radikalt steg är ju att helt enkelt slänga Librarymappen och sen starta om datorn. Då nollställs ALLA dina inställningar. Tyvärr försvinner även en massa andra saker som mail och adressbok.
Alternativt, byt namn på Library starta om och flytta tillbaka dom saker som du verkligen behöver.
Jag kommer själv att göra så när jag får min nya dator.

Ursprungligen av Creops:

Ett radikalt steg är ju att helt enkelt slänga Librarymappen och sen starta om datorn. Då nollställs ALLA dina inställningar. Tyvärr försvinner även en massa andra saker som mail och adressbok.
Alternativt, byt namn på Library starta om och flytta tillbaka dom saker som du verkligen behöver.
Jag kommer själv att göra så när jag får min nya dator.

Jag funderar snart på att göra det.

Nu har jag gått bärsärkagång i min Library-katalog och tagit bort allt från ~/Library/Caches och det mesta från Preferences. Det löste problemen med Firefox och Quicktime i Safari men nu har jag ett nytt problem. Efter att ha slängt katalogen Adium (som låg i Caches) och sen hela Caches så kan jag inte få bort dem från papperskorgen. När jag går in via terminalen får jag detta mysko resultat:

mibook:~/.Trash ahlberg$ ls -l 
total 0
drwxrwxrwx    7 ahlberg  ahlberg   238 Feb 17 11:56 Adium
drwxrwxrwx   66 ahlberg  ahlberg  2244 Mar 20 21:39 Caches
mibook:~/.Trash ahlberg$ rm -rf *
rm: Adium: Directory not empty
rm: Caches: Directory not empty
mibook:~/.Trash ahlberg$ ls -la Adium/
mibook:~/.Trash ahlberg$ ls -la Caches/
mibook:~/.Trash ahlberg$ 

Katalogerna verkar vara tomma (inte ens . eller .. syns) men de går inte att radera, inte ens som root. Hur ska jag få bort dem?

1
Bevaka tråden