Matlab med OSX och X11 fungerar inte.

Tråden skapades och har fått 9 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2006-09-18 19:09

Sitter och har försökt köra matlab på min PB 12" 1,5GHz nu i ett halvår utan framgång, men nu har det kommit upp ett förslag till lösning på Mathworks supportsidor. Denna säger att man måste ha X11 1.1.1 för att kunna köra, och jag har bara X11 1.1 på min OSX installations-dvd... hittar inte 1.1.1 på nätet så nu vänder jag mig till er. Finns det alltså någon som vet med sig att dom har X11 1.1.1 och kan tänka sig att dela med sig av installationspaketet?? Skulle vara evigt tacksam...

  • Medlem
  • Täby
  • 2006-09-18 21:51

jag har 1.1 och kan köra matlab, vad har du för problem?

  • Oregistrerad
  • 2006-09-18 22:00

Problemet är att det inte startar alls. X11 körs igång och matlabikonen hoppar i dockan, första hej-fönstret kommer upp men sen inget mer. Skapas ett gäng loggfiler med en massa java-fel, exceptions och sånt, varje gång jag startar dessutom. Min teori är att det är senaste java-versionen som kanske bråkar med X11 1.1, iom vad som står på mathworks-supporten... Här är vad som står där:

Länk

Ett tillägg: de andra lösningarna på sidan ovan hjälper inte. Matlab startar i kommandoradsläge och att ta bort preferences-filen ändrade inte ett dugg.

  • Medlem
  • Täby
  • 2006-09-19 19:58

konstigt, vilken version av os X har du?, mitt matlab krashade vid en säkerhetsuppdatering, men det fixade ganska snabbt har jag för mig, du kan inte få ut någon form av felmedelande?

  • Oregistrerad
  • 2006-09-19 20:54

Jag kör senaste uppdateringen, den har väl kommit till 10.4.7 nu. De enda felmeddelanden jag får är ett gäng loggar som skapas i användarroten, jag blir inget klokare av dom iaf. Här är loggarna iaf, om det gör ngn klokare:

http://www.cyd.liu.se/~ulfal241/temp/matlab_crash_dump.11756

och

http://www.cyd.liu.se/~ulfal241/temp/java.log.11756

Jag har också problem med detta. Skulle installera Matlab på min iMac och under installation sa den att jag skulle behöva installera X11 och att man hittar det på sin Tiger-skiva. Så jag installerade X11sdk som den heter och Matlab ville inte starta.

Tidigare hade jag Matlab på min PB och det gick fint. Däremot hade jag X11user på PB:n. Så jag försökte installera den på iMacen men den ville inte och sa att jag har en nyare version på datorn. Däremot hittar jag inte den i mappen Utilities. På PB:n finns den där.

Vet inte hur jag får bort X11sdk från datorn för att kunna installera X11user. Hittar inga X11 filer när jag söker efter dem.

Bytte rubrik så kanske fler anar att det är matlab det rör sig om

  • Medlem
  • Helsingborg
  • 2006-10-31 22:39

Har exakt samma problem som trådskaparen. Om lösning hittas posta gärna här.

  • Medlem
  • Stockholm
  • 2010-03-20 00:23

Om någon får problem med matlab (kör version 2008b på osx 10.6.2) så är oftast problemet att man kör 64bitars version av java, ändra med programmet "Java-Inställningar" och se till att använda 32bitars versionen istället så skall det fungera bra. Dock är det segt att köra under osx, vissa har rapporterat bättre prestanda om den körs i windows under parallells..

Såvida du inte kör 2009b eller senare då den både finns för 32- och 64-bit. Du väljer under installationen vilken eller vilka (du kan ha båda samtidigt) som du vill installera.

1
Bevaka tråden