Varför läggs ":16080" till efter adressen?

Tråden skapades och har fått 10 svar. Det senaste inlägget skrevs .
1

Kan någon svaras på varför jag får ett tillägg efter .se med :16080 när jag publicerar till min egen xserve med hjälp av iweb?
Tusen tack för svar!!
/asa

Jag tog bort dubletttråden du gjort och förtydligade rubriken

Det är den inbyggda apache-proxyn som gör att adressen blir annorlunda.

Ursprungligen av asasun01:

Kan någon svaras på varför jag får ett tillägg efter .se med :16080 när jag publicerar till min egen xserve med hjälp av iweb?
Tusen tack för svar!!
/asa

http://www.domän.se:16080 betyder att du använder port 16080 istället för port 80 som oftast används när man surfar. Har du någon annan webtjänst igång så kanske port 80 är upptagen.

Om du har performance cache på så stäng av den om du inte behöver den. Jag körde SSL några timmar med performance cache och då fungerade inte sidorna. Då fick jag samma portnummer och det har med performance cachen att göra.

Gå in i server admin och klicka på webserver. Välj bland options -> performance cache och kryssa ur den.

I värsta fall måste du gå in i httpd_conf för den sajten och ta bort allt vad 16080 heter men det tror jag inte behövs med 10.4 och senare versioner. (bugg i 10.3 server såvitt jag minns)

  • Medlem
  • Neverland
  • 2009-04-27 08:43

Jag väcker denna tråd då även jag har problem med att :16080 automatiskt läggs till.

Ursprungligen av Björnström:

Gå in i server admin och klicka på webserver. Välj bland options ->performance cache och kryssa ur den.

I vår 10.5-server ser det lite annorlunda ut, och jag hittar ingen performace cache att kryssa ur.

Jag antar att jag ska in i Web > Settings > Modules.

Någon snäll själ får gärna guida mig rätt.

  • Medlem
  • Gävle
  • 2009-04-27 10:47

Tror inte den funktionen finns i 10.5, borttagen.

  • Medlem
  • Gävle
  • 2009-04-27 10:50

Prova att uppgradera servern till Apache 2.2, finns en knapp i Server Admin för det. Då borde du slippa det problemet.

  • Medlem
  • Neverland
  • 2009-04-27 15:05
Ursprungligen av Creops:

Prova att uppgradera servern till Apache 2.2, finns en knapp i Server Admin för det. Då borde du slippa det problemet.

Jag tackar för tipset. Tyvärr så får jag efter uppdateringsknappen ett felmeddelande som jag inte vet hur jag ska gå vidare med.

  • Medlem
  • Gävle
  • 2009-04-27 22:51

Låter som ett fet fel på din Apache.
Enda förslaget jag har är tyvärr en ominstallation av servern..

  • Medlem
  • 2009-05-12 13:56

Angående dit error, jag löste samma problem såhär:
Om man får detta error vid uppdatering:
CANNOT_TRANSLATE_ERR' while processing a command of type: 'setApacheMode

1: Se till att det fanns en sån fil här:
etc/httpd/sites/0000_any_80_.conf

Om inte döp om
0000_any_80_.conf.default
till
0000_any_80_.conf

2: Måste finnas här med annars funkar det inte,
/etc/apache2/sites/0000_any_80_.conf.default
döpte om till
/etc/apache2/sites/0000_any_80_.conf

3. Stoppa Webtjänsten

4. Kör sedan i terminalen (istället för den grafiska uppdateringen)
sudo /System/Library/ServerSetup/translateApache.rb

1
Bevaka tråden