Start av Terminal kör en automatisk cd

Tråden skapades och har fått 6 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2006-08-21 11:36

När jag startar ett terminalfönster körs ett cd. Hur blir jag av med det? Har det med setenv att göra? Jag vill som innan starta i min root. Tror det startade efter det att jag installerat Subversion (som jag inte riktigt fått grepp om).

Dessutom får jag meddelandet att "You have new mail.". Varför kommer det där och hur blir man av med det?

  • Medlem
  • Göteborg
  • 2006-08-21 13:04
Ursprungligen av palb:

När jag startar ett terminalfönster körs ett cd. Hur blir jag av med det? Har det med setenv att göra? Jag vill som innan starta i min root. Tror det startade efter det att jag installerat Subversion (som jag inte riktigt fått grepp om).

Dessutom får jag meddelandet att "You have new mail.". Varför kommer det där och hur blir man av med det?

Ändra i inställningarna (inte fönsterinställningarna) så att den istället för att köra /bin/login kör t.ex. /bin/bash vid start av ny terminal.

  • Oregistrerad
  • 2006-08-21 13:23
Ursprungligen av desh:

Ändra i inställningarna (inte fönsterinställningarna) så att den istället för att köra /bin/login kör t.ex. /bin/bash vid start av ny terminal.

Tack. Fick bort det där med mail. Men den kör fortfarande en automatisk cd. Kan det vara en symlink eller det här med setenv som gör det. Det ser ut som följer:

cd '/Users/jag/Documents/mapp_A/mapp_B/'

Något med installationen av Subversion tycker känns som orsak till felet. Kan det vara denna snutt?

svn co http://svn.subimage.com/source/substruct/site/trunk/vendor --username substruct --password substruct

  • Oregistrerad
  • 2006-08-21 14:08

Ibland sparar tydligen Terminalen den katalog man är i när man trycker "Use settings as default" eller något sånt.
Det har alltså inte med Subversion att göra, testa ta bort Terminal-plist:en (~/Library/Preferences/com.apple.Terminal.plist). Jag är lite osäker på om det här kan hjälpa, men det är värt ett försök.

  • Oregistrerad
  • 2006-08-21 14:18
Ursprungligen av ptr:

Ibland sparar tydligen Terminalen den katalog man är i när man trycker "Use settings as default" eller något sånt.
Det har alltså inte med Subversion att göra, testa ta bort Terminal-plist:en (~/Library/Preferences/com.apple.Terminal.plist). Jag är lite osäker på om det här kan hjälpa, men det är värt ett försök.

Tänkte på det själv men glömde bort det på vägen. Ska prova...

...funkade

Tack.

Förresten, då tar jag även bort min fönsterinställningar. Kan man ta bort strängen ExecutionString i Property List Editor i pref-filen? Det är där som cd ligger. Borde väl man kunna göra?

  • Oregistrerad
  • 2006-08-21 14:18

Japp, det borde gå.

  • Oregistrerad
  • 2006-08-21 14:25
Ursprungligen av ptr:

Japp, det borde gå.

Det gjorde det. Tack. (Så har man använt Property List Editor också ).

1
Bevaka tråden