Varför hänger USB-kortläsaren/filkopieringen min Mac Mini?

Tråden skapades och har fått 3 svar. Det senaste inlägget skrevs .
1

OK, jag tror att jag har grova problem med min kortläsare. Något spökar iallafall i systemet, en Mac Mini (G4 - 1,25GHz). Någon kan säkert hjälpa mig.

Så här ligger det till: har införskaffat en kortläsare för CF-/SD-kort (allt-i-ett-läsare), en i-Rocks "IR-5300". Kortläsaren är i sin tur ansluten till en D-Link 7-portars USB-hubb, modellnamn DUB-H7 (vilken är ansluten till nätadapter). CF-kortet som används är "helt vanligt", ett TwinMos 256Mb.

Procedur:
1) Ansluter kortläsaren till datorn.
2) Kortet känns igen av systemet, ikonen för minneskortet syns på skrivbordet. Allt frid å fröjd.
3) Formaterar CF-kortet med hjälp av Skivverktyg, allt frid å fröjd. Allt normalt.
4) Slänger över ett antal filer/mappar till kortet, blandade filstorlekar.
5) Filkopieringen hänger sig.

Detta inträffar intermittent (precis när som helst). Det går inte att avbryta kopieringen med kryssrutan, tvångsavsluta Finder eller resetta systemet med det fiffiga kortkommandot för omstart (vilket det nu är, det har jag glömt). Jag är därför tvungen att göra en "sudo halt -q" i Terminal. Resten av datorn fungerar alltså, men Finder/filkopieringen dör. Att bryta strömmen är därefter det enda som hjälper för att frigöra systemet..

Varför inträffar det här? Har sökt i forumet men inte funnit något liknande problem med filkopieringar och kortläsare.

Här är min teori:
Att det är det trådlösa tangentbordet och den trådlösa musen (Logitech) som ställer till det för kortläsaren. Mus och tangentbord torde (logiskt sett?) använda USB 1.1. Kan det vara TB å mus som laggar ner systemet så till den milda grad att filkopieringen hänger sig? Har provat med olika minneskort, olika märken (CF/SD). Samma sak händer på alla kort - filkopieringen går ett par procent och avbryts abrupt, intermittent.

Ska jag prova med trådbunden mus å trådbundet TB för att se om problemet försvinner? Som det är nu är varken mus eller tangentbord anslutet till hubben, utan direkt till datorn.

Om jag ansluter kortläsaren till datorn (istället för att koppla in den i USB-hubben) verkar filkopieringen fungera 100%.

Jag är medveten om att hubben använder en lägre hastighet ifall jag blandar USB 2 å USB 1.1-prylar - men inte ska kopieringen avbrytas så här? Vad är det jag har missat? Vad är det som händer? Hur löser jag det här?

EDIT: typo.

Senast redigerat 2006-08-09 11:01

Hm, allt verkar fungera när jag ansluter kortläsaren till hubben med en annan USB-kabel. Kortslutning kanske, vad vet jag? Har provat alla möjliga å omöjliga trix men detta verkar vara den mest logiska lösningen..

Av någon anledning fungerar Spotlight (!) när rätt kabel används, men lägger av när jag pluggar in den gamla. Jaja..

Att använda trådbundet tangentbord å trådbunden mus hjälpte inte, filkopieringen hängde sig på samma sätt som tidigare.

Kul när man kan gå till botten med sina problem, även om det tagit några timmar nu..

  • Medlem
  • International user
  • 2006-08-09 11:03

Du ska inte formatera minneskortet med Skivverktyg, du ska använda kameran till det.

Jo, jag vet. Provade bara olika möjligheter. (Minneskortet till PDAn formateras egentligen varken i kamera eller dator.)

Det blev emellertid inte någon skillnad på att formatera korten i kameran eller i datorn. (Har 3 kort.) Samma problem uppstod.

Men med ny kabel mellan hubb-kortläsare verkar datorn däremot fungera som det/den ska.. Å det är ju bra!

1
Bevaka tråden