Vilken version av Mac OS X ska man stödja?

Tråden skapades och har fått 12 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2006-07-02 22:07

Jag är på väg att släppa en mjukvara för Mac och idag har jag stöd för 10.3 för PowerPC och 10.4 för Intel-maskiner. Men det hade varit betydligt enklare om man kunde kräva 10.3.9 för PowerPC, eftersom då kan man använda sig av gcc 4 - är detta rimligt eller sitter folk på äldre versioner av 10.3?

  • Medlem
  • International user
  • 2006-07-02 22:58

Jag tror att de flesta försöker hålla sig uppdaterade till den senaste versionen av OS X.

Det beror ju på vad för programvara det handlar om. Är den värd en ev. uppgradering? Är den riktad mot personer som kan tänkas använda en äldre version än 10.3.9?

  • Medlem
  • Sollentuna
  • 2006-07-03 09:52

Skilj på förutsättningar för utvecklare respektive användare. Att kunna använda sig av gcc4 vet inte en användare - och vilka nya features kommer du åt med gcc4 som inte gcc3 har? Du ger inte hela bilden för en korrekt bedömning.

  • Oregistrerad
  • 2006-07-03 10:58

gcc 4 krävs för att kompilera för Intel, så nu måste alla komponenter byggas med både gcc 3 och gcc 4, och det innebär lite mer jobb när man optimerar kompileringsflaggorna. Annars hade gcc 3 räckt mer än väl. Mac OS X 10.3 krävs för jag använder ett API i IOKit som inte fanns tidigare, och det blir väldigt komplext att lösa det utan detta API.

Min egentliga fråga är om man fortfarande kör 10.3, finns det någon som helst anledning att inte uppgradera till 10.3.9. Om inte kan jag ju lika bra kräva 10.3.9 och bara köra gcc 4.

  • Medlem
  • Stockholm
  • 2006-07-03 13:13

Känns ju som att har man 10.3 så borde man ju uppgradera till 10.3.9, Det är ju helt gratis och enkelt att ladda ner.

  • Medlem
  • Stockholm
  • 2006-07-07 03:39
Ursprungligen av Bridell:

Känns ju som att har man 10.3 så borde man ju uppgradera till 10.3.9, Det är ju helt gratis och enkelt att ladda ner.

Många har inte bandbredd nog att ladda ner så stora filer.

Dessutom har "den vanlige användaren" enligt min erfarenhet alltid en stor fobi för att installera uppdateringar när de kommer upp. De flesta klickar snabbt bort Programuppdatering så fort den visar sig och tycker bara att den stör jättemycket och/eller tror att det är väldigt svårt och att det blir massor av strul om man uppdaterar.

Detta är alltså bara två vanliga anledningar till att man inte har uppdaterat systemet. I själva frågan här håller jag med irrelogical.

Ursprungligen av Rajje:

Många har inte bandbredd nog att ladda ner så stora filer.

Jag var tvungen att kolla datumet på din post, så jag inte läste en flera år gammal tråd. Menar du verkligen att det fortfarande är "många" som använder modem som enda uppkoppling mot internet?

  • Medlem
  • Simrishamn
  • 2006-07-07 00:08

Du kan alltid kräva senaste uppdateringen inom en 10.x. Dessutom ska man egentligen itne vara rädd för att slopa kompabilitet med äldre versioner, Apple släpper mycket användbar teknologi, som verkligen kan göra det värt att ha den senaste 10.x för att köra.

Det viktigaste är att stödja 10.3 alls. Den kommer att hänga kvar ett bra tag, eftersom Tiger kräver betydligt mer minne (och i min erfarenhet fungerar sämre om man har minne i underkant). Då tycker jag att det är ganska rimligt att kräva 10.3.9. Det är ett rimligt krav.

Jag utvecklade länge med mycket hårda krav på bakåtkompatibilitet, men min utvärdering av det arbetet är att det inte gav så mycket. Det är ändå mest till nya datorer det köps program. Den största medaljen var att mina program fungerade bättre i Mac-emulatorer än andras, men det tjänar man knappast pengar på.

  • Oregistrerad
  • 2006-07-07 13:22

Jag har nu fått rätt på alla kompileringsflaggor och inställningar i Xcode för att kompilera mina Universal Binaries med gcc4 för Intel och gcc3 för PowerPC och det var betydligt mera smärtfritt än jag trott. Så länge det inte innebär mer problem än så kommer jag att stödja alla 10.3 versionerna, men blir det krångligare tycker jag givetvis att min produkt är värd en uppgradering till 10.3.9 :).

Nu verkar du ha hittat en lösning men i alla fall: Om du stödjer 10.3 och distribuerar via webben kanske 10.3.9 vore bäst då det pushar användare att faktiskt uppdatera sitt OS. Det är gratis och ger säkerhet och funktionalitet. Bra vana helt enkelt! Om de kan ladda ner ditt program kan de nog uppdatera sitt OS också.

  • Medlem
  • Mölndal
  • 2006-07-13 15:42

"Många" är de väl inte, men de finns nog. Man får väl fundera på vilken målgrupp man har. Å andra känns kombinationen Mac OS X 10.3.9 och enbart modem inte jättetrolig.

1
Bevaka tråden