Apple ställer högre säkerhetskrav på apputvecklare

Från och med nästa år kommer Apple kräva att utvecklare använder ATS i sina appar. Detta för att öka säkerheten för användare och skydda deras information.

ATS, eller App Transport Security, är en säkerhetsfunktion som introducerades för appar i IOS 9 och tvingar dessa att koppla upp sig till webbtjänster genom en säker uppkoppling. #Apple meddelar under årets WWDC-konferens att det kommer bli obligatoriskt för utvecklare att implementera detta från och med nästa år.

Mer konkret innebär denna ändring att den data som skickas gör det över HTTPS istället för HTTP. Detta innebär en stor förbättring när det kommer till säkerheten då datan krypteras och skickas över en säker uppkoppling.

ATS är aktiverat som standard i IOS 9, men utvecklare kan stänga av funktionen. Detta kommer alltså inte längre vara ett val, då Apple från och med 1 januari 2017 kommer kräva att alla appar som läggs upp på App Store använder sig av ATS.

Kommentarer
3 svar

En viktig milstolpe för strömmande musiktjänster har nåtts, då antalet betalande användare nu är fler än för videotjänsten Netflix.

Raspberry Pi släpper en uppdaterad version av Computer Module, en liten dator särskilt avsedd för industrianvändning och avancerade projekt.

En välrenommerad analytiker förutspår uppdaterade Macbook Pro-modeller under året, med stöd för mer primärminne och för vissa modeller med lägre priser.

Betaversionen av Mac OS 10.12.3 gör det lättare för användare att se hur mycket ström bildskärmen drar, och kan snabbt sänka ljusstyrkan.

Bamse ska hjälpa barn att vara källkritiska på nätet i kommande nummer.

En omfattande mutskandal har uppdagats i Sydkorea där presidenten riskerar riksrätt. Nu kan domstolen utfärda en häktningsorder mot Jay Y Lee, landets rikaste man som i praktiken styr jättekoncernen Samsung.